URGENT: EVENT & TAG Commands Fails

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

URGENT: EVENT & TAG Commands Fails

by viking on Thu Oct 15, 2015 1:06 pm

I have an account to which I need to log in (so it doesn't help to post the URL here).

In the past, I have used the recorded EVENT command to enter a credit card number into a form w/o any issues. However, it appears that within the last month, they have now changed the form so that the EVENT command no longer works (I also tried to rerecord it):
Code: Select all
EVENTS TYPE=KEYPRESS SELECTOR="#cardNumber" CHARS="XXXXXXXXXXXXX525"
(I replaced the first 13 characters of the credit card with Xs)

When I previously run this command (last time 1 month ago), the credit card numbers populated the field and it was recognized as a Visa credit card. Now the field is blank and I get an error "Please enter your card number."

I previously had problems with the recorded TAG Command (the numbers were entered, but I got the same error "Please enter your card number." Anyway, I tried it again:
Code: Select all
TAG POS=1 TYPE=INPUT:NUMBER FORM=ID:amountForm ATTR=ID:cardNumber CONTENT=XXXXXXXXXXXXX525
Now something weird happens; the card number is "rounded up" from XXXXXXXXXXXXX525 to XXXXXXXXXXXXX530 (if I use XXXXXXXXXXXXX524, it is instead rounded down to XXXXXXXXXXXXX520) and, of course, I get an error because the number is incorrect: "Sorry, we only accept the payments from MasterCard, Visa, Discover Card and American Express."

Note that in IE, I don't get this strange "rounding" error, but I still get the same error "Sorry, we only accept the payments from MasterCard, Visa, Discover Card and American Express." I can "fix it" in IE by manually placing the cursor after the last digit, hitting the space button and then manually go to the next field (e.g. using Tab). The card is then recognized as a Visa Card.

In any case, I need to use Firefox rather than IE since I need to use a javascript for the complete script.

How can I troubleshoot this issue or does anyone have any idea how to enter the credit card numbers into the field and have them recognized?

iMacros v. 8.9.4 (also tried 8.9.2.1-signed)
WIn7 Ultimate 64 bit
Firefox 40.0.3

EDIT: I used Firebug | Inspect Element | Copy Outer Element, and got:
Code: Select all
<input class="span8 text_input error" autocomplete="off" name="creditCardInfo.cardNumber" id="cardNumber" data-no-error-scroll="true" value="" type="number">
I am not experienced with Firebug but maybe this helps in trying to understand what is going on?
viking
 
Posts: 206
Joined: Sun Mar 16, 2008 12:22 am

Re: URGENT: EVENT & TAG Commands Fails

by chivracq on Thu Oct 15, 2015 2:26 pm

viking wrote:I have an account to which I need to log in (so it doesn't help to post the URL here).

In the past, I have used the recorded EVENT command to enter a credit card number into a form w/o any issues. However, it appears that within the last month, they have now changed the form so that the EVENT command no longer works (I also tried to rerecord it):
Code: Select all
EVENTS TYPE=KEYPRESS SELECTOR="#cardNumber" CHARS="XXXXXXXXXXXXX525"
(I replaced the first 13 characters of the credit card with Xs)

When I previously run this command (last time 1 month ago), the credit card numbers populated the field and it was recognized as a Visa credit card. Now the field is blank and I get an error "Please enter your card number."

I previously had problems with the recorded TAG Command (the numbers were entered, but I got the same error "Please enter your card number." Anyway, I tried it again:
Code: Select all
TAG POS=1 TYPE=INPUT:NUMBER FORM=ID:amountForm ATTR=ID:cardNumber CONTENT=XXXXXXXXXXXXX525
Now something weird happens; the card number is "rounded up" from XXXXXXXXXXXXX525 to XXXXXXXXXXXXX530 (if I use XXXXXXXXXXXXX524, it is instead rounded down to XXXXXXXXXXXXX520) and, of course, I get an error because the number is incorrect: "Sorry, we only accept the payments from MasterCard, Visa, Discover Card and American Express."

Note that in IE, I don't get this strange "rounding" error, but I still get the same error "Sorry, we only accept the payments from MasterCard, Visa, Discover Card and American Express." I can "fix it" in IE by manually placing the cursor after the last digit, hitting the space button and then manually go to the next field (e.g. using Tab). The card is then recognized as a Visa Card.

In any case, I need to use Firefox rather than IE since I need to use a javascript for the complete script.

How can I troubleshoot this issue or does anyone have any idea how to enter the credit card numbers into the field and have them recognized?

Code: Select all
iMacros v. 8.9.4 (also tried 8.9.2.1-signed)
WIn7 Ultimate 64 bit
Firefox 40.0.3


EDIT: I used Firebug | Inspect Element | Copy Outer Element, and got:
Code: Select all
<input class="span8 text_input error" autocomplete="off" name="creditCardInfo.cardNumber" id="cardNumber" data-no-error-scroll="true" value="" type="number">
I am not experienced with Firebug but maybe this helps in trying to understand what is going on?

Hum, difficult to help you directly without being able to play with the Page myself, but OK, I would have a few ideas...

The EVENT Mode should work indeed, but there are still a few things you can do/try with the EVENT Mode (and/or the TAG Mode)...:
- For both Modes, you could try putting your Credit Card Number into a Variable and use it directly for 'CONTENT' or 'CHARS'.
- Using 'EVAL()', force this Variable to become a String (using 'toString()' or 'toLocaleString()') or a Number (using 'parseInt()') before using it for 'CONTENT' or 'CHARS'.
- Once the INPUT Field has been filled in (either Mode), get out of it (EVENT Mode) with the Mouse or a Keyboard 'Tab', then come back into it (Mouse or 'Tab' if your previous Click was "by chance" on the previous Element in the Tab Sequence) and add the Actions that work on IE, using 'Arrow' (x16) or the 'End' Key, or 'Ctrl^End' (only 'End' will get recorded, you need to add manually "MODIFIERS="ctrl"" at the end of your Statement), add a 'Space' and an 'ENTER' Key.

You could upload a (zipped) HTML Saveas of your Page, the Script responsible for the Credit Card Validation will probably be on some Public Site so I could give it a try... (I should still have somewhere some valid Credit Card Test Numbers meant for Testing, at least for Visa and MasterCard..., and I think I even remember a few from the top of my head, from some previous Life...! :oops: )

Oh..., and in the worst case, I would most probably be able to convert your .js Script to a "pure" .iim Script so that you can use it on IE... (But I wouldn't do that for everybody on this Forum, only because you are / have been for a long time a valuable Helper on the Forum... 8) ))
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: URGENT: EVENT & TAG Commands Fails

by viking on Thu Oct 15, 2015 4:07 pm

@chivracq ,
Can I Message or E-mail you the saved html file?
BTW, I do not see a way to send a private message using this forum..?
viking
 
Posts: 206
Joined: Sun Mar 16, 2008 12:22 am

Re: URGENT: EVENT & TAG Commands Fails

by chivracq on Thu Oct 15, 2015 5:05 pm

viking wrote:@chivracq ,
Can I Message or E-mail you the saved html file?
BTW, I do not see a way to send a private message using this forum..?

No, PM is disabled on the Forum...

Yep, you can reach me directly per Mail: [My_Pseudo_on_the_Forum]@gmail.com.

Hum, and to manage your Expectations, I should have a bit of time tomorrow during the day to have a quick look at your Page and see if I can hopefully find some quick Solution, but it's some funny long WE in Amsterdam (started yesterday already) with some big-big Dance Event for 5 days (ADE) and I'm involved as a DJ, so it is a very busy WE for me, with People coming from all over the World to Amsterdam for this huge Event... Most of the best World DJ's come from Holland... I've got People/Friends staying at my place since the beginning of the week, tonight I'm expecting any minute a whole Punk Band from Finland or Hungaria...! But I guess they will sleep until late... :shock: :oops:
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: URGENT: EVENT & TAG Commands Fails

by viking on Fri Oct 16, 2015 1:31 am

Wow, sounds like a great event. Wish that I could be there!
I feel a little bit bad asking you for help when you have so much more fun stuff that you could do this weekend!

Anyway, I E-mailed you the web page and demo scripts. Please look at it if you have a chance.

1,000,000 THANKS!

EDIT: I tried your suggestions above, but have the same issue; I cannot get the (correct) card numbers into the field: TAG => Wrong Numbers; EVENT => Blank
viking
 
Posts: 206
Joined: Sun Mar 16, 2008 12:22 am

Re: URGENT: EVENT & TAG Commands Fails

by chivracq on Sun Oct 18, 2015 3:16 pm

viking wrote:Wow, sounds like a great event. Wish that I could be there!
I feel a little bit bad asking you for help when you have so much more fun stuff that you could do this weekend!

Anyway, I E-mailed you the web page and demo scripts. Please look at it if you have a chance.

1,000,000 THANKS!

EDIT: I tried your suggestions above, but have the same issue; I cannot get the (correct) card numbers into the field: TAG => Wrong Numbers; EVENT => Blank

OK, I received your Mail with the Full HTML Saveas of the Page on Friday already and I had a look at it directly and on Saturday as well a bit, and hum..., I get some strange Results...

I first tested on my Default Browser which is the one I use for all my own Scripts:
Pale Moon v24.6.2 (=FF31), iMacros v8.8.2, Win7-x64.
In this Environment, both your EVENT and TAG Scripts work fine!!
By using Hard Coded Values or Variables with malformed Content (with extra Spaces or Letters), same if I enter the Credit Card manually on the Page, the only Validation I get on that Field is the "Number" Type like you mentioned in the Firebug Info, any Not Number Input clears the Field automatically upon clicking away from the Field. The only "thing" Not Number which is accepted is if there is a Leading Space like in " xxx525" (xxx being 13 Digists).
I don't get any Rounding and I never got the Validation Error that you mentioned about "The only Credit Cards accepted are... etc".

I then tested on "plain" Firefox using:
iMacros for FF v8.9.4, FF41 (v41.0.1), Win7-x64.
In this Environment, I can reproduce your Results...!
- Using the EVENT Mode, nothing gets filled in the Field. It just does nothing.
- Using (your Script with) the TAG Mode, the Field is filled in and indeed, I get the Rounding with "xxx525" becoming automatically "xxx530" or "xxx524" becoming "xxx520". I can use Letters as well in the Credit Card Number, they are accepted, there is no Validation at all. But I get the same Results if I fill in the Field manually, without using iMacros at all. So the Problem looks to me like it is coming from FF41 which doesn't seem to be able to handle this "Number" Type Field.

I noticed there was an Update v41.0.2 to FF41 and I wanted to install it but I didn't come that far.
But the Pb sounds to me like it is related to FF41 itself and not really to iMacros, so you could try updating FF41 to FF41.0.2 as well (if you haven't already), or maybe after even to a later Beta FF42 or FF43 to see if you still get the Pb (and cross your fingers that iMacros v8.9.4 still works a bit correctly, since around FF29, nearly each new FF Version has broken stg in iMacros for FF...!), checking the Mozilla Forum might confirm those Results, if this "Number" Type is not handled correctly by FF41, some other Users must have reported it already...
Reverting to a previous Version of FF might be a (Temporary) Workaround until there is a Version of FF that works fine, if the Pb does come from FF41, it shouldn't take long until it is solved.

Installing Pale Moon (which works in parallel to FF) can be a good Alternative as well, PM is 3 times more efficient and reliable than "pure" FF anyway, I don't use it for nothing rather than FF...
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: URGENT: EVENT & TAG Commands Fails

by viking on Sun Oct 18, 2015 7:16 pm

chivracq wrote:I then tested on "plain" Firefox using:
iMacros for FF v8.9.4, FF41 (v41.0.1), Win7-x64.
In this Environment, I can reproduce your Results...!
- Using the EVENT Mode, nothing gets filled in the Field. It just does nothing.
- Using (your Script with) the TAG Mode, the Field is filled in and indeed, I get the Rounding with "xxx525" becoming automatically "xxx530" or "xxx524" becoming "xxx520". I can use Letters as well in the Credit Card Number, they are accepted, there is no Validation at all. But I get the same Results if I fill in the Field manually, without using iMacros at all. So the Problem looks to me like it is coming from FF41 which doesn't seem to be able to handle this "Number" Type Field.
Thank you so much for testing! I hope that you had a fun weekend otherwise :) !

I am actually using FF 40.0.3, iMacros 8.9.4 and WIN 7 -64 bit.
I get different results when I enter the card manually, e.g. "1111111111111525". In this case FF does not round the number; only when I use iMacros and the TAG command. Thus, at least with FF40, the problem seems to be with iMacros (or its compatibility with FF40).

I think that I will try Pale Moon. Do you use the 32 or 64 bit version? Can both be installed simultaneously?

p.s. The credit card validation does not work with the saved html page; only when connected live. I assume that the verification takes place on the the provider's server (after logging in)
viking
 
Posts: 206
Joined: Sun Mar 16, 2008 12:22 am

Re: URGENT: EVENT & TAG Commands Fails

by Tom, Tech Support on Mon Oct 19, 2015 6:25 am

Hi viking,

I tested your macros and confirmed the issue with the following:

iMacros 8.9.4 and Firefox 41.0.2
iMacros 8.9.2 and Firefox 40.0.2
iMacros 8.9.2 and Firefox 39
iMacros 8.9.2 and Firefox 38.0.1

Entering the value into the field manually works correctly.

Playing the macros with the iMacros Browser also fills the field correctly as expected (using both TAG and EVENT in iMacros 11).
Playing the EVENT macro with iMacros 11 for IE does not work however.

I have logged this for further investigation by the development team, but since it does not yet seem to be a general issue and is more specific to this page/site, I would not expect a resolution any time soon necessarily.
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: URGENT: EVENT & TAG Commands Fails

by viking on Mon Oct 19, 2015 1:47 pm

chivracq wrote:I first tested on my Default Browser which is the one I use for all my own Scripts:
Pale Moon v24.6.2 (=FF31), iMacros v8.8.2, Win7-x64.
In this Environment, both your EVENT and TAG Scripts work fine!!

I tried the latest version of Pale Moon, which is v25.7.3 (I used x86 & portable). I next tried to install iMacros using the versions page: https://addons.mozilla.org/en-US/firefox/addon/imacros-for-firefox/versions/
That page recognized Pale Moon as FF24.9, not FF31 (or higher). How did you determine that Pale Moon v24.6.2 =FF31?

Thus, the latest compatible iMacros version is v8.8.7.1. Unfortunately, that version didn't work at all; nothing gets filled in when using TAG or EVENT. Maybe because, according to the release notes for the next version, "- TAG command fails since the FRAME number is not set to 0"? The version before that, v8.8.5.1 seemed to have some other issue "Fixed: Some strange freeze issue in V8.8.5 (sorry about that)", so I skipped that version. Thus, I went down the list to the next version: v8.8.2.1 (which is what you have?).

Lo and behold, that combination worked: Pale Moon v25.7.3 (x86, portable)+ iMacros v8.8.2.1 + WIN7 64 bit.
Both TAG and EVENT worked on the saved html page!


However, only the EVENT command worked on the live webpage (when trying to verify the credit card). This is also what I had observed previously and was the reason for using EVENT rather than TAG in the past.
viking
 
Posts: 206
Joined: Sun Mar 16, 2008 12:22 am

Re: URGENT: EVENT & TAG Commands Fails

by viking on Mon Oct 19, 2015 1:54 pm

Tom, Tech Support wrote:Hi viking,

I tested your macros and confirmed the issue with the following:

iMacros 8.9.4 and Firefox 41.0.2
iMacros 8.9.2 and Firefox 40.0.2
iMacros 8.9.2 and Firefox 39
iMacros 8.9.2 and Firefox 38.0.1

Entering the value into the field manually works correctly.

Playing the macros with the iMacros Browser also fills the field correctly as expected (using both TAG and EVENT in iMacros 11).
Playing the EVENT macro with iMacros 11 for IE does not work however.

I have logged this for further investigation by the development team, but since it does not yet seem to be a general issue and is more specific to this page/site, I would not expect a resolution any time soon necessarily.

Hi Tom,

If I have an issue, I am sure that someone else also have or will have an issue...It would be good to have this fixed so that I can continue using Firefox. Otherwise, I guess that I will need to start using Pale Moon instead of Firefox.
If so, can iMacros be made compatible with older version of Firefox (e.g. v.24.9) so that the latest version of iMacros works with Pale Moon?
viking
 
Posts: 206
Joined: Sun Mar 16, 2008 12:22 am

Re: URGENT: EVENT & TAG Commands Fails

by chivracq on Mon Oct 19, 2015 10:54 pm

Interesting Post, I like it...! :D
(And it's nice to "explore" an Issue with you, you have a very consistent Mindset... (Meant as a compliment...! :oops: ))

OK, I'll try to reply consequently...

viking wrote:
chivracq wrote:I first tested on my Default Browser which is the one I use for all my own Scripts:
Pale Moon v24.6.2 (=FF31), iMacros v8.8.2, Win7-x64.
In this Environment, both your EVENT and TAG Scripts work fine!!

I tried the latest version of Pale Moon, which is v25.7.3 (I used x86 & portable). I next tried to install iMacros using the versions page: https://addons.mozilla.org/en-US/firefox/addon/imacros-for-firefox/versions/
That page recognized Pale Moon as FF24.9, not FF31 (or higher). How did you determine that Pale Moon v24.6.2 =FF31?

You asked me previously if I was using the x32 or x64 Version of PM... => x32.
My FCI is: iMacros for FF v8.8.2 (VERSION BUILD=8820413 RECORDER=FX), PM v24.6.2-x32, Win7-x64.

Yep, I know PM v24.x is forked on FF24, but PM v24.6.2 was the Version that came around when FF31 came and included all Security Fixes like in FF31, about 1 year ago maybe now, and oops-wow!!, FF31 => FF41...!, ridiculous...!, and CR went from 2 Version Numbers ahead to 5 Version Numbers ahead, it's a bit sad to see that Bullshit 99 Marketing Strategy has taken over the Development for Software... :shock: :roll: :oops:
After PM v24.6.2, I did try to update PM to some later Version when it came out, but I had a Pb at that time and couldn't do so, then PM25 came out, and I knew that some Changes in FF from FF29 I think forced iMacros v8.8.2 to update to v8.8.3 which was not compatible anymore with PM24, so I stuck to v8.8.2 and PM24, even when PM25 came out..., I know my Config works fine, so I stick to it..., until some very incentive New Functionality in iMacros for FF will force me to update and to find some other Stable Config (using PM, or SeaMonkey, or whatever, plain FF is a bit useless for me since 1 or 2 years...), and if I can't, I will simply add myself the new Functionality to "my" Stable Version, I've already done it, I can customize it again...
I'm a bit surprised nearly to see that PM25 is still forked on FF24...

viking wrote:Thus, the latest compatible iMacros version is v8.8.7.1. Unfortunately, that version didn't work at all; nothing gets filled in when using TAG or EVENT. Maybe because, according to the release notes for the next version, "- TAG command fails since the FRAME number is not set to 0"? The version before that, v8.8.5.1 seemed to have some other issue "Fixed: Some strange freeze issue in V8.8.5 (sorry about that)", so I skipped that version. Thus, I went down the list to the next version: v8.8.2.1 (which is what you have?).

Hum, I always say "iMacros for FF v8.8.2" and iMacros says "VERSION BUILD=8820413 RECORDER=FX", so I'm not sure if we are talking about exactly the same Version...

viking wrote:Lo and behold, that combination worked: Pale Moon v25.7.3 (x86, portable)+ iMacros v8.8.2.1 + WIN7 64 bit.
Both TAG and EVENT worked on the saved html page!

Like I said, if v8.8.2 = v8.8.2.1...

But I will give a try to PM25..., I suspected that iMacros for FF v8.8.2 would as well still be the last Version to work on PM25, but I never tested it myself, you are the first to confirm that...

viking wrote:However, only the EVENT command worked on the live webpage (when trying to verify the credit card). This is also what I had observed previously and was the reason for using EVENT rather than TAG in the past.

OK, I couldn't test that part as only the "Number" Type on the HTML Element forced some Validation Offline...

viking wrote:
Tom, Tech Support wrote:Hi viking,

I tested your macros and confirmed the issue with the following:

iMacros 8.9.4 and Firefox 41.0.2
iMacros 8.9.2 and Firefox 40.0.2
iMacros 8.9.2 and Firefox 39
iMacros 8.9.2 and Firefox 38.0.1

Entering the value into the field manually works correctly.

Playing the macros with the iMacros Browser also fills the field correctly as expected (using both TAG and EVENT in iMacros 11).
Playing the EVENT macro with iMacros 11 for IE does not work however.

I have logged this for further investigation by the development team, but since it does not yet seem to be a general issue and is more specific to this page/site, I would not expect a resolution any time soon necessarily.

Hi Tom,

If I have an issue, I am sure that someone else also have or will have an issue...It would be good to have this fixed so that I can continue using Firefox. Otherwise, I guess that I will need to start using Pale Moon instead of Firefox.
If so, can iMacros be made compatible with older version of Firefox (e.g. v.24.9) so that the latest version of iMacros works with Pale Moon?

Yep, I couldn't agree more, but I've already mentioned it several times, and I don't think I recall getting any Acknowledgement from TechSupport... (I didn't insist too much either as I currently have a perfectly working Solution with my Current Config, and I think I must be the only one using that Config, so I knew I wouldn't make any chance... And I always find a "Creative Solution" myself when I encounter a Pb, if I find a Bug, I report it but I don't wait for it to be solved in some hypothetical next Release, I always find a Workaround... In the Thread about the EVENT Mode that you bumped for example, I reported several very Blocking Issues now maybe 2 years ago and I didn't see any single one resolved (if I'm correct...), but I've found (Creative :oops: ) Workarounds for all of them...)
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: URGENT: EVENT & TAG Commands Fails

by Tom, Tech Support on Wed Oct 21, 2015 5:40 am

viking wrote:Hi Tom,

If I have an issue, I am sure that someone else also have or will have an issue...It would be good to have this fixed so that I can continue using Firefox. Otherwise, I guess that I will need to start using Pale Moon instead of Firefox.
If so, can iMacros be made compatible with older version of Firefox (e.g. v.24.9) so that the latest version of iMacros works with Pale Moon?

Like I mentioned previously, the issue has been logged for development. Unfortunately it's not up to me alone to set the priority on how soon issues get fixed. I know that the main focus for iMacros for Firefox right now has been developing a new version that will be compatible with the multi-process version of Firefox coming soon. This has been a significant undertaking that required almost a complete rewrite of the iMacros add-on.

So unless we start getting tons of complaints about the TAG command rounding numbers or the EVENT command not working on many sites, these issues are likely to remain unresolved for awhile. But I could be wrong, and if/when the status changes, I'll let you know here!
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am


Return to iMacros for Firefox

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 8 guests

-->