⛔★ Website not accepting iMacro to press SUBMIT button??

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

⛔★ Website not accepting iMacro to press SUBMIT button??

by myima on Fri Jan 08, 2016 3:32 am

Hey guys I made a Firefox iMacro for a website which posts comments but the website is not allowing iMacro to click the "SUBMIT" button.

iMacro writes the comment in the comment field just fine but can't post it. I did notice that if I personally click on the comment field first and then run the script it then works, but unless I click on the comment field first, it doesn't work.

Anyone have any idea why this is? Website in question is: cardomain.com. You can click on anyones car and at the bottom you can leave a comment.

.
myima
 
Posts: 8
Joined: Fri Jan 08, 2016 2:51 am

Re: ⛔★ Website not accepting iMacro to press SUBMIT button??

by Cobra99 on Sat Jan 16, 2016 6:55 pm

Try experimental recording mode. Or if ENTER works as submit button add it to your macro
VERSION BUILD=8820413 RECORDER=FX, WIN7 64-bit SK, Pale Moon 25.8.1(x86)
FCIM here http://forum.imacros.net/viewtopic.php?f=20&t=3331
Cobra99
 
Posts: 64
Joined: Wed Dec 24, 2014 5:17 pm

Re: ⛔★ Website not accepting iMacro to press SUBMIT button??

by chivracq on Thu Aug 24, 2017 7:17 pm

myima wrote:Hey guys I made a Firefox iMacro for a website which posts comments but the website is not allowing iMacro to click the "SUBMIT" button.

iMacro writes the comment in the comment field just fine but can't post it. I did notice that if I personally click on the comment field first and then run the script it then works, but unless I click on the comment field first, it doesn't work.

Anyone have any idea why this is? Website in question is: cardomain.com. You can click on anyones car and at the bottom you can leave a comment..

Cobra99 wrote:Try experimental recording mode. Or if ENTER works as submit button add it to your macro

:wink:
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6481
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: ⛔★ Website not accepting iMacro to press SUBMIT button??

by myima on Thu Aug 24, 2017 8:40 pm

Sorry guys didn't get notifications and totally forgot where I posted this question.

Yes the experimental method definitely works for this issue so thanks :)
myima
 
Posts: 8
Joined: Fri Jan 08, 2016 2:51 am


Return to iMacros for Firefox

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 13 guests

-->