iimOpen set to false will still open a new browser

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

iimOpen set to false will still open a new browser

by suanchieh on Sun Sep 18, 2016 10:38 pm

I am using php to call imacros use the existing firefox profile browser, but the first time it runs, when there is non firefox browser open, it will open a new browser and using it to run the macros, but the second time it runs, it will still open up a blank page firefox and use back the old browser to do its job.

How can I avoid to open a new firefox

This is my code:
Code: Select all
$iim1 = new COM("imacros")
$s = $iim1->iimOpen('-fx -fxProfile test1', FALSE);
$s = $iim1->iimSet('url',$url);
$s = $iim1->iimSet("username", $username);
$s = $iim1->iimSet("password", $password);
$s = $iim1->iimPlay("Test\Login");
suanchieh
 
Posts: 1
Joined: Sun Sep 18, 2016 10:27 pm

Return to iMacros for Firefox

Who is online

Users browsing this forum: Bing [Bot] and 14 guests

-->