Tutorial doesn't work - gives Error 921

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

Tutorial doesn't work - gives Error 921

by mildlyodd on Tue Oct 04, 2016 6:50 am

Hi
I've completely new to iMacro. I have watched some tutorials here: http://imacros.net/support/resources#prettyPhoto, then downloaded the add-on and am trying to replicate the tutorials.

This tutorial, relating to Amazon and linked from the above page, seems ok: http://www.youtube.com/watch?v=7LSDB5XszYw
This one, shown as Tutorial 2 from the above page and relating to Skyscanner.com, doesn't do what it says in the video and gives an error message: https://vimeo.com/127344574

I would like to know what I need to do to achieve even this most basic level of functionality.

Error message
----------------------
element SPAN specified by TXT:United<SP>States was not found, line: 5 (Error code: -921)


Symptoms
----------------
I followed the instructions exactly as the video, I used the same target website, Skyscanner, even down to the same reliance on auto-complete in the Start and Destination boxes. The website design has changed since the video was recorded and the target redirects from Skysanner.com to Skyscanner.net, but iMacro still have the video up, so I think that means they think it should still work.

In the video it says to record the macro, stop, navigate away from the page and then re-run the macro. What happens is that the macro returns to the skyscanner website but doesn't fill in the search boxes and doesn't set the search going.

Other context Information:
===============
iMacros for Firefox 9.03 on Firefox 48 on Linux Mint 17.3 Cinnamon

Code generated by iMacro:
============
Code: Select all
VERSION BUILD=9030808 RECORDER=FX
TAB T=1
URL GOTO=https://www.skyscanner.net/
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:NoFormName ATTR=* CONTENT=San<SP>Fran
TAG POS=1 TYPE=SPAN ATTR=TXT:United<SP>States
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:NoFormName ATTR=* CONTENT=San<SP>Francisco<SP>International,<SP>CA<SP>(SFO)
TAG POS=2 TYPE=INPUT:TEXT FORM=NAME:NoFormName ATTR=* CONTENT=Bos
TAG POS=1 TYPE=SPAN ATTR=TXT:United<SP>States
TAG POS=2 TYPE=INPUT:TEXT FORM=NAME:NoFormName ATTR=* CONTENT=Boston<SP>Logan<SP>International,<SP>MA<SP>(BOS)
TAG POS=1 TYPE=LABEL FORM=NAME:NoFormName ATTR=TXT:One<SP>way
TAG POS=2 TYPE=INPUT:RADIO FORM=NAME:NoFormName ATTR=NAME:trip-type
TAG POS=1 TYPE=BUTTON FORM=NAME:NoFormName ATTR=TXT:2<SP>travellers,<SP>Economy
TAG POS=1 TYPE=BUTTON ATTR=TXT:−
TAG POS=1 TYPE=SECTION ATTR=TXT:From<SP>San<SP>Fran<SP>Add<SP>nearby<SP>airports<SP>Click*
TAG POS=1 TYPE=BUTTON FORM=NAME:NoFormName ATTR=TXT:Search<SP>flights
mildlyodd
 
Posts: 1
Joined: Tue Oct 04, 2016 6:30 am

Return to iMacros for Firefox

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 6 guests

-->