Save as problem

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

Save as problem

by watergate74 on Wed Mar 22, 2017 10:15 am

Hello,

I have a very strange problem. I'd like to save all subpages of an internet page into four different files. For this this I have wtritten the following macro:

VERSION BUILD=9030808 RECORDER=FX
SAVEAS TYPE=HTM FOLDER="D:\Data\iMacros\" FILE="data1.html"

TAG POS=1 TYPE=A ATTR=ID:ctl00_ctl00_CPContent_CPMain_ucPager_repPages_ctl01_p1
WAIT SECONDS=1
SAVEAS TYPE=HTM FOLDER="D:\Data\iMacros\" FILE="data2.html"

TAG POS=1 TYPE=A ATTR=ID:ctl00_ctl00_CPContent_CPMain_ucPager_repPages_ctl02_p2
WAIT SECONDS=1
SAVEAS TYPE=HTM FOLDER="D:\Data\iMacros\" FILE="data3.html"

TAG POS=1 TYPE=A ATTR=ID:ctl00_ctl00_CPContent_CPMain_ucPager_repPages_ctl03_p3
WAIT SECONDS=1
SAVEAS TYPE=HTM FOLDER="D:\Data\iMacros\" FILE="data4.html"

The macro works fine - all subpages are disaplayed correctly - but all saved files contain the data of the first page?!?

Does anybody has an idea how to fix this bug?

Many thanks in advance
watergate
watergate74
 
Posts: 1
Joined: Wed Mar 22, 2017 9:50 am

Return to General Support & Discussions

Who is online

Users browsing this forum: Witty and 6 guests

-->