Page 1 of 1

imacro captcha problems

Posted: Wed Jun 07, 2017 8:04 pm
by luciferdz123
MacroSyntaxError: wrong format of TAG command, line 25 (Error code: -910)
Help me fix this imacro code:
VERSION BUILD=8890130 RECORDER=FX
TAB T=1
SET !VAR2 EVAL("var randomNumber=Math.floor(Math.random()*3 + 15); randomNumber;")
URL GOTO=**********
FRAME NAME=*
TAG POS=1 TYPE=DIV ATTR=ROLE:presentation&&CLASS:recaptcha-checkbox-checkmark&&TXT:
WAIT SECONDS = {{!VAR2}}
FRAME NAME="I1_*"
ONDOWNLOAD FOLDER=C:\Users\Mauradon\Documents\iMacros\Downloads FILE=captcha.jpg WAIT=YES
TAG POS=1 TYPE=IMG ATTR=SRC:*/recaptcha/api2/payload* CONTENT=EVENT:SAVEPICTUREAS
WAIT SECONDS=5
TAB OPEN
TAB T=2
SET !EXTRACT_TEST_POPUP NO
URL GOTO=http://api.dbcapi.me/decaptcher?function=picture2&print_format=html
TAG POS=1 TYPE=INPUT ATTR=NAME:username CONTENT=****************
TAG POS=1 TYPE=INPUT ATTR=NAME:password CONTENT=****************
TAG POS=1 TYPE=INPUT ATTR=NAME:pict CONTENT=C:\Users\Mauradon\Documents\iMacros\Downloads\captcha.jpg
TAG POS=1 TYPE=INPUT ATTR=TYPE:submit
TAG POS=6 TYPE=TD ATTR=* EXTRACT=TXT
SET !VAR1 {{!EXTRACT}}
TAB CLOSE
TAB T=1
FRAME NAME="I1_*"
TAG POS=1 TYPE=CLICK SELECTOR="#default-response" TYPE=INPUT:TEXT ATTR=ID:default-response CONTENT={{!VAR1}}
TAG POS=1 TYPE=DIV ATTR=ROLE:button&&TXT:Verify

Re: imacro captcha problems

Posted: Thu Jun 08, 2017 7:24 am
by chivracq
luciferdz123 wrote:
MacroSyntaxError: wrong format of TAG command, line 25 (Error code: -910)

Help me fix this imacro code:
Code: Select all
VERSION BUILD=8890130 RECORDER=FX
TAB T=1
SET !VAR2 EVAL("var randomNumber=Math.floor(Math.random()*3 + 15); randomNumber;")
URL GOTO=**********
FRAME NAME=*
TAG POS=1 TYPE=DIV ATTR=ROLE:presentation&&CLASS:recaptcha-checkbox-checkmark&&TXT:
WAIT SECONDS = {{!VAR2}}
FRAME NAME="I1_*"
ONDOWNLOAD FOLDER=C:\Users\Mauradon\Documents\iMacros\Downloads FILE=captcha.jpg WAIT=YES
TAG POS=1 TYPE=IMG ATTR=SRC:*/recaptcha/api2/payload* CONTENT=EVENT:SAVEPICTUREAS
WAIT SECONDS=5
TAB OPEN
TAB T=2
SET !EXTRACT_TEST_POPUP NO
URL GOTO=http://api.dbcapi.me/decaptcher?function=picture2&print_format=html
TAG POS=1 TYPE=INPUT ATTR=NAME:username CONTENT=****************
TAG POS=1 TYPE=INPUT ATTR=NAME:password CONTENT=****************
TAG POS=1 TYPE=INPUT ATTR=NAME:pict CONTENT=C:\Users\Mauradon\Documents\iMacros\Downloads\captcha.jpg
TAG POS=1 TYPE=INPUT ATTR=TYPE:submit
TAG POS=6 TYPE=TD ATTR=* EXTRACT=TXT
SET !VAR1 {{!EXTRACT}}
TAB CLOSE
TAB T=1
FRAME NAME="I1_*"
TAG POS=1 TYPE=CLICK SELECTOR="#default-response" TYPE=INPUT:TEXT ATTR=ID:default-response CONTENT={{!VAR1}}
TAG POS=1 TYPE=DIV ATTR=ROLE:button&&TXT:Verify

FCIM...! :mrgreen:
=> iMacros for FF v8.8.9...?, FF53...?, OS...?
Strange Version of iMacros to use, unless you are on Pale Moon or using some old Version of FF, around FF30-37..., I'm not even sure it still works on FF48-53... :?
Hum, and your Qt is very "basic" and sounds a bit "strange" if you've been using iMacros since v8.8.x for FF, you should start answering Threads on the Forum by now, I would think...

Yep, normal, your Line 25 is:
Code: Select all
TAG POS=1 TYPE=CLICK SELECTOR="#default-response" TYPE=INPUT:TEXT ATTR=ID:default-response CONTENT={{!VAR1}}

You made this Line by yourself from some mishmash-mixing-blending explosive Cocktail between the 'TAG' and the 'EVENT' Modes, ah-ah...!

You need to use one or the other, you cannot mix both together...

Hum..., and I see Wildcards for your Frame Names, I'm not sure you can use Wildcards for Frames..., unless that was implemented in v9.0.3 for FF... (which conflicts with the v8.8.9 for FF from your Script...).