ONDOWNLOAD works not correct

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

ONDOWNLOAD works not correct

by PedaPan on Wed Dec 27, 2017 2:52 pm

Hello Guys,

first pls sorry for some english mistakes, this is not my mother language.

Ok, first my user informations:

1: iMacros Browser (x86) Version 12.0.501.6698

2: Win 7, (x86)

3: for this Problem i use the internal iMacros Browser.

4: All demo macros works correct

What i try to do is, download a .csv file from a website. This is the iMacros code i use:

Code: Select all
VERSION BUILD=12.0.501.6698
TAB T=1
TAB CLOSEALLOTHERS
'SET !PLAYBACKDELAY 0.00
SET !TIMEOUT_DOWNLOAD 15
ONSECURITYDIALOG BUTTON=YES CONTINUE=YES
ONSECURITYDIALOG BUTTON=YES CONTINUE=YES
URL GOTO=https://52.58.164.53:8443/index.action
TAG POS=1 TYPE=INPUT:TEXT ATTR=NAME:userName CONTENT=USERNAME
SET !ENCRYPTION NO
TAG POS=1 TYPE=INPUT:PASSWORD ATTR=NAME:password CONTENT=PASSWORD
TAG POS=1 TYPE=A ATTR=TXT:Anmelden
TAG POS=1 TYPE=A ATTR=TXT:Daten-Export
TAG POS=1 TYPE=INPUT:RADIO ATTR=NAME:powerValue
TAG POS=1 TYPE=INPUT:TEXT ATTR=ID:beginDate CONTENT=2017-12-27
TAG POS=1 TYPE=INPUT:RADIO ATTR=NAME:powerValue
ONDOWNLOAD FOLDER=* FILE=* WAIT=YES
TAG POS=2 TYPE=A ATTR=TXT:OK


The result is a file with the name "exportAction!exportFile.action" , 2KB size.

First i got the error -1410: No Download Detected. After that i read the wiki and tried to solve the problem with some WAIT commands. But the only thing that happend is, that i dont get the error anymore, but still dont get the .csv file.

Maybe somebode knows what to do here.

Thanks for reading and regards,

Chris
PedaPan
 
Posts: 1
Joined: Wed Dec 27, 2017 1:56 pm

Return to General Support & Discussions

Who is online

Users browsing this forum: No registered users and 5 guests

-->