IMAGECLICK causes iMacros Browser Not Responding message

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

IMAGECLICK causes iMacros Browser Not Responding message

by marysue on Wed Mar 16, 2016 11:24 am

I have a vbscript which infinitely loops 20 instances of iMacros. It works fine for the first five minutes or so, then I start receiving iMacros Browser Not Responding intermittently until all of my 20 instances are sitting in a Not Responding state.

I know of no way to get a log of the iMacros state when this occurs. Beyond identifying the actual problem, understanding how to view this instance's state and errors would also be helpful.

I'm running iMacros version 10.4.28.1074 (Perpetual license)
I'm running on Windows Server 2008R2, with 10G RAM, 60G Hard Drive/30G Free space, 2-3.46GHz processors

The code is below. I have simplified the code to the least common denominator. If I simply navigate to the website without the IMAGECLICK it never hangs. Once I run with the IMAGECLICK it begins hanging after a period of time.

I've taken a video of the testing platform while it is running the test, and shown the task manager popping "Not Responding" states periodically; Also in this video is the state of the system - CPU, Hard Disk Faults, Memory Use, and what the "Not Responding" instances look like:

http://screencast.com/t/8VcZ8Uu2Ve4y : at 1:48 seconds into the video the first Not Responding state pops.
: at 3:42 seconds I begin showing the system state - memory, disk faults, etc.
: at 6:58 seconds I pull the not responding iMacros instances up to view so you can see the browser state

I used Snipping tool to take the enter.png picture.

It is odd this works 99% of the time - but hangs 1% of the time. Unfortunately, when I running a stress test this 1% of the time is not acceptable as the test falls to its knees after 4 hours or so.

The visual basic script code is as follows:

Dim totalDuration, currUser, endUser, delay, myURLBase
myURLBase = "http://www.jhmworldwide.50megs.com"
totalDuration = 2500
currUser = 30
endUser = 49
Delay = 5


macro = "CODE:"
macro = macro & "VERSION BUILD=10.4.28.1074, Script: " + CStr(scriptNum) + ", Users: (" + CStr(startUser) + " thru " + CStr(endUser) + ")" + vbNewLine ' used for iMacro browser
macro = macro & "URL GOTO=" + myURLBase + vbNewLine
macro = macro & "IMAGECLICK POS=1 IMAGE=enter.png CONFIDENCE=95" + vbNewLine
macro = macro & "WAIT SECONDS = 10" + vbNewLine
macro = macro & "TAB CLOSE" + vbNewLine

Dim totalDuration, currUser, delay
totalDuration = 2500
currUser = 30
endUser = 49
Delay = 5

Do While (-1 < 0)
iim1.iimOpen()
iim1.iimSet "currUser", currUser 'resets currUser on each play
iret = iim1.iimPlay(macro, ((totalDuration * 2) + delay)) '''Allow queuing
iim1.iimClose()
currUser = currUser + 1
'when the last row is reached start loop over
If (currUser > endUser) Then
currUser = startUser
End If
Loop


Thanks for all eyes on this!

Mary
marysue
 
Posts: 1
Joined: Tue Mar 15, 2016 1:41 pm

Return to Scripting and Command Line Interface

Who is online

Users browsing this forum: Bing [Bot] and 4 guests

-->