Help imacros recording problem!

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

Help imacros recording problem!

by XcHaka on Fri Aug 19, 2016 5:43 pm

Hi All
("Sorry for my bad english")
i'm using Imacros on chrome, every thing works fine
but when i try to record some thing. on page imacros faild to do it.
Ok more explain :
Image
When i Click Play button. then Imacros catch nothing! like i have not even click
Can Any One please Help Me to solve it ;(
i can do inspect element or anything that's needed to get player code
please help
and sorry for my english
XcHaka
 
Posts: 3
Joined: Fri Aug 19, 2016 5:10 pm

Re: Help imacros recording problem!

by chivracq on Sat Aug 20, 2016 9:10 am

XcHaka wrote:Hi All
("Sorry for my bad english")
i'm using Imacros on chrome, every thing works fine
but when i try to record some thing. on page imacros faild to do it.
Ok more explain :
Image
When i Click Play button. then Imacros catch nothing! like i have not even click
Can Any One please Help Me to solve it ;(
i can do inspect element or anything that's needed to get player code
please help
and sorry for my english

FCIM...! :mrgreen: (Always mention your FCI when you open a Thread, read my Sig, many Commands are not available for all Browsers/Versions...)
=> iMacros for CR v8.4.4, CR52...?, OS...?

URL not mentioned but your Video is probably a Flash Object and iMacros cannot interact with Flash Objects, only the DS Mode (available for the iMacros Browser) can...
But have a look anyway at this other similar Thread where it was still possible to get iMacros work with playing/stopping a Video...:
- Youtube Video click Play

You can give a try at the EVENT Mode as well...
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6475
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Help imacros recording problem!

by XcHaka on Sat Aug 20, 2016 11:05 pm

Thank You For Your Repley Sir :) i really feel happy
i Using Google chrome 52.0.2743.116.
iMacros for Chrome / Version: 8.4.4
Windows 10.
OK.

One of problems that type of video is not avaible for other browsers only chrome
i'm trying to change user agent on "imacros browser" for this reason but can't.
i'm trying also to give you link but i can't because need logins etc..
- EVENT Mode is not working on chrome. (give me bugs) :(
but i can do inspect element for that part of code? maybe this can help

Code: Select all
view-source:http://be.sponsorpay.com/46ebb45997cba5ba460930ff59b9a64a/bf121c1e83b80949/US/2735/web/707236?integration=video_iframe&show=SP%3AF%3BDI%3AF%3BDR%3AF%3BRB%3AT%3BPP%3AF&width=400&height=368&displayFormat=bare_player&theme=default&next_offer=null


Much thanks
XcHaka
 
Posts: 3
Joined: Fri Aug 19, 2016 5:10 pm

Re: Help imacros recording problem!

by chivracq on Sun Aug 21, 2016 11:29 pm

XcHaka wrote:Thank You For Your Repley Sir :) i really feel happy
i Using
Code: Select all
Google chrome  52.0.2743.116.
iMacros for Chrome / Version: 8.4.4
Windows 10.

OK.

One of problems that type of video is not avaible for other browsers only chrome
i'm trying to change user agent on "imacros browser" for this reason but can't.
i'm trying also to give you link but i can't because need logins etc..
- EVENT Mode is not working on chrome. (give me bugs) :(
but i can do inspect element for that part of code? maybe this can help

Code: Select all
view-source:http://be.sponsorpay.com/46ebb45997cba5ba460930ff59b9a64a/bf121c1e83b80949/US/2735/web/707236?integration=video_iframe&show=SP%3AF%3BDI%3AF%3BDR%3AF%3BRB%3AT%3BPP%3AF&width=400&height=368&displayFormat=bare_player&theme=default&next_offer=null


Much thanks

OK, perfect for FCI...

But I tried to have a look at your Video, no way, behind L&P indeed, + tried some other Tricks, => didn't work, try to find a Demo of a similar Video..., but hum, don't expect too much, if iMacros is not able to record anything, I'm not sure me or anybody else will be able to help you either...
=> iMacros Limitations...! => Oop...!
Last edited by chivracq on Wed Aug 24, 2016 5:40 am, edited 2 times in total.
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6475
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Help imacros recording problem!

by XcHaka on Wed Aug 24, 2016 3:45 am

chivracq wrote:OK, perfect for FCI...

But I tried to have a look at your Video, no way, behind L&P indeed, + tried some other Tricks, => didn't work, find a Demo of a similar Video..., but hum, don't expect too much, if iMacros is not able to record anything, I'm not sure me or anybbd else will be to help you...
=> iMacros Limitations...! => Oop...!

unlocky.. ~.~
the problem i can't find button "Play" code on source page.. is it invisible? :mrgreen:
i'm tired doing the same work everytime :3
i will try more times to solve this with imacros
excuse my english

Thanks For the help chivracq
much appreciation
XcHaka
 
Posts: 3
Joined: Fri Aug 19, 2016 5:10 pm


Return to Scripting and Command Line Interface

Who is online

Users browsing this forum: No registered users and 1 guest

-->