SAVEAS TYPE=CPL works in Firefox but not in iMacros Browser

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

SAVEAS TYPE=CPL works in Firefox but not in iMacros Browser

by ecraigil on Thu Jan 26, 2017 5:11 pm

Versions:
Windows 7 Enterprise
iMacros Browser V11.1.495.5175 Trial Version
Firefox 50.1.0
iMacros for Firefox 8.9.3 (not the latest, but 9.0.3 didn't detect when the page load was complete so I had to revert)

I have a macro that I recorded in iMacros for Firefox has worked properly in Firefox for the last several months. It doesn't do much:

Code: Select all
VERSION BUILD=8890130 RECORDER=FX
TAB T=1
URL GOTO=<URL hidden>
SAVEAS TYPE=CPL FOLDER="C:\\" FILE=a1.htm


The page has several frames populated by external HTML files. When the script is run in Firefox, all of these external HTML files are saved in the a1_files folder, but when the exact same script is run in the iMacros Browser, it doesn't save the HTML files. All other files, including graphics and JavaScript are saved in the iMacros Browser. I saw in the Wiki that TYPE=CPL isn't supported in Chrome, but it didn't say anything about the iMacros Browser.

We have a backend program that was written to parse and perform several calculations on the data in these HTML files that are missing, and the easiest solution would be to get this to work. We need to automate this process to run late at night, which is why I got the trial version. How can I get the HTML files from the frames to be saved in the a1_files folder from the iMacros Browser?
ecraigil
 
Posts: 1
Joined: Thu Jan 26, 2017 4:33 pm

Return to Scripting and Command Line Interface

Who is online

Users browsing this forum: No registered users and 1 guest

-->