How to automate Firefox with iimInit ("-fx")

Discussions and Tech Support related to automating the iMacros Browser or Internet Explorer from any scripting and programming language, such as VBS (WSH), VBA, VB, Perl, Delphi, C# or C++.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

Re: How to automate Firefox with iimInit ("-fx")

by Tom, Tech Support on Tue Jul 26, 2011 9:25 am

sanfric wrote:Yes, the script runs the first time I use it, but not twice.
Ah yes, I see now. Sorry for the confusion.
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: How to automate Firefox with iimInit ("-fx")

by omnea on Wed Dec 11, 2013 4:51 am

Hi there,

i have a problem to start imacros with firefox with iimInit("-fx") command.
If i´m starting macro with the default imacros browser it works, excepted the lack of read properly html elements.
I will list below troubleshooting infos from imacros browser and the version of firefox.
since a couple of days play on firefox version: 26.0 won´t work anymore, dont know what the reason is to get permanently the -931 error?
please help me, a solution will have big influence to buy enterprise editon or not!

i am using trial edition:
iMacros Browser Version 9.05.2613
Trial Version
Released on 24 September 2013
and here are my troubleshooting Informations from iMacros Browser:

Microsoft Windows 7 Home Premium
Microsoft Windows NT 6.1.7601 Service Pack 1
64-bit Operating System
Installed UI Culture: German (Germany)
CLR version 4.0.30319.18052
Internet Explorer version 11.0.9600.16428
iMacros Browser version 9.0.5.2613
------------------------------------------------------------
Mozilla Firefox version 26.0 (de)
Profile "default" iMacros addon version 8.6.0
------------------------------------------------------------
Auxiliary Libraries:
iMacros Direct Screen (iimds) 7.5.0.7
iimir (iimir) 6, 3, 0, 1
iMacros Image Recognition (iimIRm) 2.0.0.26
imsys (imsys) 5, 10, 0, 2
iMacros RunAs Agent (iimrunner) 8.2.0.900
iMacros Editor (iMacrosEditor) 9.0.1.62
------------------------------------------------------------
Scripting Interface Libraries:
iMacros IE Scripting Connector (iimConnector) 8.2.0.0
iMacros FX Connector (iimFirefoxConnector) 2.0.0.10
iMacros Scripting Interface (iimInterface) 8.5.0.104
iMacros FX&Cr Scripting (imtcp) 1.0.0.680
iMacros Scripting Interface (iimInterface64) 8.5.0.104
iMacros FX&Cr Scripting (imtcp64) 1.0.0.680
------------------------------------------------------------
User Settings:
Profiler = True
Split = bd
FolderLogs = C:\Users\joe\Documents\iMacros\Logs
FolderDownloads = C:\Users\joe\Documents\iMacros\Downloads
EncryptionPasswordMode = No
NewWindowBehavior = Tabs
InterfaceType =
PlaybackSpeed = Fast
TimeoutPage = 60
FolderDataSources = C:\Users\joe\Documents\iMacros\DataSources
FolderMacros = C:\Users\joe\Documents\iMacros\Macros

iOpus Software GmbH
iMacros Browser Version 9.05.2613
Trial Version
Released on 24 September 2013

and firefox version: 26.0
omnea
 
Posts: 4
Joined: Tue Nov 19, 2013 7:58 am

Previous

Return to Scripting and Command Line Interface

Who is online

Users browsing this forum: Google [Bot] and 2 guests

-->