Feedback and Issues on EVENT Recording Mode.

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

Feedback and Issues on EVENT Recording Mode.

by chivracq on Mon Aug 05, 2013 8:34 pm

Ok, my long awaited Feedback (+/-) with Issues (100% ---!) related to the new EVENT Mode introduced with iMacros for FF, v8.30...
I had mentioned it already some 6 weeks ago on 2013/06/20, but I never had/took the time to report all Issues I had found then already, I didn't find any new since I think, except when v8.51 came out, but the final result was fairly the same...
http://forum.iopus.com/viewtopic.php?f= ... 727#p53270

I will try to mention Issues in the Order from most blocking to less everything..., I'm not sure I will remember everything right now, I will add other Posts to this Thread later eventually...

- 01 - Object not found on 'MOUSEMOVE'.
The most blocking aspect with the EVENT Record Mode is that when an Object is not found, the Script will hang and there is no way at all to get it resuming its execution...

As I mentioned it earlier...:
[quote=Chivracq (2013/06/20)]
..., there was a Bug in v8.3.0 with the EVENT-Mode when a "EVENT TYPE=MOUSExxx SELECTOR="ID_xx1"" was not found, by jumping to the next instruction and hanging the Macro with no Error at all but with no possibility to resume its execution, now with the latest v8.5.1 Patch, all "EVENT TYPE=MOUSExxx" instructions are skipped together (instead of just only 1) and the Macro hangs at the next instruction.
The final result is still the same, the Macro still hangs if the SELECTOR-Object is not found (with "SET !ERRORIGNORE YES", of course!), but the behaviour is a bit different between v8.3.0 and v8.5.1, so maybe it's worth mentioning it...
(I haven't reported it yet, as I wanted to report all my EVENT-Mode feedback in one apart Thread...)

EDIT (Decb 2016) on this '01' Item:
This very Blocking Bug in my Opinion never got acknowledged by TechSup nor encountered/reported by any other User... :shock: , until finally more than 3 years later in this Thread from Novb/Decb 2016 where I've posted some fairly easy though a bit "Creative" Workaround that I've been using myself since a few months when I finally dared to dig into the "Problematic" again, ah-ah...!

- 02 - Very Intrusive Focus.
I usually run my "most important" Macros unattended in a Batch File (with AT_Scheduler...), but otherwise I will start (all of) them/some manually in one Firefox instance that I will minimize (the whole Set runs normally for some 30 min approx, and I know the parts where I might need to pause the Macro and take some manual actions inbetween, before resuming the Macro...) and check Gmail or Facebook on some 2nd Firefox Windows or do stg else on my computer not on FF... But as soon as there is some EVENT-Mode Replay action, if I'm trying to do anything on some 2nd FF Window, that's impossible because I then get the Macro Execution running live and popping all the time in front..., and even on some not FF applications, for example the DDLB Selections still become visible through 2-3-4 Windows open at the same time in front of the FF Instance running the Macro...

OK, I've got other Issues related to the EVENT-Mode, I will mention them later in some other Posts in this Thread..., at least I've started the Thread... (I'm actually a wee bit surprised that I never saw anybody reporting anything related to the EVENT-Mode...)

Tom and other iOpus/iMacros Tech-Team People, feel free to split the Issues I mention in some apart Threads if you expect/see too many replies from too many Users...
Last edited by chivracq on Mon Dec 05, 2016 8:36 pm, edited 4 times in total.
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Feedback and Issues on EVENT Recording Mode.

by Tom, Tech Support on Tue Aug 06, 2013 3:10 am

Hi chivracq,

Thanks for compiling your feedback into a new thread! I will continue sharing these posts with the dev team and creating internal development tickets as is necessary.
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: Feedback and Issues on EVENT Recording Mode.

by chivracq on Mon Sep 02, 2013 3:23 pm

OK, a bit surprised that nobody in the meantime reported any other/new findings related to the EVENT Recording Mode...

OK, first doing a Quote of myself from a Post of 'bgoodr' at viewtopic.php?f=11&t=21589 (Which I am going to reformulate and give more info...)
Hi, short reply as I see that nobody replied to your Post..., I can confirm that Ctrl^ is not being recorded in the EVENT Recording Mode, I had noticed it as well a few weeks ago... but haven't reported it yet in "my" dedicated Thread:
viewtopic.php?f=11&t=21494
Shift^ is not recorded either, except with letters and "normal" Shift^Characters on the Keyboard, but for example not with Shift^End or Shift^Arrow...
I did a wee bit of troubleshooting/finding a workaround for you a few days ago, the JS_Key codes don't work either, the only solution I found for you was doing a Mouse_Select in the Field, END, and 20-40 times BACKSPACE, depending on how long you expect your Email address to be...
But I think as well that recording your Macro in Automatic Mode will select and fill in the E-mail address with the new E-mail address even if that field is already populated...

Right_Click + Select_All doesn't work either, only the Right_Click (BUTTON=2) is recorded, but not what you may select from the Context-Menu...


3- CTRL^ / SHIFT^ are not recorded and do not replay...:
Idem with CAPSLOCK, and I didn't check (yet) all the keys on my (US-Standard) Keyboard...
Very annoying for example with Ctrl^a / Ctrl^c / Ctrl^v / Ctrl^z... Only the a/c/v/z gets recorded and replayed...

Hum, a bit confused now, I suddenly seem to be able to record the SHIFT...:
'Home + Shit^End + Delete:
EVENT TYPE=KEYPRESS SELECTOR="#body" KEY=36
EVENT TYPE=KEYPRESS SELECTOR="#body" KEY=35 MODIFIERS="shift"
EVENT TYPE=KEYPRESS SELECTOR="#body" KEY=46

Wondering if "MODIFIERS="control"" will work...

I tried to use a combination of keys like sponk-sponk http://www.webonweboff.com/tips/js/event_key_codes.aspx, but to no avail...

4- The Wiki-Page for the EVENT Recording Mode is very-very poor, there is hardly any documentation...
http://wiki.imacros.net/EVENT
This page was last modified on 17 December 2012, at 15:10.


5- Right_Click (BUTTON=2) is recorded, but not the item you may select from the Context-Menu.
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Feedback and Issues on EVENT Recording Mode.

by chivracq on Mon Nov 04, 2013 6:08 pm

Kind of bumping this (already 2 months old and no Reply...) Thread of mine about Feedback and Issues related to the EVENT Mode after Tom's new pinned Post:
viewtopic.php?f=11&t=21914#p55267
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Feedback and Issues on EVENT Recording Mode.

by chivracq on Tue Nov 26, 2013 6:41 am

Feeback with v8.60:

Item 01 - Missing MOUSEDOWN/MOUSEMOVE is still there... This is a very blocking Bug because the whole Script will simply hang at the next WAIT or URL GOTO Command. (TAG Lines are ignored...)

Code: Select all
'EVENT Mode:
EVENT TYPE=MOUSEDOWN SELECTOR="#brThumb" BUTTON=0
EVENTS TYPE=MOUSEMOVE SELECTOR="#brThumb" POINTS="(392,874),(393,873),(395,873),(396,873),(402,873),(411,873),(421,873),(422,873),(423,873),(425,873),(426,873),(436,873),(437,873),(438,873),(448,873),(449,873),(451,873),(453,873),(454,873),(462,873),(463,873),(464,873),(466,873),(468,873),(469,873),(474,873),(475,873),(476,873),(478,873),(479,873),(487,873),(488,873),(489,873),(490,873),(491,873),(492,873),(494,873),(496,873),(497,873),(499,873),(500,873),(501,873),(502,873),(509,873),(510,873),(521,873),(524,873),(525,873),(533,874),(534,874),(535,874),(536,874),(539,874)"
EVENTS TYPE=MOUSEMOVE SELECTOR="#add_cit>SPAN" POINTS="(547,874),(551,874),(554,874),(557,874),(559,874)"
EVENT TYPE=MOUSEUP POINT="(559,874)"
'TAG POS=1 TYPE=DIV ATTR=ID:brThumb
TAG POS=1 TYPE=BUTTON ATTR=TXT:Action
'WAIT SECONDS=3
URL GOTO=http://...any site


To reproduce, just copy&paste the part of Code I posted in the middle of a working Script, the SELECTOR Object related to my part will obviously not be found and the Script will hang at the next Line in the Script...

>>>

Item 02 - Very intrusive Focus might be solved, I realize right now, even if I've removed many EVENT parts because of Item 01, but I've had some Macros running with EVENT parts in them and working on some other FF Instance or DOS Window and I didn't notice the intrusive popup anymore, just like it is now solved concerning the intrusive Focus concerning URL GOTO...
Will pay more attention and will confirm...

>>> And easy to check, Item 04 - EVENT Wiki Page is still very empty...
Last edited by chivracq on Sun Dec 04, 2016 1:10 pm, edited 1 time in total.
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Feedback and Issues on EVENT Recording Mode.

by chivracq on Fri Apr 04, 2014 9:02 am

Colibry wrote:When I use EVENT command in FireFox I get this bug.

IF FireFox is maximized the EVENT command works fine. But if it minimize FireFox or open something new the EVENT command doesn't work.

This makes some codes I write useless. There is a fix for this. I can use code in virtual machine on vmware or virtualbox. But this doesn't solve the issue permanently.


Original Post posted here, I answer in this dedicated Thread in order not to pollute the other one...

Your Msg is very vague, you don't mention anything about your Config (except "Firefox") with any Versions (iMacros + Browser + OS) and you need to post a Script to reproduce the Problem if you want anybody to investigate it...
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Feedback and Issues on EVENT Recording Mode.

by Colibry on Sat Apr 05, 2014 8:57 am

Thank you.

I am using latest FireFox on Windows 7 OS and latest iMacros addon.

This is the issue. I use the EVEN command for searching in search box and clicking the search result. The EVENT works fine if I leave FireFox opened and maximized. But when I minimize FireFox into task bar I the EVENT no longer works and EVENT commands are played same as any other TAG command that can't find HTML element on the page.

So the search and click procedure fails even though website loaded properly and everything else is correct.

How to avoid this so that iMacros can use EVENT even when FireFox browser is minimized?
Colibry
 
Posts: 48
Joined: Sun Sep 25, 2011 11:47 am

Re: Feedback and Issues on EVENT Recording Mode.

by chivracq on Sat Apr 05, 2014 10:13 am

Colibry wrote:Thank you.

I am using latest FireFox on Windows 7 OS and latest iMacros addon.

This is the issue. I use the EVEN command for searching in search box and clicking the search result. The EVENT works fine if I leave FireFox opened and maximized. But when I minimize FireFox into task bar I the EVENT no longer works and EVENT commands are played same as any other TAG command that can't find HTML element on the page.

So the search and click procedure fails even though website loaded properly and everything else is correct.

How to avoid this so that iMacros can use EVENT even when FireFox browser is minimized?


"latest" won't mean much in a few weeks and there are 3 or 4 latest FF Versions at this moment...
=> iMacros v8.8.1 for FF on FF v28.0, I reckon...

"EVENT Command" is still vague, there are maybe 10 Sub-Commands within 'EVENT', you need to post a Script that reproduces the Problem...

Read this current Thread to understand what I mean as the EVENT Wiki-Page is very poorly documented...
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Feedback and Issues on EVENT Recording Mode.

by Colibry on Sat Apr 05, 2014 11:10 am

I used EVENT and CLICK, KEYPRESS with it.

The FireFox is 28 , and iMacros is v8.8.1 .
Colibry
 
Posts: 48
Joined: Sun Sep 25, 2011 11:47 am

Re: Feedback and Issues on EVENT Recording Mode.

by RickRickRick on Fri Apr 11, 2014 8:46 am

Hi,

The new EVENT recording command has worked so far for me on my own laptop, but I’d like to test it without being Administrator as well.

How can I install the EVENT mode without Administrator rights?

I’m using iMacros for Firefox 7.6.0.2 with Firefox 27.0.1, which is blocked from accessing the internet. Windows Explorer 8.0 isn’t. The HP desktop has Windows 7 Enterprise 2009 English with Service Pack 1 and a 64-bit Operating System.
RickRickRick
 
Posts: 5
Joined: Thu Mar 24, 2011 4:46 am

Re: Feedback and Issues on EVENT Recording Mode.

by chivracq on Fri Apr 11, 2014 9:49 am

RickRickRick wrote:Hi,

The new EVENT recording command has worked so far for me on my own laptop, but I’d like to test it without being Administrator as well.

How can I install the EVENT mode without Administrator rights?

I’m using iMacros for Firefox 7.6.0.2 with Firefox 27.0.1, which is blocked from accessing the internet. Windows Explorer 8.0 isn’t. The HP desktop has Windows 7 Enterprise 2009 English with Service Pack 1 and a 64-bit Operating System.


Hi 3xRick.

Short Answer:
You can't, as it is actually not relevant, I think...

Long Answer:
The EVENT Mode is built in the iMacros Add-on (for Firefox) and runs with the "Credentials" and the "Rights" and "Functionality" that the iMacros Developers have given it, within the Rights that the Add-on (and all other Add-ons, unless specifically specified (per Add-on) in the 'About:config') have within the Firefox Profile (according to its User Agent) within the Firefox Program within the Window User Rights within the Group Policy within the OS...
So in my opinion, "Admin Rights" is not relevant for the EVENT Mode or any other Recording/Replay Mode in iMacros. The EVENT Mode (only/powerfully) allows you to record and automate Actions that YOU as a User (per your Rights) on your Computer can achieve manually using your Keyboard and your Mouse (when interacting within Firefox with/within a Web-Page, though the EVENT Mode allows you as well in some tricky way to perform Actions outside a Web-Page and even outside the Browser. See this Post for more Info...).
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Feedback and Issues on EVENT Recording Mode.

by chivracq on Fri Apr 11, 2014 10:10 am

Compilation of other (interesting) Threads pertaining to the EVENT Mode:
(I will keep updating this Post to add other (future) Threads...)

- CTRL-A not getting recorded
- EVENT keypresses sometimes aren't sent (or aren't received?)
- imacros work in offline mode (Mars 2014: ALT^f / ALT^k.)
- Creating Bookmark in FF
- Can iMacros Click on a Firefox Toolbar (LastPass) Button?
- How to shrink/zoom/scroll the browser display?
- Sidebar disappeared, want it back
- How to Pin a Tab in Google Chrome and Firefox on windows? (Mars 2014: No Solution (using the EVENT Mode), but interesting Troubleshooting and Tools...)
- How to close the iMacros Browser? (May 2014) => Syntax for F-Keys and Web Console (Double Modifiers) / Alt^F4 not working...
- Press ENTER in EVENT mode [Solved] (Aug 2014) => Enter Key recorded but not replaying on Wunderlist.
- How can I avoid element waiting issue? (Novb 2016) => Other User encountering the 'MOUSEMOVE Selector not found' Bug and where I posted a Workaround.

Other interesting Threads:
- Workaround for lack of DS mouse commands
- How to simulate a keypress using Javascript
Last edited by chivracq on Sun Dec 04, 2016 1:14 pm, edited 6 times in total.
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Feedback and Issues on EVENT Recording Mode.

by mevsme on Mon May 26, 2014 7:41 am

Where is full manual for all types, what's BUTTON=0 means? TYPEs list? Where's its all?
mevsme
 
Posts: 14
Joined: Fri Sep 20, 2013 8:00 am

Re: Feedback and Issues on EVENT Recording Mode.

by chivracq on Mon May 26, 2014 8:55 am

mevsme wrote:Where is full manual for all types, what's BUTTON=0 means? TYPEs list? Where's its all?

My Answer: Join the Club...! :oops:

chivracq (02 sept 2013 - v8.51) wrote:4- The Wiki-Page for the EVENT Recording Mode is very-very poor, there is hardly any documentation...
http://wiki.imacros.net/EVENT
This page was last modified on 17 December 2012, at 15:10.

chivracq (06 nov 2013 - v8.60) wrote:>>> And easy to check, Item 04 - EVENT Wiki Page is still very empty...
This page was last modified on 11 October 2013, at 11:51.

No change per today (26 may 2014 - v8.82):
This page was last modified on 11 October 2013, at 11:51.
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: Feedback and Issues on EVENT Recording Mode.

by chivracq on Sat Sep 06, 2014 10:20 am

:idea: Time to bump this Thread...! :idea: :oops: :shock:

- Event Wiki update:
chivracq wrote:
captchacha wrote:Hello,

this is mostly directed at tech support: Would you be able to update the wiki page for the EVENT mode for the FF extension, pretty please with sugar on? It would be hugely helpful in trying to understand what's going on there - I'm currently trying to develop a macro using event mode, but finding it incredibly difficult with hardly any documentation...

Thanks, C.

Yep, I agree completely, I've been asking the same thing several times for more than 1 year already:
- Re: Feedback and Issues on EVENT Recording Mode.
.
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6479
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Next

Return to iMacros for Firefox

Who is online

Users browsing this forum: Google [Bot] and 15 guests

-->