9.0.3 Issues and Feedback

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

Re: 9.0.3 Issues and Feedback

by George87 on Sat Sep 10, 2016 7:45 am

Hello, Tech Support!

I think I've found 2 bugs with ONDOWNLOAD with iMacros version 9.0.3 with Firefox 48.0.2 (Multiprocess windows disabled/enabled) on Windows 7 x64:

The first bug is:

ONDOWNLOAD does not create folders.
I did easy *.iim file, for example:
Code: Select all
URL GOTO="http://wiki.imacros.net/ONDOWNLOAD"

ONDOWNLOAD FOLDER="D:\MyFiles\" FILE=*

TAG POS=1 TYPE=IMG ATTR=src:"/upload/thumb/9/9b/DownloadManager.png/400px-DownloadManager.png" CONTENT=EVENT:SAVEITEM

If the folder is not there yet, I get the error message:
`reason is not defined, line: 3 (Error code: -1001)`

But iMacros version 8.9.7 with Firefox 47 normally created folders.

:!:
If such feature of ` ONDOWNLOAD` is normal for iMacros version 9+, it will be necessary update ` ONDOWNLOAD` description on page http://wiki.imacros.net/ONDOWNLOAD by removing the following strings:
`Just the FOLDER parameter creates folders`.
George87
 
Posts: 5
Joined: Wed Aug 24, 2016 1:33 am

Re: 9.0.3 Issues and Feedback

by George87 on Sat Sep 10, 2016 7:46 am

The second bug:
I use `ONDOWNLOAD` for the next picture:
dp.mycdn.me/getImage?photoId=837641325558&type=4
There is my easy *.iim file, for example:
Code: Select all
URL GOTO="dp.mycdn.me/getImage?photoId=837641325558&type=4"

ONDOWNLOAD FOLDER=* FILE=*

TAG XPATH="/html/body/img" CONTENT=EVENT:SAVEITEM

I get 2 files in `Downloads` folder :!:
There are no extensions in names of these files!
One of these files has normal size (2-50 kbytes) and contents a picture.
Other file has size `0 byte`. When I trying to delete this file, I get Windows error message: `File "getImage. " not found.`
There is my `Downloads` folder with these files in attached zip-archive.

If I write file name in my code
Code: Select all
URL GOTO="dp.mycdn.me/getImage?photoId=837641325558&type=4"

ONDOWNLOAD FOLDER=* FILE="1.png"

TAG XPATH="/html/body/img" CONTENT=EVENT:SAVEITEM

the result of `ONDOWNLOAD` is the same!

It is not bug with the one picture.
There are more pictures, for example:
dp.mycdn.me/getImage?photoId=837734957808&type=4
dp.mycdn.me/getImage?photoId=837895095857&type=4
dp.mycdn.me/getImage?photoId=837701088752&type=4
dp.mycdn.me/getImage?photoId=837391970181&type=4
dp.mycdn.me/getImage?photoId=812127478728&type=4

But iMacros version 8.9.7 with Firefox 47 normally downloads such pictures.

PS.
The collect of such pictures is my hobby :wink:
But I think, that another peoples can get this bug at more important sites.
Attachments
Downloads.zip
(23.44 KIB) Downloaded 73 times
George87
 
Posts: 5
Joined: Wed Aug 24, 2016 1:33 am

Re: 9.0.3 Issues and Feedback

by George87 on Sun Sep 11, 2016 1:07 am

Hello, Tech Support!

I use iMacros with Firefox since iMacros version 8.8.
I like iMacros very much. :P
And I hope, a newer iMacros versions will become better and better. :D

Now I want to write about `iimDisplay`.
In iMacros version 8+ background color of iimDisplay messages was green. And background color of error messages was yellow. It was very useful! :)
However now in iMacros version 9.0.3 with Firefox 48.0.2 background color of iimDisplay messages and error messages is yellow. :(

:idea:
But I wait for user will be able to set manually background color of iimDisplay messages. It will be very-very useful, if user will have at least 3 background colors of iimDisplay messages:
green background color – for messages with information about normal work of macros,
yellow background color – for messages with warning information,
red background color – for messages with critical information.

I wish success for iMacros programmers! :wink:
George87
 
Posts: 5
Joined: Wed Aug 24, 2016 1:33 am

Re: 9.0.3 Issues and Feedback

by Namkce on Fri Sep 30, 2016 7:47 am

How do I revert to a previous version of IMacros for Firefox? This new update has broken so much stuff in our mission critical scripts, it's not even funny. They were all working fine before the update, and these scripts are several hundred lines with all sorts of crazy errors that NEVER happened before the update. It's been an extremely frustrating couple of weeks, and I need a solution now. Can someone post instructions on how to revert back to the old versions??? Thanks!
Namkce
 
Posts: 3
Joined: Mon Sep 09, 2013 1:44 pm

Re: 9.0.3 Issues and Feedback

by chivracq on Fri Sep 30, 2016 8:01 am

Namkce wrote:How do I revert to a previous version of IMacros for Firefox? This new update has broken so much stuff in our mission critical scripts, it's not even funny. They were all working fine before the update, and these scripts are several hundred lines with all sorts of crazy errors that NEVER happened before the update. It's been an extremely frustrating couple of weeks, and I need a solution now. Can someone post instructions on how to revert back to the old versions??? Thanks!

Simply search for "Previous Version" or "Version History" in the Wiki and you'll quickly find your Answer... :roll:
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6487
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Re: 9.0.3 Issues and Feedback

by thecoder2012 on Fri Sep 30, 2016 11:48 am

chivracq wrote:Simply search for "Previous Version" or "Version History" in the Wiki and you'll quickly find your Answer... :roll:

Link? Your text is not really helpful. Link to one thread is enough

Namkce wrote:How do I revert to a previous version of IMacros for Firefox? This new update has broken so much stuff in our mission critical scripts, it's not even funny. They were all working fine before the update, and these scripts are several hundred lines with all sorts of crazy errors that NEVER happened before the update. It's been an extremely frustrating couple of weeks, and I need a solution now. Can someone post instructions on how to revert back to the old versions??? Thanks!

1. Deinstall the newest version from iMacros for Firefox
2. Install 8.9.7 from https://addons.mozilla.org/en-US/firefo ... sion-8.9.7
3. Deactivate automatic updates in your firefox
Join 9kw.eu Captcha Service now and let your iMacros continue downloads and scripts while you sleep. - Custom iMacros? Contact me!
User avatar
thecoder2012
 
Posts: 110
Joined: Sat Aug 15, 2015 10:14 am
Location: Internet

Re: 9.0.3 Issues and Feedback

by Tom, Tech Support on Mon Oct 24, 2016 9:48 am

George87 wrote:Hello, Tech Support!
With iMacros version 8.9 with Firefox 47 I had normal extraction. There was my testing alerts, for example:

Testin iimGetExtract:
Name: Name_1
phone: phone_1
e-mail: e-mail_1

Testin iimGetExtract:
Name: Name_2
phone: phone_2
e-mail: e-mail_2

BUT
now with iMacros version 9.0.3 with Firefox 48.0 I have incorrect extraction:

Testin iimGetExtract:
Name: Name_1[EXTRACT]phone_1[EXTRACT]e-mail_1
phone: Name_1[EXTRACT]phone_1[EXTRACT]e-mail_1
e-mail: Name_1[EXTRACT]phone_1[EXTRACT]e-mail_1

Testin iimGetExtract:
Name: Name_2[EXTRACT]phone_2[EXTRACT]e-mail_2
phone: Name_2[EXTRACT]phone_2[EXTRACT]e-mail_2
e-mail: Name_2[EXTRACT]phone_2[EXTRACT]e-mail_2
:(

2. If such result of `iimGetExtract` is normal for iMacros version 9+, it will be necessary update `iimGetExtract` description on page http://wiki.imacros.net/iimGetExtract by removing the following strings:
`iimGetExtract(1) - returns 1st extracted data
iimGetExtract (2) - returns 2nd extracted data (and so on)`.
Hi George,

Thank you for reporting this here! This is definitely a bug and I have logged the issue for further investigation by the development team.
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: 9.0.3 Issues and Feedback

by Tom, Tech Support on Mon Oct 24, 2016 10:11 am

rmiller5349 wrote:Your attempt does have some key diferences from mine. I make a multiple profile call to firefox from my batch file and the files are in a subfolder:

start /wait firefox.exe -P 1st -no-remote imacros://run/?m=SubFolder/Sample.iim

URL GOTO=imacros://run/?m=SubFolder/Sample.js

Multi-process is ON.
I have tried starting from scratch with a new firefox profile.
Doesn't matter if files are in the default folder or a subfolder.
This problem is not happening on 1 macro. It is happening on multiple ones.
I configured my test to do the same as what you described here, and yet I still cannot reproduce the issue unfortunately.

Have you tried it with the same macro code that I am using?

Sample.iim:
Code: Select all
VERSION BUILD=9030808 RECORDER=FX
TAB T=1
URL GOTO=http://demo.imacros.net/
WAIT SECONDS=2
URL GOTO=imacros://run/?m=Demo-Firefox%5CSI-Send-Macro-Code.js
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: 9.0.3 Issues and Feedback

by Tom, Tech Support on Mon Oct 24, 2016 10:26 am

Legalien wrote:The countdown thing has become a count up, which is also bullshit honestly. While before you just look how many seconds it takes for the script to move onto the next action, now you have to look where the count is at, and how many seconds it's supposed to spin, and calculate how long it will take it to finish. Seriously, which genius came up with this? :?
Hi Legalien,

Thank you for your feedback! The reason it was changed was to be consistent with the behavior of the iMacros Standard and Enterprise Editions, but I think you make a valid point and will share your comments with the development team.
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: 9.0.3 Issues and Feedback

by Tom, Tech Support on Mon Oct 24, 2016 10:35 am

Legalien wrote:Also, sometimes I open a Firefox browser and I click the iMacro icon, and it opens the window on the left, but the iMacros won't show. If I let it sit for some time, sometimes they appear and sometimes not.

On the previous version 8.9.7 such problem does not exist.

So there's another problem.

Seriously, remove 9.0.3 from circulation and forget about it like a bad dream.
We haven't come across this behavior ourselves or received any submitted reports. Is there anything unusual about your macro folder hierarchy on the file system? For example, do you have a large amount of files?
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: 9.0.3 Issues and Feedback

by Tom, Tech Support on Mon Oct 24, 2016 10:40 am

Legalien wrote:Another issue I encountered with 9.0.3 is that even though all of my scripts have the ERRORIGNORE command, whenever the script would come up to the following lines, it would simply freeze and stay frozen.

Code: Select all
TAG POS=1 TYPE=INPUT:SUBMIT FORM=ID:favorite_btn_form ATTR=NAME:commit
TAG POS=1 TYPE=INPUT:SUBMIT FORM=ID:retweet_btn_form ATTR=NAME:commit
TAG POS=1 TYPE=INPUT:SUBMIT FORM=ID:update-form ATTR=*


So not only would it not do the action/click, it would also freeze. And then I'd have to stop the script and restart it. But it's pointless because the script basically stops working with 9.0.3 since it won't click on the above.
We need reproducible test cases in order to troubleshoot specific incidents like this. I know it's not always possible to provide your own macro for testing, but with no way to reproduce it, there is little further that the testers/developers can do to investigate, unless someone else provides the same or a similar report along with a runnable macro that reproduces the problem and/or detailed steps on how to replicate it.
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: 9.0.3 Issues and Feedback

by Tom, Tech Support on Mon Oct 24, 2016 11:01 am

George87 wrote:Hello, Tech Support!

I think I've found 2 bugs with ONDOWNLOAD with iMacros version 9.0.3 with Firefox 48.0.2 (Multiprocess windows disabled/enabled) on Windows 7 x64:

The first bug is:

ONDOWNLOAD does not create folders.
I did easy *.iim file, for example:
Code: Select all
URL GOTO="http://wiki.imacros.net/ONDOWNLOAD"

ONDOWNLOAD FOLDER="D:\MyFiles\" FILE=*

TAG POS=1 TYPE=IMG ATTR=src:"/upload/thumb/9/9b/DownloadManager.png/400px-DownloadManager.png" CONTENT=EVENT:SAVEITEM

If the folder is not there yet, I get the error message:
`reason is not defined, line: 3 (Error code: -1001)`

But iMacros version 8.9.7 with Firefox 47 normally created folders.

:!:
If such feature of ` ONDOWNLOAD` is normal for iMacros version 9+, it will be necessary update ` ONDOWNLOAD` description on page http://wiki.imacros.net/ONDOWNLOAD by removing the following strings:
`Just the FOLDER parameter creates folders`.
Hi George,

This bug was already noted elsewhere in the forum as well as logged on the Known Issues page.
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: 9.0.3 Issues and Feedback

by Tom, Tech Support on Mon Oct 24, 2016 12:21 pm

George87 wrote:The second bug:
I use `ONDOWNLOAD` for the next picture:
dp.mycdn.me/getImage?photoId=837641325558&type=4
There is my easy *.iim file, for example:
Code: Select all
URL GOTO="dp.mycdn.me/getImage?photoId=837641325558&type=4"

ONDOWNLOAD FOLDER=* FILE=*

TAG XPATH="/html/body/img" CONTENT=EVENT:SAVEITEM

I get 2 files in `Downloads` folder :!:
There are no extensions in names of these files!
One of these files has normal size (2-50 kbytes) and contents a picture.
Other file has size `0 byte`. When I trying to delete this file, I get Windows error message: `File "getImage. " not found.`
Thanks again George for taking the time to report these issues here. I was able to reproduce the behavior with 9.0.3 and have logged it for further investigation by the development team. When I tested the macro with 8.9.7, it still saved the image file without an extension, but it did not create the second "ghost" file.
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: 9.0.3 Issues and Feedback

by Tom, Tech Support on Mon Oct 24, 2016 12:26 pm

George87 wrote:However now in iMacros version 9.0.3 with Firefox 48.0.2 background color of iimDisplay messages and error messages is yellow. :(

:idea:
But I wait for user will be able to set manually background color of iimDisplay messages. It will be very-very useful, if user will have at least 3 background colors of iimDisplay messages:
green background color – for messages with information about normal work of macros,
yellow background color – for messages with warning information,
red background color – for messages with critical information.
Yes, the color was changed to be consistent with iMacros for IE and the iMacros browser (Standard and Enterprise Editions). I like your suggestion of making the background color user-definable and have logged this as a feature request.
Regards,

Tom, iMacros Support
Tom, Tech Support
 
Posts: 3300
Joined: Mon May 31, 2010 9:59 am

Re: 9.0.3 Issues and Feedback

by chivracq on Tue Oct 25, 2016 6:37 am

Tom, Tech Support wrote:
George87 wrote:However now in iMacros version 9.0.3 with Firefox 48.0.2 background color of iimDisplay messages and error messages is yellow. :(

:idea:
But I wait for user will be able to set manually background color of iimDisplay messages. It will be very-very useful, if user will have at least 3 background colors of iimDisplay messages:
green background color – for messages with information about normal work of macros,
yellow background color – for messages with warning information,
red background color – for messages with critical information.
Yes, the color was changed to be consistent with iMacros for IE and the iMacros browser (Standard and Enterprise Editions). I like your suggestion of making the background color user-definable and have logged this as a feature request.

Oh...!, yep, very good indeed, ... and "surfing" on this EnhReq, I would mention "mine" again (from my own EnhReq Thread...):
chivracq wrote:-09- Add 'iimDisplay()' Command to pure '.iim'.
=> viewtopic.php?f=2&t=25807&p=67840#p69714
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6487
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)

Previous

Return to iMacros for Firefox

Who is online

Users browsing this forum: Google [Bot] and 7 guests

-->