Simple YouTube macro isn't working

Discussions and Tech Support related to website data extraction, screen scraping and data mining using iMacros.

Moderators: Community Moderators, iMacros Moderators

Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the Google search box (at the top of each forum page) to see if a similar problem or question has already been addressed. This will search the entire contents of the forums as well as the iMacros Wiki.
3. We can respond much faster to your posts if you include the following information:

CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST

Answering your own posts (e.g. attempting to "bump" your topic) drops your topic from the list of unanswered threads, so it may actually receive less views.

Simple YouTube macro isn't working

by dadadatacod on Fri Sep 08, 2017 8:50 am

This simple series of clicks is supposed to hit the SHARE button on YouTube, then COPY button for the URL that appears in the popup, then dismiss the popup. (Note that YT has changed the layout of the page very recently).

VERSION BUILD=9030808 RECORDER=FX
TAB T=1
TAG POS=6 TYPE=YT-FORMATTED-STRING ATTR=ID:text
TAG POS=8 TYPE=YT-FORMATTED-STRING ATTR=ID:text
TAG POS=1 TYPE=DIV ATTR=ID:owner-container
TAG POS=8 TYPE=YT-FORMATTED-STRING ATTR=ID:text
TAG POS=2 TYPE=DIV ATTR=ID:info

However, it's as if the string is not passed to the clipboard properly. Instead, the clipboard contains the string associated with the previous run of the macro. That is why there are two tries at TAG POS=8 - trying to get the current URL onto the clipboard.

The purpose is to extract the YouTube link for pasting into an online content management system. I can't figure out the hitch here.
dadadatacod
 
Posts: 1
Joined: Fri Sep 08, 2017 8:40 am

Re: Simple YouTube macro isn't working

by chivracq on Fri Sep 08, 2017 8:56 pm

dadadatacod wrote:This simple series of clicks is supposed to hit the SHARE button on YouTube, then COPY button for the URL that appears in the popup, then dismiss the popup. (Note that YT has changed the layout of the page very recently).

Code: Select all
VERSION BUILD=9030808 RECORDER=FX
TAB T=1
TAG POS=6 TYPE=YT-FORMATTED-STRING ATTR=ID:text
TAG POS=8 TYPE=YT-FORMATTED-STRING ATTR=ID:text
TAG POS=1 TYPE=DIV ATTR=ID:owner-container
TAG POS=8 TYPE=YT-FORMATTED-STRING ATTR=ID:text
TAG POS=2 TYPE=DIV ATTR=ID:info


However, it's as if the string is not passed to the clipboard properly. Instead, the clipboard contains the string associated with the previous run of the macro. That is why there are two tries at TAG POS=8 - trying to get the current URL onto the clipboard.

The purpose is to extract the YouTube link for pasting into an online content management system. I can't figure out the hitch here.

Hum..., first time I thought I was going to help sbd with a YouTube Script as I normally don't help Users with Like/Follow/Comment/Share/etc... for Forums and Social Media that I usually consider as Spam, but I thought, hum..., your "Purpose" sounds a little bit "Legit", ah-ah...!

But nope...!! You didn't read the Forum Rules for Required Info to include in your Post when you open a Thread, too bad, ah-ah...! :twisted:
=> FCIM...! :mrgreen: (Read my Sig...)
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
chivracq
 
Posts: 6477
Joined: Sat Apr 13, 2013 6:07 am
Location: Amsterdam (NL)


Return to Data Extraction and Web Screen Scraping

Who is online

Users browsing this forum: No registered users and 3 guests

-->