Search found 42 matches

by tata668
Fri Apr 15, 2011 10:21 am
Forum: iMacros for Firefox
Topic: ONDIALOG javascript popups dont work in Firefox 4
Replies: 6
Views: 1663

Re: ONDIALOG javascript popups dont work in Firefox 4

Works great now with the update. Thanks!
by tata668
Thu Apr 14, 2011 2:17 pm
Forum: iMacros for Firefox
Topic: ONDIALOG javascript popups dont work in Firefox 4
Replies: 6
Views: 1663

Re: ONDIALOG javascript popups dont work in Firefox 4

+1

I'm also waiting for a fix on this.
by tata668
Mon Feb 15, 2010 5:07 pm
Forum: Data Extraction and Web Screen Scraping
Topic: Saving an image with a ? in it?
Replies: 9
Views: 1660

Re: Saving an image with a ? in it?

Thanks for sharing your workaround. I have pointed the developers to this issue. Is there a minimal working macro that they can use to recreate the issue easily? On a web page where the problem exists, this code would be enough to see the image is requested again: ONDOWNLOAD FOLDER=C:\ FILE=pic.gif...
by tata668
Sat Feb 13, 2010 4:38 pm
Forum: Data Extraction and Web Screen Scraping
Topic: Saving an image with a ? in it?
Replies: 9
Views: 1660

Re: Saving an image with a ? in it?

I actually found a very, very, quirky workaround for this issue. Enabling "Work offline" in firefox before saving the image does the trick: the image is taken from the cache instead of getting requested again (well at least when using BetterCache to be sure the image is actually cached). I use the s...
by tata668
Sat Feb 13, 2010 4:26 pm
Forum: Data Extraction and Web Screen Scraping
Topic: Saving an image with a ? in it?
Replies: 9
Views: 1660

Re: Saving an image with a ? in it?

Your support contact form doesn't work well when submitted. Not Found The requested URL /service/support/thankyou.asp was not found on this server. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. Not sure if my message was actually sent..
by tata668
Sat Feb 13, 2010 4:14 pm
Forum: Data Extraction and Web Screen Scraping
Topic: Saving an image with a ? in it?
Replies: 9
Views: 1660

Re: Saving an image with a ? in it?

Using: Firefox 3.6 - imacros 6.88 There really IS a problem with iMacros not taking the image from the cache, even if it's there. Using Live HTTP headers I see the image is requested by the "SAVEITEM" (or SAVEPICTUREAS) even if the image IS in the cache (about:cache or CacheViewer ). I even use Bett...
by tata668
Tue Nov 17, 2009 2:57 pm
Forum: Data Extraction and Web Screen Scraping
Topic: URL GOTO={{!VAR1}} with https
Replies: 3
Views: 1301

Re: URL GOTO={{!VAR1}} with https

Hannes, I guess you meant "SET !VAR1 {{!URLCURRENT}}" because "ADD !VAR1 {{!URLCURRENT}}" gives me an error. Other than that, this macro works.. I'll try to figure out when exactly it doesn't work for me. By the way, the download link at http://www.iopus.com/imacros/support/b685.htm doesn't work. Th...
by tata668
Mon Nov 16, 2009 7:02 pm
Forum: Data Extraction and Web Screen Scraping
Topic: URL GOTO={{!VAR1}} with https
Replies: 3
Views: 1301

URL GOTO={{!VAR1}} with https

I use this on a http s site: ADD !VAR1 {{!URLCURRENT}} (do things...) URL GOTO={{!VAR1}} And receive this error: BadParameter: The URL syntax is not correct: 'http:// https://www.example.com', line: 94 (-911) I think iMacros add a "http:// " when the url doesn't start with "http://". But It shouldn'...
by tata668
Mon Nov 16, 2009 5:55 pm
Forum: General Support & Discussions
Topic: Redirection... How to follow it?
Replies: 5
Views: 1273

Re: Redirection... How to follow it?

Actually, I'm unable to reproduce my error! :oops:

Thanks for the help...
by tata668
Fri Nov 13, 2009 5:40 pm
Forum: General Support & Discussions
Topic: Redirection... How to follow it?
Replies: 5
Views: 1273

Re: Redirection... How to follow it?

According to http://wiki.imacros.net/Error_and_Return_Codes that error does not exist :?: What version of iMacros are you using, FF plugin? IE? or iMacros Browser. I'd suggest trying on different browser and see how iMacros reacts on it. I use the scripting edition 6.60, with the "-fx" flag (firefo...
by tata668
Fri Nov 13, 2009 3:34 am
Forum: General Support & Discussions
Topic: Redirection... How to follow it?
Replies: 5
Views: 1273

Re: Redirection... How to follow it?

Any help please?
by tata668
Wed Nov 11, 2009 10:55 pm
Forum: General Support & Discussions
Topic: Redirection... How to follow it?
Replies: 5
Views: 1273

Redirection... How to follow it?

I use this code: SET !TIMEOUT 60 URL GOTO=http://www.example.com But http://www.example.com redirect to http s ://www.example.com using a "Location:" header. I want to follow the redirection, how can I do this? Currently, iMacros dies with this error: RuntimeError: unable to load http://www.example....
by tata668
Thu Nov 05, 2009 2:00 pm
Forum: Data Extraction and Web Screen Scraping
Topic: Is a text present somewhere (anywhere) on the page
Replies: 6
Views: 3399

Re: Is a text present somewhere (anywhere) on the page

Running iMacros v6.85 (beta), your extraction commands from above (with type=*) do work. Judging from the result, they are matched against the full site (<html>). If you'd like to try, here's the current beta: http://www.iopus.com/imacros/support/b685.htm I' use TYPE=BODY for now, and wait for the ...
by tata668
Wed Nov 04, 2009 4:12 pm
Forum: Data Extraction and Web Screen Scraping
Topic: Is a text present somewhere (anywhere) on the page
Replies: 6
Views: 3399

Re: Is a text present somewhere (anywhere) on the page

I'm still doing tests, but I think that using "BODY" as the type to look for works: TAG POS=1 TYPE=BODY ATTR=TXT:*Hello<SP>World* EXTRACT=TXT I'm not sure if it will always work though? I mean, I understand that is the text is in the header of the page it won't work but will it work for any text in ...
by tata668
Wed Nov 04, 2009 3:44 pm
Forum: Data Extraction and Web Screen Scraping
Topic: Is a text present somewhere (anywhere) on the page
Replies: 6
Views: 3399

Re: Is a text present somewhere (anywhere) on the page

Here you go: TAG POS=1 TYPE=* ATTR=TXT:*The<SP>confirmation<SP>code<SP>you<SP>entered<SP>was<SP>incorrect.* EXTRACT=TXT TAG POS=1 TYPE=* ATTR=TXT:*Please<SP>note<SP>that<SP>you<SP>will<SP>need<SP>to<SP>enter* EXTRACT=TXT TAG POS=1 TYPE=* ATTR=TXT:*Length<SP>must<SP>be<SP>between* EXTRACT=TXT None of...