Search found 16 matches

by skabaas
Wed Jan 26, 2011 10:38 am
Forum: Command Line and Scripting Interface
Topic: How to automate Firefox with iimInit ("-fx")
Replies: 46
Views: 53251

Re: How to automate Firefox with iimInit ("-fx")

Strange, it works for us. Can you try with this script: Option Explicit Dim iim1, iret Dim rn, i, keyword Dim code code = "CODE:URL GOTO=google.com" + vbNewLine+ "TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:f ATTR=NAME:q1 CONTENT=x" set iim1= CreateObject ("imacros") iret = iim1.iimInit("-fx",true) MsgBox ...
by skabaas
Wed Jan 26, 2011 9:53 am
Forum: Command Line and Scripting Interface
Topic: How to automate Firefox with iimInit ("-fx")
Replies: 46
Views: 53251

Re: How to automate Firefox with iimInit ("-fx")

I figured out where I went wrong, but now I'm running into another little bug: Firefox seems to handle imacros.iimGetLastExtract different than the normal iMacros browser: Same code, same extract, different outcome: iMacros browser: http://i51.tinypic.com/fxf1nc.jpg Firefox: http://i53.tinypic.com/1...
by skabaas
Fri Jan 21, 2011 2:33 pm
Forum: Command Line and Scripting Interface
Topic: How to automate Firefox with iimInit ("-fx")
Replies: 46
Views: 53251

Re: How to automate Firefox with iimInit ("-fx")

Installed the new Beta and the Firefox plugin... Seems like "-ie" or "-fx" stopped working? iimInit now always fires up the iMacros-browser?
by skabaas
Tue Jan 18, 2011 12:37 pm
Forum: General Support & Discussions
Topic: iMacros 7.20 with Firefox 3.6.13 not working?
Replies: 2
Views: 836

Re: iMacros 7.20 with Firefox 3.6.13 not working?

Why is it so hard to get someone to reply to your topic with a decent answer?! :roll:
by skabaas
Fri Jan 14, 2011 9:41 am
Forum: General Support & Discussions
Topic: iMacros 7.20 with Firefox 3.6.13 not working?
Replies: 2
Views: 836

iMacros 7.20 with Firefox 3.6.13 not working?

In the version history of iMacros 7.20 i found this: Version 7.20 Beta, January 12, 2011 * Added: Scripting Interface version 80328: support for Firefox 3.6 and above But sadly, I can't get the thing working... When I run my script from Visual Studio using imacros.iimInit("-v7 -fx", True, "", "", ""...
by skabaas
Thu Jan 13, 2011 1:14 pm
Forum: General Support & Discussions
Topic: 'theForm' is undefined
Replies: 8
Views: 2452

Re: 'theForm' is undefined

OMG! I figured it out! This morning I suddenly remembered that when I was uninstalling and reinstalling iMacros, I always had my Visual Studio project, using the iMacros scripting DLL open... When I reinstalled iMacros without VS open, everything seems to be running just fine, so probabely VS kept o...
by skabaas
Thu Jan 13, 2011 11:00 am
Forum: General Support & Discussions
Topic: 'theForm' is undefined
Replies: 8
Views: 2452

Re: 'theForm' is undefined

Is there anybody who can help me?! :roll:
by skabaas
Thu Jan 06, 2011 9:54 am
Forum: General Support & Discussions
Topic: 'theForm' is undefined
Replies: 8
Views: 2452

Re: 'theForm' is undefined

Yes, I am still experiencing the error!

Recently installed 7.1.12, same "theForm is undefined" error... And when I go back to 7.0.5, the error has disappeared again... What could this be?! Please help!
by skabaas
Wed Dec 22, 2010 10:06 am
Forum: General Support & Discussions
Topic: Sends email when iMacros encountered error
Replies: 13
Views: 5615

Re: Sends email when iMacros encountered error

You'll probabely need the Scripting Edition of iMacros...
by skabaas
Wed Dec 22, 2010 10:05 am
Forum: General Support & Discussions
Topic: 'theForm' is undefined
Replies: 8
Views: 2452

Re: 'theForm' is undefined

Anything?
by skabaas
Mon Dec 20, 2010 9:42 am
Forum: General Support & Discussions
Topic: 'theForm' is undefined
Replies: 8
Views: 2452

Re: 'theForm' is undefined

Tom, iOpus wrote:Hi skabaas,

Thanks for the detailed report. At what point do you receive the error? Is it as soon as you navigate to the login page, or is it after attempting to login?
As soon as I navigate to the login page I recieve the error. Because of that, login is not working :(...
by skabaas
Wed Dec 15, 2010 12:53 pm
Forum: General Support & Discussions
Topic: 'theForm' is undefined
Replies: 8
Views: 2452

Re: 'theForm' is undefined

By the way:

* I did not change any of the default Internet Explorer settings
* I've got IE 8.0.6001.18702 installed
* I've tried reinstalling Internet Explorer, didn't help
* I've tried reinstalling iMacros (7.12): didn't help
* When I reinstall iMacros 7.05: everything works fine again... :roll:
by skabaas
Wed Dec 15, 2010 12:42 pm
Forum: General Support & Discussions
Topic: 'theForm' is undefined
Replies: 8
Views: 2452

'theForm' is undefined

Since I've upgraded iMacros from version 7.0.5.969 to a higher version (in this case 7.1.2.1109, but the 7.1.0 beta already gave me this problem, but I thought it was just some buggy beta thingy, so I payed no attention to it...), I'm having this weird javascript-error problem. I've wrote a macro to...
by skabaas
Tue Sep 14, 2010 9:49 am
Forum: Data Extraction and Web Screen Scraping
Topic: Extract original filename
Replies: 3
Views: 779

Re: Extract original filename

Hi skabaas, Sorry, this is currently not supported, but it's a great suggestion and I've added it to our feature request list. You could devise another way to retrieve the filename using script code, but it would be a bit more involved. For example, you could download the file into an empty folder,...
by skabaas
Tue Sep 07, 2010 7:38 am
Forum: Data Extraction and Web Screen Scraping
Topic: Extract original filename
Replies: 3
Views: 779

Re: Extract original filename

Anyone? I'm really stuck here... :(