Search found 32 matches

by les_stockton
Mon Oct 22, 2018 2:31 pm
Forum: iMacros for Chrome
Topic: SET !LOOP from Eval
Replies: 12
Views: 1328

Re: SET !LOOP from Eval

I just want it to start back at the first line of the datasource. I guess I need to base that off of a counter, rather than off of !Loop.

Thanks.
by les_stockton
Mon Oct 22, 2018 1:19 pm
Forum: iMacros for Chrome
Topic: SET !LOOP from Eval
Replies: 12
Views: 1328

Re: SET !LOOP from Eval

I finally made progress based on information given here. My very last hurdle seems to be that no matter what I calculate inside the EVAL, I can't actually set !LOOP to that value. I can set it to a constant, such as 1, 2, 3 or 4. but although the EVAL actually returns a value like that, the followin...
by les_stockton
Sat Oct 20, 2018 3:22 am
Forum: iMacros for Chrome
Topic: SET !LOOP from Eval
Replies: 12
Views: 1328

Re: SET !LOOP from Eval

I don't use imacros every day. The last time I wrote any imacros was probably a year ago. I have to relearn some of it every time I use it.
by les_stockton
Sat Oct 20, 2018 3:00 am
Forum: iMacros for Chrome
Topic: SET !LOOP from Eval
Replies: 12
Views: 1328

Re: SET !LOOP from Eval

it clumsily works now, although I get a type error on the first pass since !VAR2 isn't set the first time. SET !ERRORIGNORE YES SET !DATASOURCE C:\Users\stockton\InputFiles\urls03.txt SET !DATASOURCE_COLUMNS 1 SET !DATASOURCE_LINE {{!LOOP}} SET !VAR1 EVAL("var c1='{{!COL1}}'; var z=c1.length; z;") S...
by les_stockton
Sat Oct 20, 2018 2:38 am
Forum: iMacros for Chrome
Topic: SET !LOOP from Eval
Replies: 12
Views: 1328

Re: SET !LOOP from Eval

Yes. I changed that line to your syntax and it works better. Now I'm frustrated because when I finally loop beyond the number of lines in the datasource, SET !DATASOURCE_LINE {{!LOOP}} gets an error, which is fine, but it doesn't set !COL1 to blank, so my check for the length of !COL1 never goes to ...
by les_stockton
Fri Oct 19, 2018 11:31 pm
Forum: iMacros for Chrome
Topic: SET !LOOP from Eval
Replies: 12
Views: 1328

SET !LOOP from Eval

Windows 10 Chrome: Version 69.0.3497.100 (Official Build) (64-bit) iMacros: 10.0.5 I'm trying to set the !LOOP variable using EVAL. getting an error BadParameter: !LOOP must be integer, SET !VAR1 EVAL("var c1='{{!COL1}}'; var z=c1.length; z;") SET !LOOP EVAL(parseInt("({{!VAR1}}<1)?1:{{!LOOP}}")) Es...
by les_stockton
Fri Oct 19, 2018 7:06 pm
Forum: iMacros for Chrome
Topic: !VAR1 length
Replies: 3
Views: 605

Re: !VAR1 length

I think your syntax is better. thanx
by les_stockton
Fri Oct 19, 2018 1:29 pm
Forum: iMacros for Chrome
Topic: !VAR1 length
Replies: 3
Views: 605

!VAR1 length

WINDOWS 10 CHROME Versió 67.0.3396.99 (64 bits) iMacro Version 10.0.2 I have a simple question. Shouldn't matter which OS or browser, and in fact, I'm hoping the solution is browser independent. I want to set a variable to the length of a variable (!COL1 or !VAR1, as an example). I'm getting errors ...
by les_stockton
Tue Jul 17, 2018 11:43 am
Forum: iMacros for Firefox
Topic: bought license but can't activate
Replies: 4
Views: 579

Re: bought license but can't activate

I was able to get it activated, but then realized that the personal license was for the chrome version. I had been using Firefox with the beta version of imacros that works with the newest Firefox. I'd sure like to continue doing that. What do I have to do to make that happen?
by les_stockton
Tue Jul 17, 2018 11:41 am
Forum: iMacros for Firefox
Topic: Imacros for Firefox stopped working
Replies: 2
Views: 508

Re: Imacros for Firefox stopped working

I bought a personal license, but then figured out that the license is for chrome, not for firefox.
I had been using the beta version of imacros, that works with the newest Firefox. I'd sure like to be able to do that with the personal version licensed imacros.
by les_stockton
Sat Jul 14, 2018 12:34 am
Forum: iMacros for Firefox
Topic: bought license but can't activate
Replies: 4
Views: 579

bought license but can't activate

I bought the personal license. I went to register using my email, and it said I had to use a company e-mail, which I don't really have. I tried my work email address, but it still said I needed to use a company email address.
So I have a license, but I can't use the product.
by les_stockton
Fri Jul 13, 2018 11:49 pm
Forum: iMacros for Firefox
Topic: Imacros for Firefox stopped working
Replies: 2
Views: 508

Imacros for Firefox stopped working

I have the beta version of iMacros for Firefox. 10.0.2a1440 Firefox is 61.0.1 64bit version I was using it running a macro, and I close Firefox and then reopened it a minute or two later. I looked in the imacros window where it has a Files tab and a Bookmarks tab. The bookmark tab has none of my mac...
by les_stockton
Tue Jun 19, 2018 1:06 pm
Forum: iMacros for Firefox
Topic: iMacros 10 Beta - Sign Up and Provide Feedback Here!
Replies: 84
Views: 25123

Re: iMacros 10 Beta - Sign Up and Provide Feedback Here!

Is there support for javascript files so you can use iimPlay, etc? I have one that I have previously used, but it doesn't show up when I list my macro files. I only see the ones that have the iim extension.
by les_stockton
Tue Jun 21, 2016 3:02 pm
Forum: General Support & Discussions
Topic: Feedback - Take the iMacros Add-on(s) Survey!
Replies: 16
Views: 17199

Re: Feedback - Take the iMacros Add-on(s) Survey!

6. Last but not least, are there any feature(s) would you like us to add in 2016? :-) Yes of course, but I've been asking for so long already...! I mainly use iMacros for FF: - Re-add Support for Pale Moon. (Doesn't work anymore since v8.8.3, have to stick to v8.8.2.) - Correct the few Blocking Bug...
by les_stockton
Tue Jun 21, 2016 2:58 pm
Forum: iMacros for Firefox
Topic: display?
Replies: 6
Views: 3062

Re: display?

thanks