Search found 6 matches

by esullivan
Thu Jan 05, 2017 7:13 am
Forum: Data Extraction and Web Screen Scraping
Topic: Navigating a Report Page
Replies: 4
Views: 2162

Re: Navigating a Report Page

Turns out that this was a frame issue. Once I positioned the script to point to the right frame, all was well.
by esullivan
Tue Dec 20, 2016 8:22 pm
Forum: Data Extraction and Web Screen Scraping
Topic: !WAITPAGECOMPLETE vs Wait Time
Replies: 2
Views: 3296

!WAITPAGECOMPLETE vs Wait Time

I have a relatively slow loading set of pages that I am using to scrape data. Initially I had problems with the script getting ahead of itself and causing problems by advancing too quickly. I initially tried the Wait feature and that helped a lot. I later tried the !WAITPAGECOMPLETE command thinking...
by esullivan
Fri Nov 18, 2016 1:13 pm
Forum: Data Extraction and Web Screen Scraping
Topic: Navigating a Report Page
Replies: 4
Views: 2162

Re: Navigating a Report Page

Well, it's not a PDF file and it's not Flash. It appears to me that JavaScript and hidden input fields are being used. I can't share the Web page because it's password protected but here's a sample of the related JS... <script type="text/javascript"> //<![CDATA[ (function() {var fn = function() {$ge...
by esullivan
Thu Nov 17, 2016 6:09 am
Forum: Data Extraction and Web Screen Scraping
Topic: Navigating a Report Page
Replies: 4
Views: 2162

Navigating a Report Page

While I'm still a rookie with iMacros, I've made some solid progress in navigating and extracting needed Web info. Now I'm stuck. In particular, I am trying to simulate the advancement to the last page of a report. In the default recording mode, an image button is identified for generating the repor...
by esullivan
Thu Oct 20, 2016 12:57 pm
Forum: Data Extraction and Web Screen Scraping
Topic: Tag Processing Delay
Replies: 1
Views: 924

Re: Tag Processing Delay

For anyone else having a similar problem...Turns out that using the iMacros browser instead of an I/E plug-in made a huge difference in performance.
by esullivan
Sat Oct 08, 2016 12:52 pm
Forum: Data Extraction and Web Screen Scraping
Topic: Tag Processing Delay
Replies: 1
Views: 924

Tag Processing Delay

I am trying to extract some data from a Web site. I am able to successfully navigate thru a number of pages to get to the one that has the data to extract. It works...but it seems to often hang for minutes before completing. Here's the line that causes the delay: TAG POS=1 TYPE=A ATTR=ID:ctl00_mainC...