Search found 10 matches

by J_J_D
Fri Feb 06, 2009 9:41 am
Forum: iMacros for Firefox
Topic: Component returned failure code: 0x80500001 [solved]
Replies: 18
Views: 25587

Re: Component returned failure code: 0x80500001

hi, that explanation sounds good ... and it is !!!! I converted my .csv file into UTF-8 and it worked ! My next problem is.... (but it's not the subject here) how can I produce a csv encoded with UTF8 with excel... solved ! I saved my .csv file encoding with utf-8 (thanks to notepad2). Now in vba I ...
by J_J_D
Wed Feb 04, 2009 3:46 pm
Forum: iMacros for Firefox
Topic: Component returned failure code: 0x80500001 [solved]
Replies: 18
Views: 25587

Re: Component returned failure code: 0x80500001

I've search the forum and saw 3 references to this error but no solutions...
by J_J_D
Sat Jan 31, 2009 10:29 pm
Forum: iMacros for Firefox
Topic: Component returned failure code: 0x80500001 [solved]
Replies: 18
Views: 25587

Re: what's this bug...

Changed code to : CMDLINE !DATASOURCE p:\magic.csv SET !DATASOURCE_LINE {{!LOOP}} TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:index.php ATTR=NAME:newnb CONTENT={{!COL1}} TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:index.php ATTR=NAME:newname CONTENT={{!COL2}} TAG POS=1 TYPE=INPUT:IMAGE FORM=ACTION:index.php ATT...
by J_J_D
Wed Jan 28, 2009 8:19 am
Forum: iMacros for Firefox
Topic: Component returned failure code: 0x80500001 [solved]
Replies: 18
Views: 25587

Re: what's wrong in my code...

I was using another macro setting ignore error to true. I set it to false, try with prompt (no input), but I finaly get the error : [Exception... "Component returned failure code: 0x80500001 [nsIConverterInputStream.init]" nsresult: "0x80500001 (<unknown>)" location: "JS frame :: chrome://imacros/co...
by J_J_D
Tue Jan 27, 2009 9:17 pm
Forum: iMacros for Firefox
Topic: Component returned failure code: 0x80500001 [solved]
Replies: 18
Views: 25587

Re: what's wrong in my code...

I tryed this : SET !DATASOURCE p:\magic.csv SET !DATASOURCE_LINE {{!LOOP}} 'TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:index.php ATTR=NAME:newnb CONTENT={{!COL1}} 'TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:index.php ATTR=NAME:newname CONTENT={{!COL2}} TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:index.php ATTR=NAME...
by J_J_D
Tue Jan 27, 2009 2:17 pm
Forum: iMacros for Firefox
Topic: Component returned failure code: 0x80500001 [solved]
Replies: 18
Views: 25587

Re: what's wrong in my code...

nope, it 's highlightening the form, without any input...

I tried with .csv instead of .txt without results.
I also tried with the syntax

Code: Select all

"3","MANA CRYPT"
"3","MONK REALIST"
"2","CLEANSING MEDITATION"
"4","ENCHANTED EVENING"
"4","THIRST OF KNOWLEDGE"
without success.
by J_J_D
Tue Jan 27, 2009 11:24 am
Forum: iMacros for Firefox
Topic: Component returned failure code: 0x80500001 [solved]
Replies: 18
Views: 25587

Re: what's wrong in my code...

I dit that and test it... SET !DATASOURCE your-data-file.csv Here's my full code : ' Specify input file (if !COL variables are used, IIM automatically assume a CSV format of the input file 'CSV = Comma Separated Values in each line of the file SET !DATASOURCE p:\magic.txt SET !DATASOURCE_COLUMNS 2 S...
by J_J_D
Tue Jan 27, 2009 10:09 am
Forum: iMacros for Firefox
Topic: Component returned failure code: 0x80500001 [solved]
Replies: 18
Views: 25587

Component returned failure code: 0x80500001 [solved]

[Exception... "Component returned failure code: 0x80500001 [nsIConverterInputStream.init]" nsresult: "0x80500001 (<unknown>)" location: "JS frame :: chrome://imacros/content/utils.js :: anonymous :: line 1" data: no], line 3 ? Solution : charset encoding problem, with a csv in UTF-8 it works. Thank...
by J_J_D
Mon Nov 19, 2007 10:08 am
Forum: iMacros for Firefox
Topic: !LOOP problems (noob)
Replies: 2
Views: 1780

Yes, I Tried the macro you mentionned in the wiki, and I still have the error : Emplacement : chrome://imacros/content/loopwarning.xul Numéro de ligne 5, Colonne 1 :<window id="warningDialog" width="350px" height="200px" title="&imacros.window.imacros.mas0;" orient="vertical" xmlns="http://www.mozil...
by J_J_D
Fri Nov 09, 2007 11:44 am
Forum: iMacros for Firefox
Topic: !LOOP problems (noob)
Replies: 2
Views: 1780

!LOOP problems (noob)

1) I get an error every time a line with !LOOP is executed. "Erreur d'analyse XML : entité non définie Emplacement : chrome://imacros/content/loopwarning.xul Numéro de ligne 5, Colonne 1 :<window id="warningDialog" width="350px" height="200px" title="&imacros.window.imacros.mas0;" orient="vertical" ...