Search found 243 matches

by viking
Wed Jan 18, 2017 8:28 am
Forum: iMacros for Firefox
Topic: Bug in v.9.0.3; #EAF# is no longer returned!
Replies: 5
Views: 2126

Re: Bug in v.9.0.3; #EAF# is no longer returned!

So I tried to remove all Timeout, but still same results (no #EAF# and got the timeout error).

I guess back to 8.9.7 and turn off Autoupdate.
by viking
Wed Jan 18, 2017 5:31 am
Forum: iMacros for Firefox
Topic: Bug in v.9.0.3; #EAF# is no longer returned!
Replies: 5
Views: 2126

Re: Bug in v.9.0.3; #EAF# is no longer returned!

Thanks for you answer. However, I am not sure that I understood you. I upgraded to v9.0.3 again and added "SET !ERRORIGNORE NO" to my test script: SET !ERRORIGNORE NO SET !TIMEOUT 1 TAG POS={{!LOOP}} TYPE=SPAN ATTR=CLASS:someClass EXTRACT=TXT PROMPT {{!EXTRACT}} However, I still get a timeout (no #E...
by viking
Wed Jan 18, 2017 2:13 am
Forum: iMacros for Firefox
Topic: Bug in v.9.0.3; #EAF# is no longer returned!
Replies: 5
Views: 2126

Bug in v.9.0.3; #EAF# is no longer returned!

Some of my crucial scripts stopped working after I upgraded Firefox to V50.1 I later noticed that iMacros had also been upgraded from v8.9.7 to v9.0.3. My script(s) extracts text from rows on a page; something like this: TAG POS={{rownumber}} TYPE=SPAN ATTR=CLASS:someclass EXTRACT=TXT It extracts th...
by viking
Tue Jul 05, 2016 11:21 pm
Forum: iMacros for Firefox
Topic: Firefox fails to record simple login Macro; IE works
Replies: 12
Views: 4707

Re: Firefox fails to record simple login Macro; IE works

I have never seen iMacros record a WAIT command. How did that happen? You need to add it yourself. First observe how web page responds after clicking element and make changes accordingly. Whole script cant be done in single record every time. I see. Well, the point of my post was to illustrate that...
by viking
Tue Jul 05, 2016 10:31 pm
Forum: iMacros for Firefox
Topic: Firefox fails to record simple login Macro; IE works
Replies: 12
Views: 4707

Re: Firefox fails to record simple login Macro; IE works

Try in other system. What other system? It works in IE but not FF or PaleMoon (which is based on FF). iMacros tech support also confirmed (see post above by Shital). If you are able to record the full sequence in FF as I wrote above above (steps 1-4), please post the recorded results. FRAME NAME="P...
by viking
Tue Jul 05, 2016 7:08 pm
Forum: iMacros for Firefox
Topic: Firefox fails to record simple login Macro; IE works
Replies: 12
Views: 4707

Re: Firefox fails to record simple login Macro; IE works

techimac wrote:Try in other system.
What other system? It works in IE but not FF or PaleMoon (which is based on FF).
iMacros tech support also confirmed (see post above by Shital).
If you are able to record the full sequence in FF as I wrote above above (steps 1-4), please post the recorded results.
by viking
Tue Jul 05, 2016 9:46 am
Forum: iMacros for Firefox
Topic: Firefox fails to record simple login Macro; IE works
Replies: 12
Views: 4707

Re: Firefox fails to record simple login Macro; IE works

works for me in FIrefox FRAME NAME="PageDisplay" TAG POS=1 TYPE=INPUT:TEXT FORM=ID:signonEntry ATTR=ID:username CONTENT=aaaa TAG POS=1 TYPE=INPUT:CHECKBOX FORM=ID:signonEntry ATTR=ID:remember CONTENT=YES It doesn't work. You only confirmed that FF can record the username and "Remember me". Please s...
by viking
Sun Jul 03, 2016 8:32 pm
Forum: iMacros for Firefox
Topic: FYI: What To Do if the Page "Takes Forever" to Load
Replies: 0
Views: 679

FYI: What To Do if the Page "Takes Forever" to Load

FYI: I have a site that I am looping but the pages takes "forever" to load (> 2 min). The page appears to be fully loaded after a few seconds but in the statusbar, I see that it is still trying to connect to "mysterious" URLs. This means that iMacros can't continue until the whole page is loaded. My...
by viking
Mon Jun 27, 2016 8:41 am
Forum: iMacros for Firefox
Topic: Firefox fails to record simple login Macro; IE works
Replies: 12
Views: 4707

Re: Firefox fails to record simple login Macro; IE works

Try the following (don't click on "Remember me".): 1. Enter a login name ("test"), 2. Press sign on, 3. Enter a password, 4. Press sign on again, Here is what is recorded (default "Auto" mode): VERSION BUILD=8820413 RECORDER=FX TAB T=1 URL GOTO=http://providentcu.org/index.asp?i=home FRAME NAME="Pag...
by viking
Sun Jun 26, 2016 10:25 pm
Forum: iMacros for Firefox
Topic: Firefox fails to record simple login Macro; IE works
Replies: 12
Views: 4707

Firefox fails to record simple login Macro; IE works

Firefox fails to record a simple login macro here: http://providentcu.org/index.asp?i=home The recording stops after entering user ID. Not even EVENT mode works. IE records the login fine though (and the recorded macro works in FF). I have experienced this issue several times (FF fails but OK with I...
by viking
Tue Jun 21, 2016 5:58 pm
Forum: iMacros for Firefox
Topic: Double Modifiers in Event Mode?
Replies: 8
Views: 5635

Re: Double Modifiers in Event Mode?

Hi Tom, Any way that the developer can look into improving the Keystroke simulation with the EVENT mode? It would be very useful for many applications. As I mentioned, the "Automate" software works great to open "Fastest Search" and many other keystroke simulations, but not everyone has "Automate", ...
by viking
Sun Jun 19, 2016 9:07 pm
Forum: General Support & Discussions
Topic: Unable to create a simple login script. Please HELP
Replies: 8
Views: 3692

Re: Unable to create a simple login script. Please HELP

@chivracq, What did you mean by 'FRAME NAME="*actionFrame*" It is commented out, so I don't think it would work? Maybe the new script worked because you changed from Frame F=3 to Frame F=2 (I have similar issue where Frame F=4 or Frame F=5. I solved it crudely by SET !ERRORIGNORE YES SET !TIMEOUT_ST...
by viking
Sat Jun 18, 2016 8:49 am
Forum: iMacros for Firefox
Topic: Double Modifiers in Event Mode?
Replies: 8
Views: 5635

Re: Double Modifiers in Event Mode?

I tried EVENT TYPE=KEYPRESS SELECTOR=* Char="k" MODIFIERS="[ctrl,shift]" and it works (opened the developer tools) Not sure why EVENT TYPE=KEYPRESS SELECTOR=* Char="f" MODIFIERS="[ctrl,shift]" doesn't work for the Fastest Search addon. I tried another automation tool "Automate" (http://www.networkau...
by viking
Fri Jun 17, 2016 7:18 pm
Forum: iMacros for Firefox
Topic: ctrl-v in EVENT Mode Doesn't Work
Replies: 6
Views: 4227

Re: ctrl-v in EVENT Mode Doesn't Work

'Both following Statements work: 'EVENTS TYPE=KEYPRESS SELECTOR="#gsr" CHARS="fv" MODIFIERS="ctrl" EVENTS TYPE=KEYPRESS SELECTOR=* CHARS="fv" MODIFIERS="ctrl" Great! Didn't think abot doing the f and v at the same time! (This doesn't work on the Google search field though) Where did you get #gsr fr...
by viking
Fri Jun 17, 2016 6:01 pm
Forum: iMacros for Firefox
Topic: Double Modifiers in Event Mode?
Replies: 8
Views: 5635

Re: Double Modifiers in Event Mode?

The following works fine in FF v47 (iMacros 8.9.7, OS WIN7-64bit): EVENT TYPE=KEYPRESS SELECTOR=* Char="f" MODIFIERS="ctrl" (it opens the search box) How do I specify double modifiers, e.g. ctrl-shift-f ? I tried: EVENT TYPE=KEYPRESS SELECTOR=* Char="f" MODIFIERS="ctrl,shift" and EVENT TYPE=KEYPRES...