Firefox private mode problem

Discussions and Tech Support specific to the iMacros Firefox add-on.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
honzakrizek
Posts: 7
Joined: Fri Nov 06, 2020 6:51 pm

Firefox private mode problem

Post by honzakrizek » Wed Jun 15, 2022 2:44 pm

Hello,


I need imacros to run in private mode only. When trying latest imacros(10.1.0.1485) I am getting error "Due to restrictions in Firefox Private Browsing, iMacros for Firefox is disabled in this mode."
I have been using firefox portable 54.0 and imacros 8.9.7 (build 8970419), that works fine in private mode, but some websites doesn't work in old firefox version, that is why I am trying to use newer firefox version

Is there any workaround for this?

windows 7 64bit, English
imacros build 10.1.0.1485
browser Firefox portable 92.0
chivracq
Posts: 10134
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Firefox private mode problem

Post by chivracq » Wed Jun 15, 2022 3:15 pm

honzakrizek wrote:
Wed Jun 15, 2022 2:44 pm
Hello,


I need imacros to run in private mode only. When trying latest imacros(10.1.0.1485) I am getting error "Due to restrictions in Firefox Private Browsing, iMacros for Firefox is disabled in this mode."
I have been using firefox portable 54.0 and imacros 8.9.7 (build 8970419), that works fine in private mode, but some websites doesn't work in old firefox version, that is why I am trying to use newer firefox version

Is there any workaround for this?

Code: Select all

windows 7 64bit, English
imacros build 10.1.0.1485
browser Firefox portable 92.0

Thread moved to the 'iMacros for FF' Sub-Forum... :!:

'Free' / 'PE' / 'Trial' is missing from your FCI... :shock:

Well, using FF100 Portable (+ iMacros for FF v10.1.0 'Free' + Win10_Pro), I have the following Setting in 'about:addons' for the iMacros Addon, for the "Details" Tab: :idea:
Run in Private Windows
Allow <-> Don’t Allow
When allowed, the extension will have access to your online activities while private browsing. Learn more
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE'/'Trial').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
honzakrizek
Posts: 7
Joined: Fri Nov 06, 2020 6:51 pm

Re: Firefox private mode problem

Post by honzakrizek » Wed Jun 15, 2022 3:28 pm

Apologies, Free I think, I downloaded from addons and did nothing else.

I have the same selected - Allow, but in the Options tab I see the error and I cannot see any scripts to run anyway. Are you able to run any script if your Firefox portable in private mode?
picture.JPG
error
chivracq
Posts: 10134
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Firefox private mode problem

Post by chivracq » Wed Jun 15, 2022 3:57 pm

honzakrizek wrote:
Wed Jun 15, 2022 3:28 pm
Apologies, Free I think, I downloaded from addons and did nothing else.

I have the same selected - Allow, but in the Options tab I see the error and I cannot see any scripts to run anyway. Are you able to run any script if your Firefox portable in private mode?

picture.JPG

Hum, you're right, I get the exact same "Private Browsing" Red Box on the "Options" Tab, like you, while "Allow" is and remains selected on the "Details" Tab, and trying to click on the iMacros Icon (or clicking on some other already open Browser Tab) changes the Colour of the iMacros Icon into some light/disabled Blue, and nothing happens...

Then I don't know, I tried to have a look at some "about:config" Settings (+ "private" / "extension" / "addon" / "incognito" / etc...) but I didn't see any "relevant" Setting(s) that could help...

But hum, the Release Notes for v10.0.2 for FF already mentioned:
"iMacros for Firefox is disabled in Private Browsing mode due to restrictions in Firefox"
=> I guess it's a known Limitation... :(

Try maybe to see on the Mozilla Forum if other Addons are also "impacted" and if there is maybe some Hack/Workaround to manage to bypass that Limitation... :idea:

And hum..., maybe elaborate why you need the 'Private Mode', it merely clears your Cookies + History when closing the ('Private') Window, can't you use the iMacros `CLEAR` Command to achieve the same Result...? :idea:
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE'/'Trial').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
honzakrizek
Posts: 7
Joined: Fri Nov 06, 2020 6:51 pm

Re: Firefox private mode problem

Post by honzakrizek » Wed Jun 15, 2022 7:46 pm

I am getting the disabled blue icon when I click it. I tried as well search about:config page but no luck there. I even tried to load temporary addon imcaros 8.9.7. from file just to see if it helps, but that does not work (error: "does not contain a valid manifest"). I guess it is not compatible.

I have seen the release notes where it is mentioned, but could not find it anywhere else. I guess that not many people use imacros with private browsing

Tried few random extensions, they worked, but they dont have the Options tab where it says it is disabled. I think it is imacros issue, not firefox issue

Didnt know there was such command, I will probably try it with CLEAR if I cant solve this, but I would prefer private browsing

A bit sad that there is not more detailed error about the restrictions for private mode
Post Reply