I found a bug?

Discussions and Tech Support specific to the iMacros Firefox add-on.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Loginbug
Posts: 9
Joined: Tue Feb 02, 2010 7:36 pm

I found a bug?

Post by Loginbug » Fri Nov 12, 2010 11:54 am

Code: Select all

TAG POS=1 TYPE=TD ATTR=class:topic EXTRACT=HTM
SAVEAS TYPE=EXTRACT FOLDER=* FILE={{!VAR1}}.htm
I have extracted the html from a page, then i have saved the extracted code in a .htm file. In the output file the " char is always repeated twice.Example:
<img src=""http://
target=""_blank""
<td style=""border:
:? :? :?
Tom, Tech Support
Posts: 3678
Joined: Mon May 31, 2010 4:59 pm

Re: I found a bug?

Post by Tom, Tech Support » Mon Nov 22, 2010 5:34 pm

Hi Loginbug,

This is because the SAVEAS TYPE=EXTRACT command saves the results in CSV format, and embedded quotes are double-quoted:

http://wiki.imacros.net/csv

Note: When doing this with the iMacros Browser or iMacros for IE, the embedded quotes are not double-quoted if you are only saving one extracted value (i.e. you only use EXTRACT= once prior to a SAVEAS TYPE=EXTRACT command and you reset the internal extraction buffer by using SET !EXTRACT NULL after the save command).
Regards,

Tom, iMacros Support
Post Reply