imacros V7.4.0.1 is only for Firefox 4.0 - 8?

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
bumusic
Posts: 36
Joined: Sun Nov 08, 2009 9:59 pm

imacros V7.4.0.1 is only for Firefox 4.0 - 8?

Post by bumusic » Fri Sep 30, 2011 3:23 am

just knew that imacros V7.4.0.1 is only for Firefox 4.0 - 8

is it possible to run it on Firefox 3.XX?
the reason is that my other add-on cant implement under FF4
bumusic
Posts: 36
Joined: Sun Nov 08, 2009 9:59 pm

Re: imacros V7.4.0.1 is only for Firefox 4.0 - 8?

Post by bumusic » Sat Oct 01, 2011 4:04 am

just installed Compatibility Reporter add-on and now all our old add-on are available
https://addons.mozilla.org/en-US/firefox/addon/15003/

thanks
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Re: imacros V7.4.0.1 is only for Firefox 4.0 - 8?

Post by Tech Support » Sat Oct 01, 2011 9:02 pm

Officially we only support 4-8, but as you said, it might still work for 3. We just don't test with Firefox 3 anymore.

Currently we recommend Firefox 7. It is very fast => ideal for web automation :)
bumusic
Posts: 36
Joined: Sun Nov 08, 2009 9:59 pm

Re: imacros V7.4.0.1 is only for Firefox 4.0 - 8?

Post by bumusic » Mon Oct 03, 2011 6:23 am

the reason why im using 3 becoz there is several addons dont work any more with FF7
i need time to find the replacement

everything is fine. eval works!
http://wiki.imacros.net/EVAL
but where can i get more EVAL code? i mean more sample code

but Compatibility Reporter add-on will be a good alternative for this pivotal transition period
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Re: imacros V7.4.0.1 is only for Firefox 4.0 - 8?

Post by Tech Support » Mon Oct 03, 2011 11:54 am

Here is another EVAL demo macro. It works in both, iMacros V7.5 Beta and iMacros for Firefox V7.4 and later.

Code: Select all

URL GOTO=http://www.iopus.com/imacros/demo/v7/eval.htm
'Wait a random number (1 to 5) of seconds
SET !VAR1 EVAL("Math.floor(Math.random()*5 + 1);")
WAIT SECONDS={{!VAR1}}
SET !EXTRACT_TEST_POPUP NO
'Extract the date
TAG POS=1 TYPE=B ATTR=TXT:* EXTRACT=TXT
'Check if time deviates more than 20 hours. If yes, stop macro with an error
SET !VAR2 EVAL("var h=20; var s=\"{{!EXTRACT}}\"; var today=new Date(); var postAge=today.getTime()-Date.parse(s); var hInMilli=h*60*60*1000; if(postAge>hInMilli){MacroError(\"Time deviates more than 20 hours\");}else null")
'Clean the !EXTRACT variable for the next task
SET !EXTRACT NULL
'Extract the number in the input box
TAG POS=1 TYPE=INPUT:TEXT FORM=ID:form1 ATTR=NAME:textfield EXTRACT=TXT
'Check if extracted number (still a string, has to be parsed into a float!) lies between 99 and 101. 
'Stop macro with an error if not.
SET !VAR2 EVAL("var s=\"{{!EXTRACT}}\"; var d = parseFloat(s); if((d>99)&&(d<101))d; else MacroError(\"Value is not in the set range\");")
Post Reply