imacros shows duplicate lines and then not save #Current.iim

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
tgandy
Posts: 14
Joined: Wed Nov 04, 2009 8:59 am

imacros shows duplicate lines and then not save #Current.iim

Post by tgandy » Mon Oct 01, 2012 1:07 pm

Hi,
Windows 7/imacaos 7.5.0.4/FF 15.0.1

I been using the simple scripting of imacros record and play for a while. Useful for repetitive tasks in browsers.

Recently, I record a macro, all OK.
Then record a second, it seems OK until I press Stop (sometime it needs two presses to get it to Stop?). then I find the #Current.iim file is the previous version. If I've delete #Current.iim it is not re-created on the second record.

If I record again, it records three duplicate steps for each click, see below.

VERSION BUILD=7500718 RECORDER=FX
TAB T=1
TAB CLOSEALLOTHERS
URL GOTO=https://transguard.fsifmhosting.com/Evo ... Items.aspx
TAG POS=1 TYPE=SPAN ATTR=TXT:TG056532
TAG POS=1 TYPE=SPAN ATTR=TXT:TG056532
TAG POS=1 TYPE=SPAN ATTR=TXT:TG056532

Can't figure how to stop it happening.
* Restart FF
* Remove iMacros addin (Restart) - reinstall iMacros
* Empty Cashe, etc.

Then sometime after a start, it'll work OK for one recording. Then back to duplicate lines for subsequent recording.

It's only started happening yesterday, so any suggestions are appreciated. I'm 99% sure no changes have been made to my system.

Andy
Tom, Tech Support
Posts: 3513
Joined: Mon May 31, 2010 4:59 pm

Re: imacros shows duplicate lines and then not save #Current

Post by Tom, Tech Support » Mon Oct 08, 2012 3:27 pm

Hi Andy,

Updates regarding this issue will be posted on this thread. Thanks for reporting it!
Regards,

Tom, iMacros Support
Post Reply