iMacro auto stop from playing,

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
tech40
Posts: 17
Joined: Sun Sep 30, 2012 11:12 am

iMacro auto stop from playing,

Post by tech40 » Tue Oct 08, 2013 6:35 am

Good Day Guys, I made a script, and at first it works well without any problem, but after few minutes this is what happened
Image
imacro is still running but not working, and stock up with secs25 after few couple minutes while running this script
I tried to merge it to wait secs 50, but still stock on secs 50, after few couple minutes while running this script

i hope can someone help me.


here's the script

Code: Select all

SET !ERRORIGNORE YES
ONDIALOG POS=1 BUTTON=OK CONTENT=
ONDIALOG POS=2 BUTTON=OK CONTENT=
ONDIALOG POS=3 BUTTON=OK CONTENT=
SET !TIMEOUT_STEP 10
SET !TIMEOUT_PAGE 10
'SET !TIMEOUT_TAG 10
SET !LOOP -99999
TAB T=1
URL GOTO=##
SET !TIMEOUT_STEP 10
SET !TIMEOUT_PAGE 10
WAIT SECONDS = 1
TAG POS=1 TYPE=A ATTR=TXT:View<SP>Sites
TAG POS=1 TYPE=INPUT:BUTTON FORM=NAME:form* ATTR=VALUE:*
WAIT SECONDS = 1
FRAME F=0
TAG POS=1 TYPE=A ATTR=TXT:Continue
WAIT SECONDS = 25
WAIT SECONDS = 25
TAB T=1
TAB CLOSEALLOTHERS
FRAME F=0
TAG POS=1 TYPE=INPUT:BUTTON FORM=NAME:form* ATTR=VALUE:*
WAIT SECONDS = 1
FRAME F=0
TAG POS=1 TYPE=A ATTR=TXT:Continue
WAIT SECONDS = 25
WAIT SECONDS = 25
TAB T=1
TAB CLOSEALLOTHERS


SET !TIMEOUT_STEP 10
SET !TIMEOUT_PAGE 10
WAIT SECONDS = 1
TAG POS=1 TYPE=A ATTR=TXT:Regular<SP>Sites
TAG POS=1 TYPE=INPUT:BUTTON FORM=NAME:form* ATTR=VALUE:*
WAIT SECONDS = 1
FRAME F=0
TAG POS=1 TYPE=A ATTR=TXT:Continue
WAIT SECONDS = 45
TAB T=1
TAB CLOSEALLOTHERS
FRAME F=0
TAG POS=1 TYPE=INPUT:BUTTON FORM=NAME:form* ATTR=VALUE:*
WAIT SECONDS = 1
FRAME F=0
TAG POS=1 TYPE=A ATTR=TXT:Continue<SP>to<SP>Website
WAIT SECONDS = 45
TAB T=1
TAB CLOSEALLOTHERS
tech40
Posts: 17
Joined: Sun Sep 30, 2012 11:12 am

Re: iMacro auto stop from playing,

Post by tech40 » Thu Oct 10, 2013 10:03 am

still having a problem, please someone can help me to fix this problem, I also tried to make it imacro run slow, but still same problem..
siniy
Posts: 118
Joined: Sat Nov 07, 2009 7:44 pm

Re: iMacro auto stop from playing,

Post by siniy » Thu Oct 10, 2013 12:46 pm

I had imacros stuck on complex websites. What helped me was to open an empty tab and waiting there. Then return to my tab.
So whenever you use WAIT command. Try instead of

Code: Select all

WAIT SECONDS=10
this, open empty tab, wait your time on this empty tab, then return to you first tab

Code: Select all

TAB OPEN
TAB T=2
WAIT SECONDS=10
TAB CLOSE
tech40
Posts: 17
Joined: Sun Sep 30, 2012 11:12 am

Re: iMacro auto stop from playing,

Post by tech40 » Sat Oct 19, 2013 11:08 am

Thank you, now it works, but I have another problem, I try to make another imacro, but I encountered a problem
Image
imacro pause by running and there's a message on the upper of my I macro.
Post Reply