Download built-in videos w/ ONDOWNLOAD + Flashgot, error804

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
astrojoe777
Posts: 1
Joined: Wed Dec 25, 2013 2:05 pm

Download built-in videos w/ ONDOWNLOAD + Flashgot, error804

Post by astrojoe777 » Wed Dec 25, 2013 4:17 pm

What I'm trying to do is automate the process of downloading built-in videos from a webpage that are in a playlist. By built-in I mean that that there is no designated download link for these videos - they are loaded by webpage and I use another Firefox extension called Flashgot to download this video. Here is my macro code. If something looks inexplicable it's because this is the first macro I'm making and I'm very likely doing something wrong.

VERSION BUILD=8601111 RECORDER=FX
TAB T=1
URL GOTO=http://www.lynda.com/Ableton-Live-tutor ... 600-2.html
TAG POS=1 TYPE=A ATTR=HREF:javascript:void(0);
WAIT SECONDS=15
ONDOWNLOAD FOLDER=* FILE=+_{{!NOW:yyyymmdd_hhnnss}} WAIT=YES
TAG POS=1 TYPE=DIV ATTR=ID:qa-dt-s1
WAIT SECONDS=3
TAG POS=1 TYPE=SPAN ATTR=TXT:next

So you can see I'm going to a webpage from lynda, then "TAG POS=1 TYPE=A ATTR=HREF:javascript:void(0);" is me clicking the play button so that the video loads which lets me download through Flashgot. I have to "WAIT SECONDS=15" to make sure the video has loaded so that is in fact available for download. "ONDOWNLOAD FOLDER=* FILE=+_{{!NOW:yyyymmdd_hhnnss}} WAIT=YES \ TAG POS=1 TYPE=DIV ATTR=ID:qa-dt-s1" is what is generated from me using Flashgot to download the video. "qa-dt-s1" is the ID of the div containing the video. Then I "WAIT SECONDS=3" because I read something about allowing some time for the download to work. "TAG POS=1 TYPE=SPAN ATTR=TXT:next" is me pressing the next button in the playlist to go to the next video.

Now, everything works up until the downloading. It stalls out on "TAG POS=1 TYPE=DIV ATTR=ID:qa-dt-s1" and then displays "RuntimeError: ONDOWNLOAD command was used but no download occurred. (Error code: -804)".


Has anyone done anything like this before? Any tips? It's frustrating, I can't see why this is happening and the cause of everyone else who gets Error code 804 seems to be entirely different from mine.



Other misc info about my setup: using Firefox 26.0, on OSX Mavericks 10.9 (but this wasn't working when I had 10.8 either). If you've made it down this far, thanks for reading, appreciate the help.



P.S. I also tried recreating this same setup for video playlists on other websites (I tried Youtube) and I got the exact same result.
User avatar
bobis
Posts: 364
Joined: Sat Sep 11, 2010 3:34 pm
Contact:

Re: Download built-in videos w/ ONDOWNLOAD + Flashgot, error

Post by bobis » Fri Dec 27, 2013 7:00 am

ignore errors with:

Code: Select all

SET !ERRORIGNORE YES
you do not need to use ondownload as it waits for browser download and fail in your case, because you use external plugin/software for download, remember that imacros can not interact with other plugins in your browser.
Get Best iMacros scripts at http://imacrosbot.com/
Post Reply