[V9B1] 9.0 beta 1 issues

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
lanx
Posts: 38
Joined: Sat Jul 03, 2010 2:11 am

[V9B1] 9.0 beta 1 issues

Post by lanx » Sun Nov 08, 2015 4:30 pm

Hi guys,

just here to report some terrible issues encountered since using 9.0 beta 1 version.

(1) NO MACRO SELF-EXECUTION
I have many macros that loop indefinitey by calling themselves with URL GOTO command, and they've all worked till I have updated to this beta version.
Now I get the following error message:
Component returned failure code: 0x805e0006 [nsIWebNavigation.loadURIWithOptions] (Error code: -1001)

(2) NO FILE SAVE
Trying to save a text with the following command

Code: Select all

SAVEAS TYPE=EXTRACT FOLDER={{!COL2}} FILE=textfile.csv
currently breaks macro execution with the following errore message:
expected absolute paths are prohibited for security reason as parameter (Error code: -911)

(3) INTERFERING TAB HOTKEY
Keyboard TAB key is used by almost everyone to move across form fields, but now it seems to be assigned to hide/show iMacros in Firefox sidebar which obviously interferes with user's manual form filling.
It would be great if you'll add customizable hotkeys for this purpose and, most of all, to stop/play/pause macro execution.
[EDIT] After further testing, it seems that many other key-combos are colliding with iMacros: even a simple CTRL+C turns on/off iMacros sidebar.

(4) NO BUTTONS IN HIDDEN MODE
While running macros in hidden mode, the floating iMacros panel doesn't have stop/play/pause buttons anymore.
[EDIT] It seems to be somewhat solved for me by reverting to 8.9.4 and then updating to 9.0 beta 1 once again.


(5) NO WAY TO DISABLE SCROLLING TO OBJECT
"Scroll to object when found" option seems to be currently ineffective because the browser scrolls up and down to each found element, despite of this option being checked or not.
Shital, Tech Support
Posts: 54
Joined: Tue May 07, 2013 9:42 am

Re: 9.0 beta 1 issues

Post by Shital, Tech Support » Mon Nov 09, 2015 8:52 am

Hi Lanx,

Thank you for trying our Beta version. Could you please provide us with more details on the issues that you have encountered, for example, can you share the macro you are trying ?

Regards,
Shital, iMacros Tech Support
lanx
Posts: 38
Joined: Sat Jul 03, 2010 2:11 am

Re: 9.0 beta 1 issues

Post by lanx » Tue Dec 01, 2015 11:09 am

Whoa... I have provided simple, plain and self-explanatory details nearly one monthe ago and you haven't even tried to do a single, quick countercheck?? :roll:

It shouldn't be that difficult to do, since you'll encounter those issues with very simple operations that won't require particular scripting skill. :?

(1) NO MACRO SELF-EXECUTION
Is it that complex to put these two lines in a text editor?

Code: Select all

WAIT SECONDS=5
URL GOTO=imacros://run/?m=Loop.iim
(2) NO FILE SAVE
Trying to save a text with the following command

Code: Select all

SAVEAS TYPE=EXTRACT FOLDER={{!COL2}} FILE=textfile.csv
What else should I say if iMacros 8.9.4 and previous versions have always processed this command with no error at all??

(3) INTERFERING TAB HOTKEY
Same here... what kind of "more details" should I provide?
Simply install iMacros 9.0 beta1 on a clean Firefox profile, hit the TAB keyboard key or CTRL+C and see what happens.

(5) NO WAY TO DISABLE SCROLLING TO OBJECT
And again... I have said "Scroll to object when found" option seems to be currently ineffective because the browser scrolls up and down to each found element, despite of this option being checked or not.
There's no magic scripting code in my own macros that would make any difference.

Currently using Firefox 42.0 x64 stable on a clean, fresh new profile: hope this would help to locate and solve these issues before next release.
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

[V9B1] Re: 9.0 beta 1 issues

Post by Tech Support » Wed Dec 30, 2015 10:02 am

Thanks a lot for the feedback and sorry for the delay. But you can expect a Beta 2 release early next year.

Meanwhile, did any other V9 issues surface? Version 9 is a major rewrite of both iMacros and Firefox (keyword: e10s), so we plan for a longer beta period.
lanx
Posts: 38
Joined: Sat Jul 03, 2010 2:11 am

Re: [V9B1] 9.0 beta 1 issues

Post by lanx » Thu Dec 31, 2015 3:00 pm

Hi, glad to know there is a forthcoming beta2 with various improvements and bugfixes.

Unfortunately I didn't have the opportunity to dig and investigate for further issues because the existing ones are currently preventing me to work with minor side effects.

As soon as you will post a fresh new beta, I'll take care to start again deep daily testing.
Post Reply