FYI: What To Do if the Page "Takes Forever" to Load

Discussions and Tech Support specific to the iMacros Firefox add-on.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
viking
Posts: 243
Joined: Sun Mar 16, 2008 7:22 am

FYI: What To Do if the Page "Takes Forever" to Load

Post by viking » Sun Jul 03, 2016 8:32 pm

FYI:
I have a site that I am looping but the pages takes "forever" to load (> 2 min). The page appears to be fully loaded after a few seconds but in the statusbar, I see that it is still trying to connect to "mysterious" URLs. This means that iMacros can't continue until the whole page is loaded.

My solutions was to set the page timeout to 1 second and the step/tag timeout to 60 sec. In this way, iMacros only waits until it sees the Tag before it continues
(if you don't have a TAG to look for, you can always insert a dummy one based on the page).

The code that I added (on top of the scripts was):

Code: Select all

SET !ERRORIGNORE YES
SET !TIMEOUT_PAGE 1
SET !TIMEOUT_STEP 60
Now, instead of the script taking 20-30 min to run, it takes less than 2 min :)
Post Reply