<br> keeps showing up for no reason

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
PBNSurprise
Posts: 15
Joined: Sun Jun 19, 2016 12:10 am

<br> keeps showing up for no reason

Post by PBNSurprise » Mon Jul 04, 2016 8:43 pm

I'm using this code to post comments on a website

Code: Select all

SET div3 HTML>BODY>DIV:nth-of-type(3)>DIV>DIV>DIV>DIV:nth-of-type(2)>DIV>DIV>UL>LI>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV:nth-of-type(3)>DIV>
SET div2 HTML>BODY>DIV:nth-of-type(3)>DIV>DIV>DIV>DIV:nth-of-type(2)>DIV>DIV>UL>LI>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV>
SET !ERRORIGNORE YES
SET !TIMEOUT_STEP 0

EVENT TYPE=CLICK SELECTOR="{{div3}}DIV" BUTTON=0
EVENTS TYPE=KEYPRESS SELECTOR="{{div3}}DIV" CHARS="Comment"
EVENT TYPE=CLICK SELECTOR="{{div3}}BUTTON" BUTTON=0
EVENT TYPE=CLICK SELECTOR="{{div2}}DIV" BUTTON=0
EVENTS TYPE=KEYPRESS SELECTOR="{{div2}}DIV" CHARS="Comment"
EVENT TYPE=CLICK SELECTOR="{{div2}}BUTTON" BUTTON=0
WAIT SECONDS=60
After the comment is written and submitted though it shows up with <br> written at the end of it. Why is this and how do I get rid of this? Thanks
chivracq
Posts: 8628
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: <br> keeps showing up for no reason

Post by chivracq » Tue May 22, 2018 10:22 pm

PBNSurprise wrote:I'm using this code to post comments on a website

Code: Select all

SET div3 HTML>BODY>DIV:nth-of-type(3)>DIV>DIV>DIV>DIV:nth-of-type(2)>DIV>DIV>UL>LI>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV:nth-of-type(3)>DIV>
SET div2 HTML>BODY>DIV:nth-of-type(3)>DIV>DIV>DIV>DIV:nth-of-type(2)>DIV>DIV>UL>LI>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV:nth-of-type(2)>DIV>
SET !ERRORIGNORE YES
SET !TIMEOUT_STEP 0

EVENT TYPE=CLICK SELECTOR="{{div3}}DIV" BUTTON=0
EVENTS TYPE=KEYPRESS SELECTOR="{{div3}}DIV" CHARS="Comment"
EVENT TYPE=CLICK SELECTOR="{{div3}}BUTTON" BUTTON=0
EVENT TYPE=CLICK SELECTOR="{{div2}}DIV" BUTTON=0
EVENTS TYPE=KEYPRESS SELECTOR="{{div2}}DIV" CHARS="Comment"
EVENT TYPE=CLICK SELECTOR="{{div2}}BUTTON" BUTTON=0
WAIT SECONDS=60
After the comment is written and submitted though it shows up with <br> written at the end of it. Why is this and how do I get rid of this? Thanks
:wink:
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
PBNSurprise
Posts: 15
Joined: Sun Jun 19, 2016 12:10 am

Re: <br> keeps showing up for no reason

Post by PBNSurprise » Wed May 23, 2018 12:25 am

i honestly don't think i ever solved this issue. i think i just gave up. i can't remember
Post Reply