Beyond Firefox 57 version: XPI container is obsolete

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
juanato
Posts: 22
Joined: Sun Sep 25, 2011 4:11 pm

Beyond Firefox 57 version: XPI container is obsolete

Post by juanato » Tue Oct 24, 2017 7:06 pm

The new frontier of internal XPCOM functional API from Firefox cannot use the current XPI container ADDON.

The last version supported may be the 57 version of FirefoxThe new API is called WebExtensions:

https://developer.mozilla.org/en-US/Add ... fox_add-on

Its possible the new version of iMacros 4 Firefox under 10.x compliants the new API ?
Post Reply