WAIT SECONDS command aborted after pressing F8

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
jonastio
Posts: 9
Joined: Wed Mar 14, 2007 4:43 pm

WAIT SECONDS command aborted after pressing F8

Post by jonastio » Wed Mar 14, 2007 8:00 pm

I set up a quick script to rotate between a few system monitoring pages. Really basic:

VERSION BUILD=5200814
TAB T=1
URL GOTO=http://notnecessary.com/
WAIT SECONDS=30
rinse-repeat

I've tested this under firefox 1.5.0 and firefox 2.0..0.2
Both using iMacros 0.6.0.4
I am running Centos 4.4

When I run the script and hit F8, the sidebar goes away, and after waiting for a couple of minutes, nothing happens. I'll hit F8 again, the Play button will be greyed out, while the Pause and STOP buttons are active, though the script is no longer being processed. I've found this to still be true if I start the script and double-tap F8, script paused though it still thinks it's running. Is iMacros not supposed to run while minimized?
jonastio
Posts: 9
Joined: Wed Mar 14, 2007 4:43 pm

Post by jonastio » Thu Mar 15, 2007 1:59 pm

I've tried this with iMacros 0.6.0.6 as well, using 2 different machines running firefox 2.0.0.2.
One box running Centos 4.4, the other running Fedora Core 6
Both systems exhibiting the same problem(?).
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Thu Mar 15, 2007 8:44 pm

I confirmed the issue. It will be fixed ASAP. Thank you for reporting it!
jonastio
Posts: 9
Joined: Wed Mar 14, 2007 4:43 pm

Post by jonastio » Thu Mar 15, 2007 8:53 pm

No prob. It's a pretty slick little system.
Post Reply