Automatic Update Preference - about:config

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Lantus
Posts: 3
Joined: Tue Jan 19, 2016 5:40 pm

Automatic Update Preference - about:config

Post by Lantus » Fri May 04, 2018 4:53 pm

Hi,
My code - javascript - works perfectly on iMacros 8.8.1.1
So I want the code to set iMacros Auto-Update preference to OFF.

I already have a piece of code, to set some of the preferences of about:config

Code: Select all

"use strict";
var prefs = Components.classes["@mozilla.org/preferences-service;1"].getService(Components.interfaces.nsIPrefBranch);
prefs.setBoolPref("extensions.imacros.showjs", false);
But searching for iMacros in about:config, I can't find what preference is related to the auto-update.

Any hint?

Using PaleMoon 25.0.0, imacros 8.8.1.1
chivracq
Posts: 8199
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Automatic Update Preference - about:config

Post by chivracq » Fri May 04, 2018 6:10 pm

Lantus wrote:Hi,
My code - javascript - works perfectly on iMacros 8.8.1.1
So I want the code to set iMacros Auto-Update preference to OFF.

I already have a piece of code, to set some of the preferences of about:config

Code: Select all

"use strict";
var prefs = Components.classes["@mozilla.org/preferences-service;1"].getService(Components.interfaces.nsIPrefBranch);
prefs.setBoolPref("extensions.imacros.showjs", false);
But searching for iMacros in about:config, I can't find what preference is related to the auto-update.

Any hint?

Using

Code: Select all

PaleMoon 25.0.0, imacros 8.8.1.1
Hum, you could use v8.8.2 for FF (like me...!), or even v8.8.7, on PM25.

But, hum, nope you can't change the Auto-Update for FF from the 'about:config', all "imacros" Settings there are set by the Add-on itself, it would be "dangerous" if an Add-on could overwrite your Choices, I think those Settings (for each Add-on) are kept at some "higher" Level in one of the 'sqllite' FF/PM Core Modules.

Your "Solution" about 'showjs' is a bit cumbersome btw, you can set it directly at the beginning of your '.js' Script with:

Code: Select all

//imacros-js:showsteps yes/no
... as a Comment at the Top of your Script, ah-ah...!
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
thecoder2012
Posts: 248
Joined: Sat Aug 15, 2015 5:14 pm
Location: Internet
Contact:

Re: Automatic Update Preference - about:config

Post by thecoder2012 » Sat May 05, 2018 6:31 am

chivracq wrote:But, hum, nope you can't change the Auto-Update for FF from the 'about:config', all "imacros" Settings there are set by the Add-on itself, it would be "dangerous" if an Add-on could overwrite your Choices, I think those Settings (for each Add-on) are kept at some "higher" Level in one of the 'sqllite' FF/PM Core Modules.
In the future with FF57+, maybe. :mrgreen:

Global solution for all addons:

Code: Select all

var prefs = Components.classes["@mozilla.org/preferences-service;1"].getService(Components.interfaces.nsIPrefBranch);
prefs.setBoolPref("app.update.enabled", false);
prefs.setBoolPref("browser.search.update", false);
prefs.setBoolPref("extensions.update.enabled", false);
Addons with enough rights can install and uninstall XPI files but no auto-update choice (on/off). It's really crazy. :shock:
New (FF57+): WebExtensions/API/management] but required permissions
Old (FF30+): Add-on_Manager, Code Samples
Very old (with auto-update on/off, FF3+ but not higher than 29): preventing-firefox-from-updating-specific-extensions and Updating_extensions#Disabling_update_checks_for_individual_add-ons_-_Advanced_users

But the very old way is not longer possible in FF30+. I have checked MR Tech Toolkit (about:addons => uninstall because menu was broken) but not longer possible in Waterfox v55 in my tests.
chivracq wrote:I think those Settings (for each Add-on) are kept at some "higher" Level in one of the 'sqllite' FF/PM Core Modules.
Yes but I think it's possible in the old FF/PM. Addon SQLite Manager for Firefox. More security with FF 57+.
Last edited by thecoder2012 on Sun May 06, 2018 12:48 am, edited 1 time in total.
Join 9kw.eu Captcha Service now and let your iMacros continue downloads and scripts while you sleep. - Custom iMacros? Contact me!
chivracq
Posts: 8199
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Automatic Update Preference - about:config

Post by chivracq » Sat May 05, 2018 10:09 am

thecoder2012 wrote:
chivracq wrote:But, hum, nope you can't change the Auto-Update for FF from the 'about:config', all "imacros" Settings there are set by the Add-on itself, it would be "dangerous" if an Add-on could overwrite your Choices, I think those Settings (for each Add-on) are kept at some "higher" Level in one of the 'sqllite' FF/PM Core Modules.
In the future with FF57+, maybe. :mrgreen:

Global solution for all addons:

Code: Select all

prefs.setBoolPref("app.update.enabled", false);
prefs.setBoolPref("browser.search.update", false);
prefs.setBoolPref("extensions.update.enabled", false);
Addons with enough rights can install and uninstall XPI files but no auto-update choice (on/off). It's really crazy. :shock:
New (FF57+): WebExtensions/API/management] but required permissions
Old (FF30+): Add-on_Manager, Code Samples
Very old (with auto-update on/off, FF3+ but not higher than 29): preventing-firefox-from-updating-specific-extensions and Updating_extensions#Disabling_update_checks_for_individual_add-ons_-_Advanced_users

But the very old way is not longer possible in FF30+. I have checked MR Tech Toolkit (about:addons => uninstall because menu was broken) but not longer possible in Waterfox v55 in my tests.
chivracq wrote:I think those Settings (for each Add-on) are kept at some "higher" Level in one of the 'sqllite' FF/PM Core Modules.
Yes but I think it's possible in the old FF/PM. Addon SQLite Manager for Firefox. More security with FF 57+.
Oh..., interesting all the Links, Thanks...

About the 'SQLite Manager' Add-on, yep, I will try it, oops, need to restart PM, ah-ah..., will have to wait a little bit..., even if I'm always a bit "suspicious" when sbd can't speak English on one full Page, ah-ah...!

And hum, completely suspicious again about "More security with FF 57+.", ah-ah...!, my Experience is "More Security" = "Less Control for User" and usually + "Spying and Logging and Sending to some Web-Server (for "Security", just to "check", yeah...!, fuck it...!)" and Bugs and sbd will find a way to break through, and no way for the User to counter anything...!
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
thecoder2012
Posts: 248
Joined: Sat Aug 15, 2015 5:14 pm
Location: Internet
Contact:

Re: Automatic Update Preference - about:config

Post by thecoder2012 » Sat May 05, 2018 12:25 pm

chivracq wrote:About the 'SQLite Manager' Add-on, yep, I will try it, oops, need to restart PM, ah-ah..., will have to wait a little bit...,
SQLite Manager is useless in this case. But useful is JSONView + Elegant JSON Editor
I have found the option in the file extensions.json (set applyBackgroundUpdates to 0) in my profile directory. But browser restart is required with file extensions.json

Example code in Javascript for iMacros:

Code: Select all

const {classes: Cc, interfaces: Ci, utils: Cu} = Components;
Cu.import("resource://gre/modules/osfile.jsm");
Cu.import("resource://gre/modules/Services.jsm");

var mydata = "";
var myfile = OS.Path.join(OS.Constants.Path.profileDir,'extensions.json');
OS.File.read(myfile).then(function(data) {
	mydata = (new Services.appShell.hiddenDOMWindow.TextDecoder()).decode(data);
});
iimPlayCode("WAIT SECONDS=2");

var objJSON = JSON.parse(mydata);
for (var i = 0, len = objJSON['addons'].length; i < len; ++i) {
	if(JSON.stringify(objJSON['addons'][i]['defaultLocale']['name']) == "\"iMacros for Firefox\""){
		objJSON['addons'][i]['applyBackgroundUpdates'] = 0;
		break;
	}
}
OS.File.writeAtomic(myfile,(new Services.appShell.hiddenDOMWindow.TextEncoder()).encode(JSON.stringify(objJSON))).then({});
//Browser restart
//Cc['@mozilla.org/toolkit/app-startup;1'].getService(Ci.nsIAppStartup).quit(Ci.nsIAppStartup.eAttemptQuit | Ci.nsIAppStartup.eRestart);
Tested with iMacros 8.9.7, Win8.1 and Waterfox 55
chivracq wrote:And hum, completely suspicious again about "More security with FF 57+.", ah-ah...!, my Experience is "More Security" = "Less Control for User" and usually + "Spying and Logging and Sending to some Web-Server (for "Security", just to "check", yeah...!, fuck it...!)" and Bugs and sbd will find a way to break through, and no way for the User to counter anything...!
Yes but FF is open source. You can make your own "chivracqfox"! :lol:
Join 9kw.eu Captcha Service now and let your iMacros continue downloads and scripts while you sleep. - Custom iMacros? Contact me!
Post Reply