how to use JavaScript(.js) and start with .iim

Discussions and Tech Support specific to the iMacros Firefox add-on.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
evanx
Posts: 3
Joined: Wed May 30, 2018 4:21 am

how to use JavaScript(.js) and start with .iim

Post by evanx » Wed May 30, 2018 9:13 am

how to use JavaScript(.js) and start with .iim

Hello,

I used to using .iim via javascript,
but this beta version (imacros_for_firefox_b-10.0.2a1396-an+fx) seems not support. :|

and i need to start with some script use command as follows :

start "" D:\firefoxinstallpath\Firefox.exe "imacros://run/?m=/Common/IssueTracker.iim"

but not work. :|
chivracq
Posts: 9588
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: how to use JavaScript(.js) and start with .iim

Post by chivracq » Wed May 30, 2018 9:52 am

evanx wrote:how to use JavaScript(.js) and start with .iim

Hello,

I used to using .iim via javascript,
but this

Code: Select all

beta version (imacros_for_firefox_b-10.0.2a1396-an+fx)
seems not support. :|

and i need to start with some script use command as follows :

Code: Select all

start "" D:\firefoxinstallpath\Firefox.exe   "imacros://run/?m=/Common/IssueTracker.iim"

but not work. :|
Yeah..., but take it easy a bit with the Forum...!, this is already the 4th Duplicate you open now about the same Report, I already had to delete/disapprove 2 Duplicates... :wink:
Your Post/Report in the "iMacros for FF v10.b Beta-Testing" Thread was the correct place...

It's OK to open a "parallel" Thread (as the Beta-Testing Thread is already a bit "busy") if you want to be able to follow up (only) on your specific Issue and hope for some Workaround, but you could have posted a Link to your original Report in the Beta-Testing Thread... (OK, I've done it for you...)

+ You should mention your exact FCI... (Read my Sig...)
=> iMacros for FF v10.0.2b, FF57/58/59/60...?, OS=Win...?

But I think the Syntax you are trying to use was already not supported anymore in v9.0.3 for FF..., and only (still) works in v8.9.7 for FF (which still works on FF55/56)... (I might be wrong though, about v9.0.3, as it maybe still works when used from a '.BAT' File like you do...)

:arrow: v10b for FF is only in "early" Beta-Testing for the moment anyway... :idea:
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
Post Reply