BUTTON was not found

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
in2fire
Posts: 1
Joined: Wed Mar 13, 2019 5:20 pm

BUTTON was not found

Post by in2fire » Wed Mar 13, 2019 5:52 pm

Hello
I've an account on pornhub.com
I need to add new friends one by one.
I'm trying to add new friend on page:

VERSION BUILD=10021450
URL GOTO=https://www.pornhub.com/user/search?onl ... 1=0&age2=0
TAG SELECTOR="#advanceSearchResultsWrapper>UL>LI>DIV>A>DIV>DIV>DIV:nth-of-type(2)>DIV>BUTTON"
TAG SELECTOR="#advanceSearchResultsWrapper>UL>LI:nth-of-type(2)>DIV>A>DIV>DIV>DIV:nth-of-type(2)>DIV>BUTTON"
TAG SELECTOR="#advanceSearchResultsWrapper>UL>LI:nth-of-type(3)>DIV>A>DIV>DIV>DIV:nth-of-type(2)>DIV>BUTTON"
TAG SELECTOR="#preventClick"


And i get an error:
RuntimeError: element specified by #advanceSearchResultsWrapper>UL>LI>DIV>A>DIV>DIV>DIV:nth-of-type(2)>DIV>BUTTON was not found, line: 3

Why am i geting this error? Maybe it's because i need to put mouse on user's avatar to show this button?
Post Reply