Unecessarily slow scripts??

Discussions and Tech Support specific to the iMacros Firefox add-on.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
zabby
Posts: 3
Joined: Sat May 12, 2007 3:27 am

Unecessarily slow scripts??

Post by zabby » Sat May 12, 2007 4:05 am

I wrote a script to rip text off a *locally* stored internal website, and, I know this sounds picky, but it takes FIVE seconds to parse a fully loaded page? The CPU doesn't seem to max out, what's the deal?

It's only a couple extracts... I assign them to variables and post them in a form concatenated... nothing fancy.

It sounds insignificant, but it's 5 seconds times something I have to do around 400 times a day. That's half an hour a day! :-(
User avatar
Tech Support
Posts: 4947
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Tue May 15, 2007 11:03 am

Hi,

Thanks for the feedback. We are constantly looking to improve the iMacros product, so understanding how people are using it and what limitations they are encountering helps a lot.

One feature we have added to improve the macro execution time is the introduction of the filter command. http://wiki.imacros.net/FILTER Currently this only works with images, but it improves page loading times and reduces the page content.

Daniel Kerr
iOpus Support
User avatar
Tech Support
Posts: 4947
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Tue May 15, 2007 10:44 pm

Also, can you please email a sample html page for testing to support1 @ iopus.com ?

Thanks.
zabby
Posts: 3
Joined: Sat May 12, 2007 3:27 am

Post by zabby » Thu May 24, 2007 5:28 pm

Hi, I did try the filter command, doesn't seem to make too much of a difference.

I will email you a sample page, thanks.
Post Reply