macro for registration on email

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
faustf
Posts: 5
Joined: Fri Sep 20, 2019 2:03 pm

macro for registration on email

Post by faustf » Mon Sep 23, 2019 12:51 pm

hi guy i wan create a macro for register me fast , and my client in mail.com , but the script work but is like not write nothing , because when arrive at end for click button , appear all in red also if is filled

Code: Select all

VERSION BUILD=12.0.501.6698
TAB T=1
TAB CLOSEALLOTHERS
'SET !PLAYBACKDELAY 0.00
URL GOTO=https://signup.mail.com/?edition=int&lang=en#.2859408-header-signup2-1
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:check-email-availability-email-input CONTENT=casimirotevisan543
TAG POS=1 TYPE=LABEL ATTR=TXT:Mr
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:first-name-input CONTENT=casimiro
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:last-name-input CONTENT=trevisan
TAG POS=1 TYPE=SELECT ATTR=DATA-TEST:country-input CONTENT=%IT
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:month CONTENT=12
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:day CONTENT=13
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:year CONTENT=1977
TAG POS=1 TYPE=INPUT:PASSWORD ATTR=ID:password
SET !ENCRYPTION NO
TAG POS=1 TYPE=INPUT:PASSWORD ATTR=ID:password CONTENT=Kronos123@
TAG POS=1 TYPE=INPUT:PASSWORD ATTR=ID:confirm-password CONTENT=Kronos123@
TAG POS=1 TYPE=LABEL ATTR=TXT:By<SP>email
TAG POS=1 TYPE=INPUT:CHECKBOX ATTR=NAME:contact-email-checkbox CONTENT=YES
TAG POS=1 TYPE=LABEL ATTR=TXT:By<SP>SMS<SP>(recommended)
TAG POS=1 TYPE=INPUT:EMAIL ATTR=ID:contactEmail CONTENT=casimiro@yopmail.com
chivracq
Posts: 8716
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: macro for registration on email

Post by chivracq » Mon Sep 23, 2019 1:34 pm

faustf wrote:
Mon Sep 23, 2019 12:51 pm
hi guy i wan create a macro for register me fast , and my client in mail.com , but the script work but is like not write nothing , because when arrive at end for click button , appear all in red also if is filled

Code: Select all

VERSION BUILD=12.0.501.6698
TAB T=1
TAB CLOSEALLOTHERS
'SET !PLAYBACKDELAY 0.00
URL GOTO=https://signup.mail.com/?edition=int&lang=en#.2859408-header-signup2-1
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:check-email-availability-email-input CONTENT=casimirotevisan543
TAG POS=1 TYPE=LABEL ATTR=TXT:Mr
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:first-name-input CONTENT=casimiro
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:last-name-input CONTENT=trevisan
TAG POS=1 TYPE=SELECT ATTR=DATA-TEST:country-input CONTENT=%IT
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:month CONTENT=12
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:day CONTENT=13
TAG POS=1 TYPE=INPUT:TEXT ATTR=DATA-TEST:year CONTENT=1977
TAG POS=1 TYPE=INPUT:PASSWORD ATTR=ID:password
SET !ENCRYPTION NO
TAG POS=1 TYPE=INPUT:PASSWORD ATTR=ID:password CONTENT=Kronos123@
TAG POS=1 TYPE=INPUT:PASSWORD ATTR=ID:confirm-password CONTENT=Kronos123@
TAG POS=1 TYPE=LABEL ATTR=TXT:By<SP>email
TAG POS=1 TYPE=INPUT:CHECKBOX ATTR=NAME:contact-email-checkbox CONTENT=YES
TAG POS=1 TYPE=LABEL ATTR=TXT:By<SP>SMS<SP>(recommended)
TAG POS=1 TYPE=INPUT:EMAIL ATTR=ID:contactEmail CONTENT=casimiro@yopmail.com

Any chance you could start using the Forum "a bit correctly"...? :roll:
(Even if the "Quality" of this Thread is already a bit better than your previous/first Thread... Hum..., my "Fault" also, I approved it a bit in a hurry and a bit by "Guilt" after being Offline for 2 days...)

=> Open your Threads in the "correct" Sub-Forum each time, instead of "randomly" selecting the 'iMacros for FF' Sub-Forum twice...! :roll:
The 'iMacros for FF' Sub-Forum is meant for Threads/Cases that are specific to FF only, which can't be the case if you don't even mention your FCI, and v12.0 visible from the Script in this Thread is not even an iMacros for FF Version...! Grrrr...! :x
(Correct Sub-Forum for both Threads would have been the 'General' Sub-Forum... Hum, or the 'Data Extraction' Sub-Forum actually for your first Thread... But the 'General' Sub-Forum is always the "correct" one if you are unsure... But no need to duplicate now... (The Forum Admin can move your Threads if "needed"...))

=> + Read the Forum Rules for what Info to include in your OP when you open a Thread...! :roll:
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
faustf
Posts: 5
Joined: Fri Sep 20, 2019 2:03 pm

Re: macro for registration on email

Post by faustf » Mon Sep 23, 2019 3:55 pm

sorry i will use max attention next time
chivracq
Posts: 8716
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: macro for registration on email

Post by chivracq » Mon Sep 23, 2019 4:48 pm

faustf wrote:
Mon Sep 23, 2019 3:55 pm
sorry i will use max attention next time

Beeeeeh..., not only "next time", but for your 2 existing Threads also...! :roll:
Your first one is a bit of a "Joke" for a Technical Forum, I don't even know what "Newubbo" of whatever means, and is full of Typos... :shock:

You can still edit all your previous Posts on this Forum 8) , to still improve the Quality of your OP's (Opening Posts) in both Threads..., to meet the "Quality Criteria" mentioned in my Sig + in the Forum Rules... :idea:

Quality Criteria:
- "Correct" Sub-Forum. :!: (OK, this one is "only" for "next time", don't open any Duplicates...)
- Descriptive Thread Title. :!:
- FCI mentioned (preferably at the complete Top of your OP), + mention also 'Free'/'PE'/'Trial' if using any of the v10.0.x Versions for CR/FF or the v12.x Versions for iMB/IE. :!:
- "All" relevant Info with Script, URL, etc..., and what you've tried... :!:
- And if you include any Screenshot(s), upload those directly to the Forum rather than using some external Pix Hosting Site. :!:

+ "Neat" Follow-up on all Threads. :!: (Only part you are doing "correctly" for the moment... :D )
+ Sharing your Solution / Final Script to finish all Threads "correctly" and "useful" for other Users... :!:

(And all those Criteria also apply if you open a parallel Thread on some other Tech Forum, like 'SOF' ('Stackoverflow') for example... Perfectly fine to open parallel Threads on different Tech Forums, but you'll have to maintain the same "Quality" for all of them... :!: )
- (F)CI(M) = (Full) Config Info (Missing): iMacros + Browser + OS (+ all 3 Versions + 'Free'/'PE').
- I don't even read the Qt if that (required) Info is not mentioned...!
- Script & URL help a lot for more "educated" Help...
Post Reply