Bug with .js files - simple code cannot locate script to run

Discussions and Tech Support specific to the iMacros Firefox add-on.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
StarFaller
Posts: 13
Joined: Sat Jan 20, 2007 9:03 am

Bug with .js files - simple code cannot locate script to run

Post by StarFaller » Sun Jun 17, 2007 11:17 am

Code: Select all

i = iimPlay("D:\MyStuff\Data and Configs\iMacros\Personal\generic header")
if (i < 0) {
s = iimGetLastError();
s = "Error: " + iimGetLastError();
alert (s);
};

hi, i have this simple code.
it is saved in a file, in the root directory of the imacros folder, as i specified in the options of iMacros.
the header file is a simple iim, that activates image filtering and popup message.
when i run the code above i get a "macros not found" error message.

I did manage to get it to work, if i place the file in the same folder as the java script, but that was a hit or miss business, and of omitting the path part of the script name.

i also tried with "//" same result, it will not run it.

the demo scripts work just fine btw, so i'm not sure what is the exact problem.

btw...there also seems to be an issue, after you edit a file name in the imacros folder, you need to refresh imacros macro list so it take the new filenames into account.
User avatar
Tech Support
Posts: 4947
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Wed Jun 20, 2007 10:44 pm

Just to clarify, the macro name in this example is "generic header"?
Post Reply