what am I doing wrong? simple .CSV stuff

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
addiktion
Posts: 29
Joined: Thu Mar 01, 2007 10:07 am

what am I doing wrong? simple .CSV stuff

Post by addiktion » Thu Aug 16, 2007 7:31 am

Ok I'm trying to read some information from a .CSV file. I've put the test.csv file in the C:\Documents and Settings\Yessir\Application Data\iMacros\Datasources location.

I've also put this in the macro.

VERSION BUILD=6000707 RECORDER=FX
TAB T=1
SET !ERRORIGNORE YES
URL GOTO=http://www.mydomain.com
CMDLINE !DATASOURCE test.csv
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:WizardForm ATTR=NAME:root_Image_I0_Text_String CONTENT={{firstname!LOOP}} - {{lastname!LOOP}}

All it does is input the {{firstname!LOOP}} - {{lastname!LOOP}} into the text box. I need it to extract the data from the CSV file and input those names in there instead.

What am I doing wrong??
addiktion
Posts: 29
Joined: Thu Mar 01, 2007 10:07 am

Post by addiktion » Thu Aug 16, 2007 7:49 am

Nevermind I was using an outdated set of code on the wiki. The newly updated one in the firefox demos is working just fine.

Thanks!
Post Reply