A Bug?

Discussions and Tech Support specific to the iMacros Firefox add-on.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Posts: 29
Joined: Thu Mar 01, 2007 10:07 am

A Bug?

Post by addiktion » Mon Oct 15, 2007 4:12 am

I was wondering if any of you have noticed this bug as well.

Basically I have a macro set up to do an event after so many wait seconds. Basically I'll browse and do other things but once it hits 1000 seconds it automatically kicks in and does its thing. The problem I noticed is it wasn't being very consistent and thats when I noticed the wait seconds was going twice as fast and counting down by 2's instead of one second at a time.
1000.. 998... 996 every second. I've tried to recreate the problem but it only happens once in awhile. Sometimes it will consistently count normally and other rare times it will count down 2 seconds for every second thus throwing off the timer. I know I'm not crazy lol so I was wondering if anyone had any input on how to fix this or what to avoid that may cause this.
User avatar
Tech Support
Posts: 4947
Joined: Tue Sep 20, 2005 7:25 pm

Post by Tech Support » Mon Oct 15, 2007 12:46 pm

Hi, we are not able to recreate this issue here. But if somebody else notices such a problem please let us know.

As an alternative, you can use the Windows Task Scheduler (or its Linux/Mac equivalents) and the command-line.
Posts: 1
Joined: Wed Dec 12, 2007 1:18 am

Post by pym » Wed Dec 12, 2007 1:25 am

I have an issue that's maybe connected to this one. I'm using iOpus for Firefox on Windows XP. Between step n and step n+2 my script waits several seconds. It worked fine for two weeks now, but since yesterday it doesn't wait anymore. I didn't change any options, but i've updated the version (which happens automatically), the code stayed the same. does anyone have an idea, how to fix this. does it depend on the update?
Posts: 1
Joined: Wed Jan 02, 2008 5:01 pm

Post by senretsu » Wed Jan 02, 2008 5:09 pm

I'm having the exact same problem as addiktion is. There's nothing to say that he hasn't already mentioned, except that I'm running XP pro 32-bit on an intel core2 duo e6750.
User avatar
Tech Support
Posts: 4947
Joined: Tue Sep 20, 2005 7:25 pm

Post by Tech Support » Thu Jan 03, 2008 12:23 am

Just to clarify. You mean this macro does not work for you?

Code: Select all

URL GOTO=http://forum.imacros.net/
URL GOTO=http://wiki.imacros.net
Posts: 7
Joined: Sun Feb 24, 2008 7:52 pm

Post by wHEEzAH » Sun Feb 24, 2008 9:29 pm

I have exactly the same problem when I "Pause" and then "Continue" a macro while it's in a WAIT command to skip the delay. It does not happen everytime though.
They do not want you to know it!
Post Reply