v6.0.6.3 beta - drop-down listbox not setting values

Discussions and Tech Support specific to the iMacros Firefox add-on.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
gimber_sj
Posts: 7
Joined: Fri Jun 06, 2008 9:10 am
Location: Bristol

v6.0.6.3 beta - drop-down listbox not setting values

Post by gimber_sj » Thu Jul 24, 2008 10:00 am

Hi,

I've given the new v6.0.6.3 beta a trial run (FF 2.0.0.16 FF 3.0.1, WinXP).

Some existing scripts which handle listboxes do not work any more.

On entry to the screen all is as expected, but when selecting values from the boxes, a blank entry is selected instead of the usual expected value.

The code to set two listboxes was recorded and played back on the same page:

Code: Select all

TAG POS=1 TYPE=SELECT FORM=NAME:Form1 ATTR=ID:MAINWALLTYPE CONTENT=$3
TAG POS=1 TYPE=SELECT FORM=NAME:Form1 ATTR=ID:MAINWALLINSUL CONTENT=$1
The underlying code for one of these .Net2 / aspx page controls is here:

Code: Select all

<select name="MAINWALLTYPE" id="MAINWALLTYPE" tabindex="1" style="background-color:LightYellow;width:201px;Z-INDEX: 113; LEFT: 424px; POSITION: absolute; TOP: 88px">
	<option selected="selected" value="-1">Please select....</option>
	<option value="1">Stone (granite or whinstone)</option>
	<option value="2">Stone (sandstone)</option>
	<option value="3">Solid brick</option>
	<option value="7">Cavity</option>
	<option value="9">Timber frame</option>
	<option value="10">System build (i.e. any other)</option>
</select>
Any ideas?

P.S. I know it's a beta!

John.
Post Reply