Feature Requests & Bug Fix Requests. ADD YOURS!

Discussions and Tech Support related to the iMacros Firefox Add-on, including the built-in Javascript scripting interface for playing .js files.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Mma87
Posts: 4
Joined: Sat Jan 15, 2011 12:52 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Mma87 » Wed Jan 09, 2013 11:30 am

I think there is a big problem in imacros for firefox.

If i start js it's impossible to stop it untill it finish, the only solution is to kill firefox.

best reguards,
Matteo
nevyn
Posts: 3
Joined: Thu Jan 10, 2013 11:13 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by nevyn » Thu Jan 10, 2013 11:40 pm

Bug fix Firefox 18

Bug with FF18, my image saving script crashes with error code:
NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [nsIWebBrowserPersist.saveURI], line: 12 (Error code: -1001)
Failing lines:
ONDOWNLOAD FOLDER=* FILE=* WAIT=YES
TAG POS=1 TYPE=IMG ATTR=HREF:http://*.jpg CONTENT=EVENT:SAVEPICTUREAS
(script is working ok in ff17 and older)

This error is also reproducable with one of the Demo files; Demo-SaveTargetAs.iim

Google gives this result from Bugzilla:

https://bugzilla.mozilla.org/show_bug.cgi?id=820522

It seems Mozilla has rewritten it's code adding an extra argument, and the addons involved needs to be updated to this?

Is there a solution or workaround for this error? Seems to me there must be a lot of iMacro users who are facing this problem.

Thanx Nevyn
Tom, Tech Support
Posts: 3513
Joined: Mon May 31, 2010 4:59 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Tom, Tech Support » Fri Jan 11, 2013 11:16 am

Mma87 wrote:I think there is a big problem in imacros for firefox.

If i start js it's impossible to stop it untill it finish, the only solution is to kill firefox.

best reguards,
Matteo
You need to check the return value of iimPlay in your .js scripts. If the users presses the Stop button, iimPlay will return -101. You can then test for this value and abort the rest of your .js script accordingly.

http://wiki.imacros.net/Error_and_Retur ... turn_Codes
Regards,

Tom, iMacros Support
Tom, Tech Support
Posts: 3513
Joined: Mon May 31, 2010 4:59 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Tom, Tech Support » Fri Jan 11, 2013 11:21 am

nevyn wrote:Bug fix Firefox 18

Bug with FF18, my image saving script crashes with error code:
NS_ERROR_XPC_NOT_ENOUGH_ARGS: Not enough arguments [nsIWebBrowserPersist.saveURI], line: 12 (Error code: -1001)
This issue has been logged and will be tracked on this thread.
Regards,

Tom, iMacros Support
Thais
Posts: 39
Joined: Mon Sep 24, 2012 7:33 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Thais » Mon Jan 21, 2013 6:26 pm

Hi Tom,

Thanks for the bug fixe.

I download the zip file, but how to install it ? and integrate it in FF
I hav FF18, mac 10.6.8 and fior the moment iMacros 7.6.0.2 as an extension ...

Thanks for your help

Thais
Mac Os : 10.13.3 (17D102)
Firefox : 48.0.2
iMacros for Firefox : 8.9.7
Tom, Tech Support
Posts: 3513
Joined: Mon May 31, 2010 4:59 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Tom, Tech Support » Wed Jan 23, 2013 9:01 am

Hi Thais,

To install, just unzip the file then drag-and-drop the .xpi file onto an open instance of Firefox.
Regards,

Tom, iMacros Support
Thais
Posts: 39
Joined: Mon Sep 24, 2012 7:33 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Thais » Wed Jan 23, 2013 5:19 pm

Hi Tom,

Thanks for your help, i perform to do it.
My problems comes from my unzip tools on my mac whoch generate a directory instead of a xpi file ....
Know, it works fine.

It seems to be another bug coming with this version.

location.href = "......";
execute from an iMacro js file seems not working .... since this new path ?
Do you have any information ?

Thais
Mac Os : 10.13.3 (17D102)
Firefox : 48.0.2
iMacros for Firefox : 8.9.7
Thais
Posts: 39
Joined: Mon Sep 24, 2012 7:33 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Thais » Wed Jan 23, 2013 5:20 pm

The error :

ReferenceError: location is not defined, line: 1 (Error code: 991)

Thais
Mac Os : 10.13.3 (17D102)
Firefox : 48.0.2
iMacros for Firefox : 8.9.7
qhuser
Posts: 4
Joined: Mon Jan 21, 2013 5:19 am

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by qhuser » Thu Jan 24, 2013 4:37 am

Hello,

I use the latest version of imacros for firefox.

When the tag does not exist, the delay time becomes negative and never moves to the next step. I have the code to ignore errors but imacros not ignore the error.

How can I resolve this situation?

Thank you!
Tom, Tech Support
Posts: 3513
Joined: Mon May 31, 2010 4:59 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Tom, Tech Support » Fri Jan 25, 2013 7:02 pm

Thais wrote:The error :

ReferenceError: location is not defined, line: 1 (Error code: 991)

Thais
You need to full qualify the reference as window.location now.
Regards,

Tom, iMacros Support
MeeSush
Posts: 19
Joined: Sat Jan 26, 2013 9:08 am

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by MeeSush » Sat Jan 26, 2013 9:20 am

Code: Select all

ONLOGIN USER=your-proxy-username PASSWORD=your-proxy-password retry=yes
RETRY IS NOT WORKING
its giving me error!!!
is this errorrr!!
Tom, Tech Support
Posts: 3513
Joined: Mon May 31, 2010 4:59 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Tom, Tech Support » Sun Jan 27, 2013 12:24 pm

qhuser wrote:Hello,

I use the latest version of imacros for firefox.

When the tag does not exist, the delay time becomes negative and never moves to the next step. I have the code to ignore errors but imacros not ignore the error.

How can I resolve this situation?

Thank you!
This has already been reported previously in this thread. Please do a search in the forums first before submitting issues. Thanks!

This issue has not yet been resolved.
Regards,

Tom, iMacros Support
Thais
Posts: 39
Joined: Mon Sep 24, 2012 7:33 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Thais » Sun Jan 27, 2013 5:58 pm

Hi Tom,

I confirm the windows.location works fine.

Thanks for your help

Thais
Mac Os : 10.13.3 (17D102)
Firefox : 48.0.2
iMacros for Firefox : 8.9.7
viking
Posts: 214
Joined: Sun Mar 16, 2008 7:22 am

Feature Request: Save as Firefox Bookmark in Folder with Tag

Post by viking » Mon Jan 28, 2013 1:29 am

Currently, if I save a macro as a Firefox Bookmark, it ends up at the bottom of the Bookmarks menu.
I then have to move it to the Firefox Bookmark Folder where I want it, and then add an appropriate Tag.

It would be great if the "Create an iMacros Bookmark" window could include an option to select the Bookmark Folder and also contain a Tag Field.

TIA!!!
Tom, Tech Support
Posts: 3513
Joined: Mon May 31, 2010 4:59 pm

Re: Feature Requests & Bug Fix Requests. ADD YOURS!

Post by Tom, Tech Support » Mon Jan 28, 2013 10:04 am

Thanks for the suggestion viking, I have added this to our feature request list.
Regards,

Tom, iMacros Support
Post Reply