Macro hadn't worked this time around.

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
LAPIII
Posts: 254
Joined: Tue Oct 07, 2008 7:24 pm

Macro hadn't worked this time around.

Post by LAPIII » Sat Jun 05, 2010 7:29 am

This macro to search Yahoo, Google, and MSN:

Code: Select all

VERSION BUILD=6600217 RECORDER=FX
PROMPT Enter<SP>search<SP>term !VAR1 Linux<SP>Virtualization
URL GOTO=http://www.yahoo.com/
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:sf1 ATTR=ID:p CONTENT={{!VAR1}}
TAG POS=1 TYPE=INPUT:SUBMIT FORM=NAME:sf1 ATTR=ID:searchsubmit&&VALUE:Web<SP>Search
TAB OPEN NEW
TAB T=2
URL GOTO=http://www.google.de/webhp?hl=en
TAG POS=1 TYPE=INPUT:TEXT FORM=NAME:f ATTR=NAME:q CONTENT={{!VAR1}}
TAG POS=1 TYPE=INPUT:SUBMIT FORM=NAME:f ATTR=NAME:btnG&&VALUE:Google<SP>Search
TAB OPEN NEW
TAB T=3
URL GOTO=http://www.msn.com/
TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:http://search.msn.com/results.aspx ATTR=ID:f1 CONTENT={{!VAR1}}
TAG POS=1 TYPE=INPUT:SUBMIT FORM=ACTION:http://search.msn.com/results.aspx ATTR=VALUE:Search<SP>Web      
Hadn't worked and gave me this error:

Code: Select all

RuntimeError: element P specified by TXT:*Results* was not found, line: 5
Tom, Tech Support
Posts: 3601
Joined: Mon May 31, 2010 4:59 pm

Re: Macro hadn't worked this time around.

Post by Tom, Tech Support » Tue Jun 22, 2010 11:35 am

Hello,

It could be that something changed in the HTML coding on yahoo for that button. Try re-recording the macro again for yahoo, or look at the HTML source for the page and manually correct your macro code.
Regards,

Tom, iMacros Support
Post Reply