iimplay("",FALSE) always starts a new brower?

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
mjohnson1857
Posts: 7
Joined: Thu Feb 01, 2007 7:00 am

iimplay("",FALSE) always starts a new brower?

Post by mjohnson1857 » Thu Feb 01, 2007 7:11 am

I thought the FALSE parameter should connect to the already open iMacro browser.

I am running from Microsoft Access visual basic. My form first opens a script that opens a browser and logs onto a real estate service. Then based on user input it is going to call various macros to retrieve data. Whenever I try to play a new macro from the form usiing iimInit("",FALSE) and then iimPlay(macroname) a new iMacro browser opens and my real estate service requires a new logon and password.

Sample code is as follows:

Private Sub test_Click()

Dim iim1 As Object
Dim iplay, iret As Integer
Dim data, sCmdLine As String

Set iim1 = CreateObject("InternetMacros.iim")
iret = iim1.iimInit(, False)
iplay = iim1.iimPlay("getParcelData")
data = iim1.iimGetLastExtract()

End Sub

What am I doing wrong?
whitertlnav
Posts: 43
Joined: Tue Mar 28, 2006 4:10 pm

Post by whitertlnav » Thu Feb 01, 2007 6:25 pm

It looks like you need to use 'iret' at the beginning of each line of code instead of 'iplay' or 'data', like this:

Set iim1 = CreateObject("InternetMacros.iim")
iret = iim1.iimInit(, False)
iret = iim1.iimPlay("getParcelData")
iret = iim1.iimGetLastExtract()

Hope this helps.
Post Reply