Issue when saving pages

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
satya
Posts: 5
Joined: Sat Sep 24, 2005 2:24 pm

Issue when saving pages

Post by satya » Sat Sep 24, 2005 2:41 pm

Hi,

Im using iopus scripting edition 4.3

On one particular site when my macro tries to save a webpage i get a dialog like in the gif below

Image

Which i presume is a dialog thats similar to what Internet Explorer displays

This happens irrespective of whether i use the SAVEAS type as TXT or HTM.

Any actions i perform on this dialog are not recorded by the macro.

How can i programatically supress this, or rather make the page save by default without displaying the dialog ever? ( im using VB6)

Question #2 How can i programatically set the USER AGENT to Internet explorer ( ie stealth mode)

Thanks
Guest

Post by Guest » Sat Sep 24, 2005 6:55 pm

1. If you check the "never ask again" box, the warning dialog will not display next time.

2. The USER AGENT can be set to "Internet Explorer" by going to
TOOLS > OPTIONS > Browser tab > Check "stealth mode". In this mode, the IIM browser identifies itself as Internet Explorer.
Guest

Post by Guest » Sat Sep 24, 2005 9:20 pm

Anonymous wrote:1. If you check the "never ask again" box, the warning dialog will not display next time.

2. The USER AGENT can be set to "Internet Explorer" by going to
TOOLS > OPTIONS > Browser tab > Check "stealth mode". In this mode, the IIM browser identifies itself as Internet Explorer.

I would like to achieve both programatically...without user intervention...

any ideas?

Thanks
satya
Posts: 5
Joined: Sat Sep 24, 2005 2:24 pm

Post by satya » Sun Sep 25, 2005 12:05 pm

Could someone from IOPUS tech support please answer my query

Thanks

Satya
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Sun Sep 25, 2005 7:41 pm

Hi, the answers given by guest are correct. Checking the box needs to be done only ONE time manually, after this everything works automatically.

Does this answer your question?
satya
Posts: 5
Joined: Sat Sep 24, 2005 2:24 pm

Post by satya » Sun Sep 25, 2005 9:36 pm

Tech Support wrote:Hi, the answers given by guest are correct. Checking the box needs to be done only ONE time manually, after this everything works automatically.

Does this answer your question?
Unfortunately it doesnt...

I'm trying to achieve both programatically as id be running IOPUS in the silent mode and the end user wont know that IOPUS is running in the background.

Is that dialog from the microsoft webbrowser control, that IOPUS uses internally, due to which this dialog cant be controlled programatically?

Ideally id like to be able to check the box and click yes on the dialog via a macro

Also id like to set the useragent programatically.. I had a look at the ini file the IOPUS uses and cant find any reference to it either.

Please let me know if both these or either can be achieved programatically as i wont be deploying the whole IOPUS setup and neither is the end user going to know that IOPUS is being used.

Thanks
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Mon Sep 26, 2005 1:31 pm

(1) If I understand you correctly checking the box does work - but you want to avoid this so the end-user does not have to do it?
Solution: IIM takes this setting from the IE settings, so you can check this box programmatically by writing to the approbriate IE registry entry.

(2) Solution: The User Agent option (as well as any other IIM setting) can be set programmatically by writing to the "iim.ini" file. If you are already a Scripting Edition user, you can request the complete installer source code from our tech support. Typically users that use IIM along with their own software include a predefined "iim.ini" file along with their setup.

Also, we offer a popular OEM package, that allows you to customize the software from "iOpus Internet Macros" to "YourCompany Internet Macros" and include your company logo in the software. Contact our tech support directly at http://www.iopus.com/service/support/ for a quote and more details.
satya
Posts: 5
Joined: Sat Sep 24, 2005 2:24 pm

Post by satya » Mon Sep 26, 2005 2:01 pm

Tech Support wrote:(1) If I understand you correctly checking the box does work - but you want to avoid this so the end-user does not have to do it?
Solution: IIM takes this setting from the IE settings, so you can check this box programmatically by writing to the approbriate IE registry entry.
Yes id like to programatically check this box so that the page gets saved by default and the user is not shown that dialog. I understand that when i manually check the box a flag must be written somewhere in the registry so that the dialog is not shown again.

So could you please let me know which key in the registry i need to modify, or perhaps a url that talks about this tweak.
Tech Support wrote: (2) Solution: The User Agent option (as well as any other IIM setting) can be set programmatically by writing to the "iim.ini" file.
Which section in the iim.ini file do i need to edit/ add to?

This is how it currently looks

Code: Select all


[iOpus]
IEhigth=508
IEwidth=538
CTRLhigth=8730
CTRLwidth=9438
T1Fast=10
ReplaySpeed=1
UserSpeed=1
DbgLog=0
Version=3710421
UsePopupManager=1
Addwait=0
Sys1=1
LicenseKey=---
WarnCookie=1
PathBasic=C:\Program Files\InternetMacros3
LastDS=Address1
StartUrl=http://www.iopus.com/iim/iim.htm?r=1&v=3710421
IDA=-1
GotoHomepage=1
DispPro1=1
UseMergeDefault=0
MaxLoop=3
IgnoreAllPopups=0
CSVcomma=,
DownloadFileTypes=EXE*ZIP*PDF*XLS*DOC*RTF*AVI*WAV*MP3*CSV
TPP=222
TSD=0
ErrorSound=0
ErrorSoundPath=\error.wav
ErrorExe=0
ErrorExePath=C:\WINNT\notepad.exe
ErrorMacro=0
ErrorMacroName=ErrorExampleMacro
TimeOut=60
InternetMacrosLogPath=C:\Program Files\InternetMacros3\InternetMacrosLog.txt
LogEvents=1
StoreKey=111
PathEditor=C:\WINNT\notepad.exe
PathDownload=C:\Program Files\InternetMacros3\Downloads\
PathDatasources=C:\Program Files\InternetMacros3\Datasources\
PathMacros=C:\Program Files\InternetMacros3\Macros\
Key=XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX
RecentUrls=
I dont seem to see any reference to the user agent.

Thanks

Satya
satya
Posts: 5
Joined: Sat Sep 24, 2005 2:24 pm

Post by satya » Wed Sep 28, 2005 2:07 pm

TechSupport.. could you please reply....

Thanks
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Wed Sep 28, 2005 4:24 pm

I checked with our developers and the User Agent option is just like the "This web page may not save correctly" dialog one of the few IIM settings that are not controlled by iim.ini but a special registry key.

The information on how to edit this entry is available to all registered users. Please contact me at support2 (at) iopus.com to discuss this in a private email. Thanks!
Guest

Post by Guest » Fri Sep 30, 2005 2:16 pm

Ive sent you both an email as well as a PM via the forum.
Could you please answer...

Thanks
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Fri Sep 30, 2005 4:00 pm

I replied to your email on 9/28:
Thanks for your email. Sorry, I can reveal this information only to registered users. But I can assure you that the problem can be solved by writing to the correct registry keys.

We offer a 30 day money back guarantee, so you can purchase the software absolutely risk free.
Ann
Post Reply