PAUSE in IE

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
who_me??
Posts: 12
Joined: Sat Feb 17, 2007 2:34 pm

PAUSE in IE

Post by who_me?? » Tue Apr 10, 2007 6:37 pm

I was using iMacros in Firefox, but due the problem that i cant use FireFox due macros is running i have switched on IE for running iMacros! But then problem jumped out!

I made new macro for IE!

While i run macro it happens that page dont load good (cos of slow internet connection) and then iMacros says "loadcheck" i was doing this manual in FF and when i load that page macro simply continue playing, but in IE it just stop there and count, there is no way to let it continue!

There is also another problem! When security code appears i used to pause macro, type code, get back on page where it stopped and just continue macro! But in IE it doesnt work! I cant even pause macro, on place where pause button should be there says "stopping..." :?

i need macro to run normal until until security code apears or till it have problem with loading page, then i have to pause it type code or reload page and then continue macro!


Is there any solution for my problem???

Thanks!
Hannes, Tech Support

Post by Hannes, Tech Support » Wed Apr 11, 2007 2:07 pm

Hello,

did you already try the PAUSE command?
(cf. http://www.iopus.com/imacros/help/cmd_pause.htm)

Hannes
who_me??
Posts: 12
Joined: Sat Feb 17, 2007 2:34 pm

Post by who_me?? » Wed Apr 11, 2007 11:26 pm

yes i tried with it! But problem is that i dont know when security code will jump out, i should set it that when error appear that pause macro!

On the side when i pause macro and continue it again in IE it get me back on login screen (this doesnt happen in FF)


Thanks
Hannes, Tech Support

Post by Hannes, Tech Support » Thu Apr 12, 2007 3:33 pm

First note that if the site does so much to prevent you from automating it, this is probably forbidden by the site's conditions of use. Please check this!

Now, with random elements, it is tricky. How about the following workarounds?

1) Increase the TAG timeout (http://www.iopus.com/imacros/help/var_timeout.htm). So if the page asks for the security code, i.e. the next TAG is not found immediately, you have more time to enter the code.

2) Add a "is the security popup there" check (cf. http://www.iopus.com/imacros/help/faq_s ... eyword.htm) between every two commands where the security code may be asked for.


Hannes
Post Reply