Nested loop personal edition

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information:CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
consiglio
Posts: 1
Joined: Thu Nov 22, 2018 5:19 pm

Nested loop personal edition

Post by consiglio » Thu Nov 22, 2018 5:25 pm

Hi!
Is there any way to make a nested loop in the personal edition?
I cannot afford to pay the enterprise edition. We are a University and we don't do this for business.
I started using imacros some years ago and there was a nice feature where I could run .js script from the extension, but it seems this is not available anymore.

Can you help?

Thanks,

Andrea
chivracq
Posts: 8140
Joined: Sat Apr 13, 2013 1:07 pm
Location: Amsterdam (NL)

Re: Nested loop personal edition

Post by chivracq » Thu Nov 22, 2018 6:14 pm

consiglio wrote:Hi!
Is there any way to make a nested loop in the personal edition?
I cannot afford to pay the enterprise edition. We are a University and we don't do this for business.
I started using imacros some years ago and there was a nice feature where I could run .js script from the extension, but it seems this is not available anymore.

Can you help?

Thanks,

Andrea
FCIM...! :mrgreen: (Read my Sig...)
=> 'PE' (= 'Personal Edition') is a bit vague, there are now 3 'PE' Versions, for IE/FF/CR...

But yep, completely possible to have Nested Loops in pure '.iim', search my Posts on "nested+loop(s)+eval+modulo" (+"pure+iim" maybe), and you should find some relevant Threads/Examples, I've posted several times a Solution, and other Advanced User @iimfun also using a different Syntax...

Or if you want to keep using '.js' Scripts, you need FF v55.0.3 + iMacros for FF v8.9.7 which is the FCI I use myself, or Pale Moon v27 + iMacros for FF v8.9.7 is also a possibility... :idea:
- (F)CIM = (Full) Config Info Missing: iMacros + Browser + OS with all 3 Versions...
- I usually don't even read the Question if that (required) Info is not mentioned...
- Script & URL usually help a lot for a more "educated" Help...
Post Reply