iMacros doesn't always run when called from Excel

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
danhinz
Posts: 22
Joined: Mon May 07, 2007 5:48 pm

iMacros doesn't always run when called from Excel

Post by danhinz » Thu Nov 29, 2007 4:39 pm

iMacros v6.01 bld 277
WinXP SP2
Excel 2007 (12.0.4518.1014)

I have a several macros that I've been using for many months (some created in v5.22). They all do the same thing for different websites. From inside Excel I run a macro that calls an iMacros macro that reads data from the spreadsheet and inputs it to a website. When the website responds it pulls the data and stores it in the same spreadsheet. It repeats this until it gets all the data.

iMacros runs with its window open on the screen.

My problem is this: sometimes (1 of ~7 to 10 times) iMacros macro does not start. The iMacros browser opens and instead of the called macro appearing on the upper left of the iMacros window, the list of available macros appears.

To fix the problem, I have to exit iMacros reset the excel macro and restart it. Most of the time this is sufficient at other times I have to exit excel and restart it too.

Any ideas on what to do? It seems to me as if excel is not sending the macro name or iMacros isn't receiving it.

Thanks in advance,
Dan
User avatar
Tech Support
Posts: 4947
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Sat Dec 01, 2007 1:17 am

Thanks for the report. We are investigating this ASAP.
Post Reply