!Loop function NOT running!

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
Adarkness
Posts: 2
Joined: Mon Dec 10, 2007 9:50 pm

!Loop function NOT running!

Post by Adarkness » Fri Dec 14, 2007 2:15 am

=================================================
Heres the code of mine...
=================================================

VERSION BUILD=6011201 RECORDER=FX
TAB T=1
URL GOTO=http://www.gaiaonline.com/register/avatar/
PROMPT Input<SP>Desired<SP>Username<SP> !VAR1
PROMPT Input<SP>Desired<SP>Password<SP> !VAR2
SET !LOOP 123
TAG POS=1 TYPE=A ATTR=ID:next_gender&&TXT:>
TAG POS=1 TYPE=A ATTR=ID:next_outfit&&TXT:>
TAG POS=1 TYPE=A ATTR=ID:next_outfit&&TXT:>
TAG POS=1 TYPE=A ATTR=ID:next_outfit&&TXT:>
TAG POS=1 TYPE=A ATTR=ID:next_outfit&&TXT:>
TAG POS=1 TYPE=INPUT:IMAGE FORM=ACTION:/register/avatar/ ATTR=ID:continue
TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:/register/user/ ATTR=ID:username CONTENT={{!VAR1}}{{!LOOP}}
TAG POS=1 TYPE=INPUT:TEXT FORM=ACTION:/register/user/ ATTR=ID:email CONTENT={{!VAR1}}@mail.misterpinball.de
SET !ENCRYPTION NO
TAG POS=1 TYPE=INPUT:PASSWORD FORM=ACTION:/register/user/ ATTR=ID:password CONTENT={{!VAR2}}
TAG POS=1 TYPE=INPUT:PASSWORD FORM=ACTION:/register/user/ ATTR=ID:password_confirm CONTENT={{!VAR2}}
TAG POS=1 TYPE=SELECT FORM=ACTION:/register/user/ ATTR=ID:dob_month CONTENT=$10
TAG POS=1 TYPE=SELECT FORM=ACTION:/register/user/ ATTR=NAME:dob_day CONTENT=$31
TAG POS=1 TYPE=SELECT FORM=ACTION:/register/user/ ATTR=NAME:dob_year CONTENT=$1990
TAG POS=1 TYPE=INPUT:CHECKBOX FORM=ACTION:/register/user/ ATTR=ID:tos_agree&&VALUE: CONTENT=YES
TAG POS=1 TYPE=INPUT:IMAGE FORM=ACTION:/register/user/ ATTR=ID:continue
TAG POS=1 TYPE=A ATTR=ID:skip&&TXT:No,<SP>Thanks
WAIT SECONDS = 3
TAG POS=1 TYPE=A ATTR=TXT:Logout

================================================
When it is runn, the number in the loop function WONT INCREASE/CHANGE the number. What did I do wrong?
"BLARGH!!!"
User avatar
Tech Support
Posts: 4948
Joined: Tue Sep 20, 2005 7:25 pm
Contact:

Post by Tech Support » Sat Dec 15, 2007 12:29 am

Did you start the macro with the LOOP button instead of PLAY?
Adarkness
Posts: 2
Joined: Mon Dec 10, 2007 9:50 pm

Post by Adarkness » Sat Dec 15, 2007 11:01 pm

I started it with the LOOP button because a message would always pop up stating that in order for the !LOOP function to work, you need to click that button.
"BLARGH!!!"
my2testing
Posts: 21
Joined: Tue Oct 30, 2007 6:57 am
Contact:

Post by my2testing » Tue Jan 08, 2008 9:57 am

Play(Loop) Max:200

Max must Greater than 123.
You can rewrite your code,not use "CONTENT={{!VAR1}}{{!LOOP}}"
Post Reply