Page 1 of 1

Blogger Post Problem

Posted: Wed Feb 08, 2006 11:35 am
by msalperen
Hello, I've created this script to automatically post some information to my bloger pages. Everything seems correct till the level of inflating the content into the blogger form. It does not type the content "trial post" into the related form. I suppose that the problem maybe about the hidden form structture but I couldn't solve it. The macro code waits extremely
long time in this line:

URL GOTO=http://www.blogger.com/post-create.g?blogID=16266475

and finishes without filling the form in. Note: Extraction seems correct.

VERSION BUILD=5030127
TAB T=1
TAB CLOSEALLOTHERS
SIZE X=1004 Y=723
SET !VAR1 {{!EXTRACT}}
URL GOTO=en.wikipedia.org
TAG POS=1 TYPE=A ATTR=TXT:someattributionhere
TAG POS=1 TYPE=HTML ATTR=TXT:
EXTRACT POS=1 TYPE=HTM ATTR=<DIV<SP>id=bodyContent>*
URL GOTO=http://www.blogger.com/post-create.g?blogID=16266475
TAB T=1
FRAME F=1
WAIT SECONDS=#DOWNLOADCOMPLETE#
TAG POS=1 TYPE=INPUT:SUBMIT FORM=NAME:stuffform ATTR=NAME:htmlPostBody CONTENT=trial<SP>post
TAG POS=1 TYPE=INPUT:SUBMIT FORM=NAME:stuffform ATTR=NAME:publishPost&&VALUE:Publish<SP>Post

Thank you

Posted: Sat Feb 18, 2006 3:59 am
by smaxor
a good way to test things is just put that line of code in a macro and see what happens. Is it loading the page?

Try running just

TAB T=1
TAB CLOSEALLOTHERS
URL GOTO=http://www.blogger.com/post-create.g?blogID=16266475

and see what happens. Also, you might try deleteing your cookies and then don't auto login and build those login lines to your script.

John

Posted: Fri Apr 28, 2006 6:23 am
by redbrad0
I am having the exact same problem. My thought is there is some code running on bloggers back end that is keeping the page from thinking it has been loaded. did you ever figure this out? or is there a way you can make a page not wait for it to be loaded?

Re:

Posted: Thu Sep 17, 2009 2:18 pm
by Khing38
I'm also experiencing this problem. Where there is some code running on bloggers back end that is keeping the page from thinking it has been loaded. Is there a way you can make a page not waiting when it is loading?

________________
[URL=http://www.suite101.com/freelance_writing_jobs/]Freelance writing jobs[/URL]

Re: Blogger Post Problem

Posted: Fri Sep 18, 2009 7:48 am
by Hannes, Tech Support
You may set !TIMEOUT to a value smaller than the default 60 seconds and additionally use !ERRORIGNORE in order to make the macro ignore the timeout.

Re: Blogger Post Problem

Posted: Fri Sep 25, 2009 10:58 pm
by satishbhawra37
I suppose that the problem maybe about the hidden form structture but I couldn't solve it. The macro code waits extremely

Re: Blogger Post Problem

Posted: Mon Sep 28, 2009 6:44 am
by Hannes, Tech Support
How about the workaround mentioned above?

The following worked fine for me:

Code: Select all

VERSION BUILD=6600525     
TAB T=1     
TAB CLOSEALLOTHERS     
URL GOTO=<MY BLOG'S URL>
SET !TIMEOUT 2
SET !ERRORIGNORE YES
TAG POS=1 TYPE=A ATTR=TXT:New<SP>Post   
SET !ERRORIGNORE NO
SET !TIMEOUT 60

Re: Blogger Post Problem

Posted: Wed Sep 30, 2009 6:57 am
by Hannes, Tech Support
pankajnagarkoti74 wrote:The macro code waits extremely
long time in this line:
In what line?

Re: Blogger Post Problem

Posted: Tue Nov 27, 2018 5:34 pm
by techimac
anyone able to insert image?
when I click Add selected, it dont insert