Feature Request: Fine tuning of Replay Speed control

Support for iMacros. The iMacros software is the unique solution for automating every activity inside a web browser, for data extraction and web testing.
Forum rules
Before asking a question or reporting an issue:
1. Please review the list of FAQ's.
2. Use the search box (at the top of each forum page) to see if a similar problem or question has already been addressed.
3. Try searching the iMacros Wiki - it contains the complete iMacros reference as well as plenty of samples and tutorials.
4. We can respond much faster to your posts if you include the following information: CLICK HERE FOR IMPORTANT INFORMATION TO INCLUDE IN YOUR POST
Post Reply
zigner
Posts: 12
Joined: Fri Jan 15, 2010 2:47 pm

Feature Request: Fine tuning of Replay Speed control

Post by zigner » Fri Jan 15, 2010 2:56 pm

The number one issue I have with this great product is the limited replay speed choices, fast, medium, and slow.

I find that slow is too slow, and medium is much too fast. Couldn't you create an option that lets me specify either in the options panel, or in the imacros script itself some kind of more granular speed choice?

I'm guessing that your slow, medium, and fast, internally correspond to some numeric internal speed control variables in your code. Just let us directly specify it ourselves in the script (of course within an acceptable range). And/or, a slider bar would be a nice interface in the options for replay speed.
slamsal
Posts: 96
Joined: Fri Sep 12, 2008 4:39 pm

Re: Feature Request: Fine tuning of Replay Speed control

Post by slamsal » Fri Jan 15, 2010 9:09 pm

Please try inserting this command.

WAIT SECONDS=3
(It will wait 3 seconds)
You can even try
WAIT SECONDS=0.5
(It will wait half second)

If you need a custom macro, please feel free to contact me at sanjivlamsal@hotmail.com
Sanjiv Lamsal
iMacros Consultant
Duluth, MN USA
sanjivlamsal@hotmail.com
zigner
Posts: 12
Joined: Fri Jan 15, 2010 2:47 pm

Re: Feature Request: Fine tuning of Replay Speed control

Post by zigner » Sun Jan 17, 2010 6:34 am

Thanks, I am well aware of the wait statement.

My request is not for waiting for a particular part in the script. It is the entire script. My scripts are 100 lines plus. I need a speed somewhere between slow and medium for the entire imacro script.
Daniel, Tech Support
Posts: 1483
Joined: Tue Jan 26, 2010 11:35 am

Re: Feature Request: Fine tuning of Replay Speed control

Post by Daniel, Tech Support » Fri Feb 05, 2010 11:47 am

Hello,

Sorry for coming back to use so late!

Thank you for the suggestion! We will definitely consider it for future releases.

To other users who read this forum post: If you think you could use this feature as well, please "vote" for it by replying to this post. This helps us to get a feeling for the priority and popularity of this feature request.

Best regards,
Daniel, iOpus Support
americano528
Posts: 1
Joined: Wed Mar 24, 2010 6:04 pm

Re: Feature Request: Fine tuning of Replay Speed control

Post by americano528 » Wed Mar 24, 2010 6:08 pm

I registered for the sole purpose of voting on this! :-)
Daniel, Tech Support
Posts: 1483
Joined: Tue Jan 26, 2010 11:35 am

Re: Feature Request: Fine tuning of Replay Speed control

Post by Daniel, Tech Support » Fri Mar 26, 2010 8:17 pm

Thank you! :)
Daniel, iOpus Support
jgar
Posts: 1
Joined: Sun May 02, 2010 3:10 am

Re: Feature Request: Fine tuning of Replay Speed control

Post by jgar » Sun May 02, 2010 3:13 am

Yes, we need to be able to adjust the speed, i have a macro that needs to be between fast and medium. so i vote "YES"!

Also, i noticed that using the WAIT command causes the "802" timeout error to occur. this happned like 2 out of 7-9 attemps that i used the WAIT command to adjust the speed between the commands in one of the macros i use to check my hotmail account, but when i use the SET !REPLAYSPEED to medium i do not get the error, but medium is too slow, maybe you should include half seconds increments!

Thanks.
Daniel, Tech Support
Posts: 1483
Joined: Tue Jan 26, 2010 11:35 am

Re: Feature Request: Fine tuning of Replay Speed control

Post by Daniel, Tech Support » Tue May 18, 2010 6:50 pm

Thanks Jgar!

Actually the error shouldn't really occur. If it happens again, please let us know and post the macro where it happens, if possible.

Best regards,
Daniel, iOpus Support
danielgraber
Posts: 3
Joined: Tue Sep 21, 2010 6:22 pm

Re: Feature Request: Fine tuning of Replay Speed control

Post by danielgraber » Fri Oct 01, 2010 3:35 pm

I agree with the integer setting. However, the Version 7 I'm using seems to not go as fast as the v6.9 per line (that was lightning) but it seems that the V7 wants to display if the TAG line is found (not all the times it is).
Daniel, Tech Support
Posts: 1483
Joined: Tue Jan 26, 2010 11:35 am

Re: Feature Request: Fine tuning of Replay Speed control

Post by Daniel, Tech Support » Fri Oct 01, 2010 6:29 pm

Hello Daniel,

Could you please give us an example of a macro that worked faster in 6.9 and doesn't work as fast in 7? I didn't quite understand this phrase: "V7 wants to display if the TAG line is found (not all the times it is)".

It would be best if you could create a new topic on that, as this topic is related to a bit different issue, although also speed related :).

Thanks!
Daniel, iOpus Support
blackjack
Posts: 17
Joined: Sat Aug 14, 2010 12:53 am

Re: Feature Request: Fine tuning of Replay Speed control

Post by blackjack » Mon Apr 18, 2011 12:39 am

I have playing with SET !REPLAYSPEED values and it seems MEDIUM replays at 1 sec per step. The documentation I saw on the wiki stated MEDIUM should be 0.25 sec and SLOW should be 1 sec. Is there an error in the documentation or was the settings changed with the recent bug fix?
leadri
Posts: 1
Joined: Wed Jul 04, 2012 6:58 pm

Re: Feature Request: Fine tuning of Replay Speed control

Post by leadri » Wed Jul 04, 2012 7:00 pm

I registered for the sole purpose of voting on this!

Please do it. I agree with the integer setting
Post Reply